PDA

View Full Version : Thief 2 problems..Please help!!!



axell7
21st Feb 2008, 09:27
I've already tried to install thief 2 on my new computer athleast 20 times..and the error is repeating..:confused:..i know it is an old game but i want to play it so much..
I put the CD 1 in the drive..it runs setup but then it freezes on 100%. Than it disappears, and reapers after 10 min. like it's normal. After installation it asks for cd, i put CD 1 in drive it runs the game intro,screen goes black and then crashes with a note ''Thief 2: The Metal Age has encountered a problem and needs to close. We are sorry for the inconvenience.'' :mad2:
And that's it..I can't go further than that..

my system:
operating system: Microsoft Windows XP Professional (5.1, Build 2600)
processor:AMD Athlon (tm) 64 X2 Dual Core Processor 5000+, MMX, 3DNow (2 CPUs)
memory: 2048 MB RAM
DirectX Version: DirectX 9.0c
graphic card: NVIDIA GeForce 8500 GT
sound: Realtek HD Audio output

can anybody help me???please..

Peter_Smith
22nd Feb 2008, 03:16
Are you installing using the -lgntforce option (that's lower case L)? Failure to do that might explain the hang.

After you install, you need to make the EXE run on only one core. Do a search for "affinity" for details.

Then you need to uncomment the line "safe_texture_manager" in the file user.cfg by removing the semicolon from the front of the line.

There may be other things such as the need to register the codecs, but they will not cause a crash.

Be prepared for poor rendering of all dark textures using an Nvidia 8xxx card. There is a patch to fix it called DDFIX, but don't worry about that until you get it running.

Please post back and tell us what you did and where you stand after trying some of these things.

axell7
22nd Feb 2008, 17:41
First I want to thank you for replying..
I've :
-tried -lgntforce..doesn't work..setup was still delaying..
-installed the game
-uncommented the line "safe_texture_manager" in the file user.cfg by removing the semicolon from the front of the line = WORKS!!!
-entered the game
-(to be sure) set affinity= unchecked the CPU 0, left only CPU 1
-selected new game and I was set to go..but than sreen went black..and I could hear the sound like it is frozen,not progressing or changing,if you know what I mean..

what can I do about that? have any suggestion?

Peter_Smith
23rd Feb 2008, 05:21
It sounds like you are having a problem playing the movies. There are a couple of things with codecs. To verify that this is the problem, you might hit ESC as soon as you hit new game to see if it bypasses the introductory movies and puts you at the loadout screen. Not sure that will work in your case if it is crashing right away.

The first thing to try is the following at the command prompt:

regsvr32 "c:\your\path\to\thief\LGVID.AX"

If that does not work, you may try a different version of the codecs:

http://www.thief-thecircle.com/download.asp?fid=876

If that doesn't work, check here:
http://www.ttlg.com/forums/showthread.php?t=75031#freezingmovie

As a matter of fact, you might find all kinds of juicy things in that FAQ.

EDIT: now that setting affinity works, there is a permanent way.
http://www.thief-thecircle.com/guides/hyperthreading/

Make a backup of your original EXE before applying this patch.

Again, let us know what works and what doesn't and if you have any other problems.

axell7
24th Feb 2008, 07:25
in meantime,i tried to fix the game..so I've downloaded the patch from v1.07 to v1.18 and applied it,{edited for content, banned by TOU...}started the game, set CPU to 1 and it works now..
thanks anyway..:)