PDA

View Full Version : Thief 2 - spinning around



tomiathon
12th Jan 2008, 06:25
hola any old timers that might remember me!

well, after many years and a computer that ran thief 2 so poorly (and thief 3 not at all) that I never finished it, I finally have purchased a laptop, and decided to knock off the rust and go taffin' again. thought my machine, a new dell xps m1530, would run the games beautifully, but I'm having problems. specifically, when I load my saved game, it plops Garrett down and spins him around at a dizzying speed, and I can't move at all except to look up or down while Garrett threatens to vomit from nausea. the spinning will not stop (in fact it seems to get faster, though this may well be a function of my imagination). when I hit ESC, my mouse (or touchpad) will only travel the upper left quadrant of the screen, and I have to CTRL+ALT+DEL and close the game through the task manager. this has not occurred only when loading a save, however, as after running around a bit when I first insalled and not saving, when I went back and started a new game, it did the same thing (but obviously I've started the mission more than once without it doing this). this is the only save I've made/loaded, but it does it every time. perhaps I'll try and start a new game, make a new save and see if it does it there too, though I'm not hopeful of a different result (you know the definition of insanity...)

my specs are as follows: Windows Vista Home Premium, Intel Core 2 Duo T7500 (2.2GHz), 3 GB RAM, 250GB 5400rpm hdd, 256mb nvidia geforce 8600M GT (don't know about drivers?), integrated sound blater audigy hd.

one other small thing, when I started, I didn't get a cut scene (I thought I recalled there being one? though it has been several years). and when I click on "Intro" in the main menu screen, nothing happens there either.

help! pretty please? :confused:

tomiathon
12th Jan 2008, 23:14
UPDATE:

well, I finaly tried one more time and it loaded up ok. this is still a problem, however, as I don't want to go through this 90% of the time when I try and play.

also, there was once again no cut scene before shipping and recieving, so something's definitely up there.

I did the normal install, if that's worth anything (but I think that's what I normally do, and I don't know that even the minimum install cuts the cut scenes...)

any ideas on either of these issues would be much appreciated, thanks in advance.

Peter_Smith
13th Jan 2008, 20:52
I have heard that USB input devices other than the mouse can cause unwanted motion. I don't know about spinning. I have never heard of that. You might try disconnecting any USB devices, including the keyboard, to see what happens. Maybe run the keyboard through a USB to PS2 adaptor.

tomiathon
13th Jan 2008, 21:05
hmm, well the only USB device I had plugged in was the mouse. but I could try loading the game without even that plugged in and plug it in later and see if that works (pretty sure I had it plugged in that last time it worked though).

thanks for the advice, will let you know if that looks like it solves the problem.

tomiathon
13th Jan 2008, 23:37
thanks Peter, that seems to work! didn't try to plug the mouse back in, just loaded it a couple times and messed around a bit with just the touchpd, but I don't think there should be any problem with that.

now, any suggestions for getting the cut scenes and intro to play?

also, the lighting is really really dark in many places. doesn't appear to be anything to do for it but to turn the gamma up really high and settle for a washed out look. (in particular I had remembered from years ago that first hallway in the basement out of the butler's room being completely dark, but since it still is, I'm guessing they just didn't put any ambient lighting at all into that hallway or something).

anyway, I gather there are some issues with the nvidia cards (not sure if my old comp had an nvidia or not - quite possible though; it was a secondhand card from a roommate when he upgraded his. whatever came with the comp was sufficient for thief dp and gold, but not for thief 2. I think the gifted vid card handled it fine, any problems including the extreme darkness may have just been nvidia issues, and my comp by that point probably just being barely above minimum specs) . is the 8600M GT among them?

and back to the point i started this post with, might - I don't know why it would, but might as well consider any remote possibility - the graphics card have anything to do with the cutscenes not playing?

theBlackman
14th Jan 2008, 02:53
The cutscene problems are usually associated with the Video drivers. You might try putting The iV5play.exe from the disc on your desktop. Then run it just before you start the game.

I used to have to do that to get the cutscenes to run.

Peter_Smith
14th Jan 2008, 03:49
thanks Peter, that seems to work! didn't try to plug the mouse back in, just loaded it a couple times and messed around a bit with just the touchpd, but I don't think there should be any problem with that.

now, any suggestions for getting the cut scenes and intro to play?


Perhaps the touchpad is a USB device and is conflicting with the mouse. Two possibilities I can think of are to disable the touchpad in the bios and leave the mouse plugged in, or create two different hardware configurations, one with the touchpad alone and one with the mouse alone, and booting to the configuration you want.

There is a permanent fix to the movie problem.
http://www.ttlg.com/forums/showthread.php?t=75031#movies
Scroll down for Scrooge's permanent movie fix. It works.