View Full Version : thief 3 - save games aways corrupted

The Crunch
9th Jan 2008, 09:32
my issue is when ever i save a game it becomes corrupted. ive tried reinstalling but no help. im running vista on a new laptop and the games graphics run great. ive only seen one other person on the forums with this problem and theres was no help. another problem im having is the game resets the graphics to default setings every time i load a new stage or zone and my keybindings reset to default when i restart the game.

10th Jan 2008, 04:42
Not a clue. I've never heard of this, but that doesn't mean much. Basically, laptops are not supported, and T3 was developed way before Vista came out. My suggestion is to search here, at TTLG, and the Internet in general for Deadly Shadows Vista and see if something pops up. At least you will see what problems people have had with Vista, and maybe correcting something there will help.

You might post your system specs so we can see if anything obvious stands out.

Good luck, and please post back if you find a fix.

The Crunch
10th Jan 2008, 04:54
it seems to me that its not able to save any of my settings including my save games. its like its not just the saved games that are geting corrupted. could you tell me were i could download a saved game to see if it will load it?

10th Jan 2008, 07:58
Vista puts all user data such as control changes into a file in my documents.

Take a look at www.TTLG.com and check the tech section http://www.ttlg.com/forums/forumdisplay.php?f=81 and the Legacy game thread http://www.ttlg.com/forums/forumdisplay.php?f=153

The subject came up within the last week. Do a SEARCH THIS FORUM for VISTA.

The Crunch
10th Jan 2008, 20:54
i have looked through and the only other person i found with this problem is here http://forums.eidosgames.com/showthread.php?t=67314
i tried what you said there no luck. right now im trying eidos tech support and so far they have been the worst tech support i have ever dealt with. i cant even get on the phone with them and through email they are giving me the run around.this is frusterating to have a problem that no one else is having.

The Crunch
11th Jan 2008, 01:37
something just dawned on me. windows vista doesnt have the documents folder structured the same way as xp. could that be the cause of my problems?

11th Jan 2008, 07:19
something just dawned on me. windows vista doesnt have the documents folder structured the same way as xp. could that be the cause of my problems?
Good find. That sounds very probable. Not being at all familiar with Vista, I was surprised to learn about that. Some explanation of where files are located in Vista may be found here:

I would suggest doing a search to find out where the install files and user settings are located on your Vista computer. As a frame of reference, in my XP installation, the program files are in
C:\Program Files\Thief - Deadly Shadows
The user settings files, including all save games are located in
C:\Documents and Settings\peter\My Documents\Thief - Deadly Shadows (your name will vary - mine is peter)
All the save games are in
C:\Documents and Settings\peter\My Documents\Thief - Deadly Shadows\SaveGames
And the user settings INI file is
C:\Documents and Settings\peter\My Documents\Thief - Deadly Shadows\SaveGames\User Options\options.ini

If you do a search on your hard drive for options.ini, you may find where TDS put it in your file structure.

TDS may or may not be hard wired to store documents in the above folders. I don't know. But if the file locations are hard wired, then TDS will not find the My Documents in the XP-like file structure, so it might not work.

Depending on what you find when you look around, you might consider creating your own My Documents file structure like the one in XP and see if that works.

Please report back and let us know your findings.

The Crunch
11th Jan 2008, 20:36
i did a search and it threw options.ini in c:\users\matt\appdata\local\virtualstore\program files\thief - deadly shadows along with other files.

The Crunch
11th Jan 2008, 20:45
omg my savegames folder is in users\matt\appdata\roaming\microsoft\windows. i read threw that article and im thinking to myself what was microcrap thinking when they did this.

correction that was a shortcut

my saved games folder doesnt exist the one its refering to is one i downloaded but couldnt get to work. i tried creating a documents and settings folder but windows was not leting me do it.

The Crunch
11th Jan 2008, 21:31
mine consists of c:\Users\matt\Documents\Thief - Deadly Shadows
with only one file i it called launcher.log and theres no savegames folder in there or any other folders.
and theres the files in program files and the files in the folder(virtualstore) i mentioned above.

12th Jan 2008, 06:05
Well Microcrap (:)) has really made mess of this. Another good reason for me to avoid Vista like the plague. But let's see if you can fix it.

That business about "junctions" (see article) is a little strange. I don't completely understand it yet, but it bears further investigation. I am guessing that TDS, during the install, tried to create a user settings folder under "C:\Documents and Settings". Vista would not allow this and used "C:\Documents and Settings" as a "junction", which means an alias or shortcut, that points to the actual folder C:\Users. So when TDS tries to use "C:\Documents and Settings", it ends up using C:\Users. Does that make sense so far?

Vista also put the SaveGames folder in a completely different place. I have no idea why it would do this. It is not difficult to imagine that poor TDS has no idea what Vista has done with the SaveGames folder. Maybe TDS, by referencing the junction, is trying to store the save games in the folder
C:\Users\matt\Documents\Thief - Deadly Shadows\SaveGames ,
which at this point in time does not exist. So it fails.
This would be consistent with normal TDS convention.

I suggest that you manually create a folder \SaveGames under C:\Users\matt\Documents\Thief - Deadly Shadows. Give that a try and let me know if that works.

EDIT: it occurred to me that you might have difficulty creating the folder if you are not logged in as an administrator.

The Crunch
15th Jan 2008, 21:05
well i tried puting a savegames folder in every folder and still doesnt work. i was checking out the activity of the hard drive to see what files it reads and writes too on task manager. from what ive seen it reads and writes to all the files in the virtualization folder and the launcher.log file in documents but it is not reading or writing to any save files when i test that. on top of that its reading and writing to the options.ini file but for some strange reason it resets to default and saves it to options.ini when i load a stage. tech support still has not contacted me for like a week. i gave in and purchased an xbox version from ebay hopefully it will run on the 360. why does one ove my favorite game developers(favorite is valve) have the worst tech support i have ever seen. you guys have helped me out more than they ever could.

bob the builder
24th Mar 2008, 20:59
Crunch you are not alone, I just bought the vista copy of thief 3 last week. Game runs great but I have to start from the beginning everytime. The save games are "damaged" strange they don't seem to exsist anywhere on the harddrive. Tech support has been closed so far so I will find out next week I guess. How did you make out?

23rd Sep 2008, 01:35
Here's what I did to get Thief - Deadly Shadows working correctly in Vista:

Hit Windows Symbol + R on keyboard to bring up the run dialog

type in: regedit

hit control + F to perform a search

search for: Ion Storm

expand the Thief - Deadly Shadows folder, right click SaveGamePath, and select Modify... option

select a location ( I created a folder in \users\<my account>\Saved Games )

game was released well before Vista, obviously, so the default save game path was pointing to a location you didn't have write access to, which was causing the problem

problem should be solved - was for me

29th Jan 2010, 14:31
Here's what I did to get Thief - Deadly Shadows working correctly in Vista:

Hit Windows Symbol + R on keyboard to bring up the run dialog

type in: regedit

hit control + F to perform a search

search for: Ion Storm

expand the Thief - Deadly Shadows folder, right click SaveGamePath, and select Modify... option

select a location ( I created a folder in \users\<my account>\Saved Games )

game was released well before Vista, obviously, so the default save game path was pointing to a location you didn't have write access to, which was causing the problem

problem should be solved - was for me

I did this and it told me there was an error writing in the new value.... could you simplify and break it down. What did I do wrong? What should I do?

29th Jan 2010, 16:59
I took a look at the registry entry in my XP computer, and it is straightforward text. It is I would think you could create a folder and copy its full path name into that text box and that would be it. The string I see does not have quotes, but I suppose you could try entering the string inside quotes, i.e., "full_path" and see if that works better. Remove quotes if it doesn't. I think regedit does not do any checking. So, I wonder, do you have admin privileges on your computer? What exactly is the error message?

20th Aug 2010, 20:18
I am guessing the Author is no longer involved?

Well, my turn!

I have the same problem, all the save games in Thief 3

(Running on vista, but not a laptop, so there is no escaping the fact this is a production mistake by both the makers of Thief 3 and Microsoft, hard truth)

And I do not have any save game folder either. Only the "Launcher" text file on User/Documents.

I tried the regedit doo-hiky, but it didn't do much good.

I modified the SaveGame file 'whatever' on regedit, and put it on the Thief folder in Documents.

I don't know if it is supposed, but there is nothing apart from the "Launcher" in the Documents thief folder.

And the saved games are still corrupted.

Could I receive a real answer? This is a real problem and it is very inconvinient after buying Thief, waiting for it to arrive for a week, and then spending days in figuring out how to play it.

I can now, at least PLAY the game, thank goodness.
But still, there are no save games, I don't want to play and see all the things I worked for get unsaved, so I can only either play without quitting (Not recommended) or just giving up.

Thief 3 is a great game, so I expect to find a great way to play it.

And I know, Vista sucks, whoop-de-doo, but there is a 'check' on the Windows Vista bar in the game cover. So I still have confidence I will get to play it as well as any .XP

Any answers?

21st Aug 2010, 02:30
I wouldn't call it a production mistake. I don't think the developers had enough information to tailor the game for Vista or XP.

You can't fix what you don't know is a problem without the information. In this case two new operating systems not available during early development.

Vista as a operating system SUCKS. XP is better as is W7, which I hate, but you can get a new version that will run on all three without tweaks, or problems. At least mine do.

I don't know if it is part of your problem, but if you are using USB devices you can have all types of problems. And the way Vista handles file storage causes big problems not only with Thief.

21st Aug 2010, 09:41
Yup, you are totally right. The comment of it being a production mistake might have been uncalled for, but you can understand me being pissed over this;

I bought 3 games yesterday, they were cheap, but I expected to get to play them.

Every single one of them didn't work on my computer, even if the Windows Vista was 'checked' in the cover.

Thief 3 was pretty much the only one I get to play, but without save games, so either I play a week in a row to pass the complete story without dying, or my Thief gaming will be done in the first 3 levels then.

But, what you said about USBs.. Can you give me more information about them?

I mean, Vista is a mother effing pain, but usually there's always some VERY COMPLICATED method of making games run on it.

And yes, my comp uses USBs.

If something is blocking the installation from bringing the Thief SaveGames folder, or then I have to figure out a very sneaky way to make the save games folder.

Also, I think I can only play it once every installation, funny, eh? :lol:

Got to reinstall it every morning lmao.

But hey, if someone knows a way to make a SaveGame folder successfully, manually, so I can actually save the progress of my game, tell me. I can always copy the savegames to another location when uninstalling.

For now, I have 3 kinds of forums I'm going to lol.

Thanks for replying!

21st Aug 2010, 19:21
Take a look at the top three or four threads in this Tech forum. Also do a "search this forum" with the keyword USB.

Also, as we found out to our dismay, T3 has the SAVE game folder in MY DOCUMENTS.

Do you have a MULTI-CORE CPU? If so you need to set the compatibility etc. Set the game to run on ONE core, and set the Compatibility to W2k or W98 and see if that helps.

There have been a few tweaks such as DDFIX that has helped the players.

So search for DDFIX and Hyper-threading, and visit TTLG tech forum with the same searchs in both the TECH and LEGACY forums.

Good luck.

28th Aug 2010, 12:41
Hmm yes, after my last post I somehow managed to run it with save games, because I manually added a folder labeled ' SaveGames ' in the thief folder. I was able to play before but forgot to notify about it.
----Spoiler alert---

So, I had awesome playtime, until Shalebridge Cradle, and that's news for the Burrick Inn on how disturbing the level is, but enough of that.

I find now, that somehow, not by any works of me, the T3Main.exe has ran away from the disc files.

And I find now, that everytime I log in, there is a message telling me "There are files waiting to be uploaded to disc."

And then there's the T3Main.exe file, waiting to be uploaded to the disc.

The problem is, the Thief DS Disc, big surprise, is protected, so I can't upload the file to the disc.

And yes, I wouldn't be saying this if there weren't any problems:

I can play Thief perfectly, but the problem has occurred with save games, yet again.

This time, I still have my save games (which I have, as a smart person, made 2 backup copies of them just incase). Now, the save games ingame, are not corrupted, and any new save games I create, are not corrupted.

Yesterday I played T3, not the cradle, managed to get to the past-part of the level..

I started a new game, from the Blue Heiron Inn, worked nicely, and then proceeded to the rutherford opal level, then the 1st day in the city, just went to perry and bertha, and then I went to artemus for the cutscene, and then I also finished the St Edgar's church-level.

I made about 5 save games in that playtime. In the Rutherford Castle beginning, in Garret's building, in the Hammer church, in Garret's building after, and in Stonemarket Plaza.

When I was in Garret's building, I noticed, the rutherford opal save game was gone. I ignored it then, and saved. Then, when I looked, the garret's building savegame was perfectly intact, not corrupted, not missing, just above 'Inner Cradle' savegame, which I did earlier that day.

So, my playtime was as following:

Started from Inner Cradle (Just the savegame after entering the inner part in the present time). And yes, shakingly, I disposed of 3/5 zombies, and freely walked, got lauryl's nightgown, disposed of it in the morgue, stole the King No. One's mask, and saved at the White Hall, looking for the Seclusion chamber (Which's location I now know from a helpful guide). Such a disturbing level indeed.

So, then I shut down the game and went to the pdf file with the whole potporr of complimenting the elements of the cradle, which had a big, detailed and easy-to-read map of the cradle. (The realistic map ingame is awesome, but I just wanted to get rid of this forsaken level, I feel like a cheat now.)

So yeah, shut down the game, then decided that I will wait a few days until continuing this level.

But I still entered the game, now decided to start a New Game.

Played until finishing St. Edgar's church. (Saved the pagan sanctuary for later)

Then I realised, that even if I saved so many times, they kept erasing themselves.

Well, I ignored it, yet again, I was glad to be playing the game.

Today, I clicked to check what files were waiting for upload to disc.

And then I came up with my theory of the T3Main.exe having an effect on save games?

So, is there an effect on saving the game due to the T3Main.exe being missing?

Nothing out of the ordinary happened when I closed the game to go look for the cradle map of the seclusion chamber's whereabouts.

And, who knows, the T3Main.exe could have been missing way before that.

But the yesterday's (27th) cradle saves are intact, and have staid that way
(I checked today, but couldn't play the game now, because Adobe flashplayer needs to be updated.. sigh)

So, why are the save games not saving? They are not damaged, as they were back when I had no save game folder. But they won't stay, after I close the save game window (theoretically, or when I finish another level, haven't tested how long the save games stay saved)

So, I thought about reinstall, but that won't help much if there is a disc file missing?

How can I upload the disc file back to the disc.. The product is protected of any 3rd party files, so I cannot upload the thief file into the disc.

There's 3 possibilities, the way I see it.

1. The Thief will not save new game progress, and it will now, only save the progress from inner cradle onwards.

2. I copied the savegame files into a folder for backup, this effected the original save game folder somehow. (I do not recall doing backup copies when I was searching the map on the internet between playtimes, before the save games started disappearing, but it's possible, I checked the save game files' health often)

3. The SaveGames are full, as I have a load (About, 20+) of save games saved in the game.

What good is it to have the stomach to progress on the cradle level, if the progress will not stay saved.

Cause I don't really like playing the cradle level.. The only thing keeping me going is, that there are some more thieving to be done after this horrible stage.

28th Aug 2010, 21:03
The folder for SAVES in T3 has UNLIMITED ROOM, depending on your HDD available space.

The folder is in MY DOCUMENTS and should stay there. T3 does not read from the TDS folder for SAVES.

Unless you can rewrite the code, you will have many problems with the SAVES the way you are going.

I have nearly 100 saves in the ORIGINAL TDS SAVE folder.

I can call anyone of them up any time with the UP/DOWN arrows on the keyboard to scroll through the saves.

Adobe Flash has NOTHING to do with T3. Why that caused you a problem I don't know, but no application (Flash, QT, etc.) affects the game.

I suggest you remove TDS entirely. Clean all traces and folders after uninstall.

Reinstall a complete CLEAN install. Use the MrWynn Save files up to where you are and start your mission with the MRWYNN save that suits.


29th Aug 2010, 07:57
Well, I will not reinstall it yet. So far the game IS working perfectly. I will, eventually, test if the game saves the games from the cradle forward.

Oh and believe you me, I would not 'screw around' with the save game folder if it would exist and be in place in the first place.

I was looking forward to play it instantly after installation, but, that couldn't happen.

I had to reroute the whole file to C:, and I had to come up with a save game folder.

THERE IS NO SAVEGAME FOLDER IN MYDOCUMENTS. If there is no folder, and THERE WILL NOT BE ANY FOLDER BY ANY REINSTALL, then I have no choice but to make that folder myself. T3 is not working too well in vista, and to be honest, few games work perfectly on vista. So as a vista user I'm perfectly used to bumming forums for help and such. But enough about vista, I haven't done anything to the safe folder from the install, BECAUSE THERE ISN'T ONE. I believe that is clear now.
So frankly, either I make a savegame folder, put it in a location, which now happens to be in C:\Program Files\Thief - Deadly Shadows\SaveGames!
There hasn't been any new solution to this that has been presented to me, and simply this was the only way that it ever worked. I did try other advice given. I have not tried tempering with my prosessors and whatever-devices-they-were on my computer to have 1 running for Thief and the other shut down. If I can play it without just tempering with the taffing settings in my computer, I would really play it like that. So far, it is working out for me fine.

There barely is anything, the only file in mydocuments relating to T3 is: Launcher - 2kt.

In the manually created SaveGame folder, which I, using regedit, implanted the unexistant savegame file to, now works.

The save games folder is as following:

I will randomly select one of the folders in the SaveGames folder:

Folder named: 6D056768-1B2A7FE8-D19CC04B-212184CE-A92A0479

These SAVEGAMES obviously indicate the saves in the Clocktower mission, Started at the 22nd; I finished it around the evening of the 23rd/August.

The files are DATED: And they go from the lower to the upper, making them like this: Stonemarket1.wgs was dated 23.8.2010 16.08
And Clocktower1.wgs was dated 22.8.2010 17.06 (Clocktower2.wgs dated 23.8.2010 15.22)

Includes files:

Clocktower1.wgs 778kt
Clocktower2.wgs - 903kt
docks2.wgs - 1030kt
LoadFilter - 1kt
metadata.ion - 1kt
OldQuarter1.wgs - 915kt
PlayerFlags - 10kt
Restart_AsParams - 1kt
Restart_TravelData - 10k
Restart_TravelFlags - 9kt
SaveImage.dds - 65kt
SaveManifest - 4kt
SouthQuarter1.wgs - 940kt
SouthQuarter3.wgs - 725kt
Stonemarket1.wgs - 916kt

There is another folder of Clocktower; Identical in all ways to the one listed here, but there are 2 additional files: Stonemarket1_int1.wgs - 226kt
and OldQuarter3.wgs - 840kt

And they are all dated differently, this might be a detail, that I replayed it or played it more or something, but I guess it's irrelevant at this time, just an example of my save files.

There are 45 Of files named like this (5 rows of 'random' 8digit combinations)
And then 2 additional folders:

UserOptions : 1 Files = Options - 5kt

and CurrentSave: Files:
HauntedHouse1.wgs, HauntedHouse2.wgs, LoadFilter, metadata.ion, PlayerFlags, Restart_AsParams, Restart_TravelData, Restart_TravelFlags, SaveImage.dds
Haunted House files are about 1000~ kt, and the others are 1-12kt. (SaveImage 65kt)

Which seems convinient, "Current Save" is here, and there's the fact, that my latest save before starting a new game was: Inner Cradle 2010/8/27
And the Shalebridge Cradle is the HauntedHouse in the file text, as someone already mentioned.

But yes, the AdobeFlash.tml report after trying to start Thief was odd. But, I have a "cheapy cheap" version of T3, the SoldOut version. Possibly the SoldOut menu requires the Adobe Flash player? For everytime I start Thief, it automatically goes to the SoldOut menu, and then I can select "Play" or "Install" or "Help" from that menu.

Possibly, if all these save games are correct, and the only thing is that my savegames do not save earlier playthrough, for there is the 'Current Save' which is related to the HauntedHouse, and it therefore does not save any Rutherford Castle or St. Edgar's Cathedral there, which, really, makes sense.

It is simple, and with a 3rd party answering me I would take some action. Also, in time I will attempt to update the Adobe, and go try the Cradle again, and then I will see if it will save.

But, with so many possibilities that Thief is running perfectly, the savegames are protecting the CurrentSave file, for it already is taken by HauntedHouse and apparently it is not finished with the HauntedHouse, requiring me to finish the level so it will get it's own 2702BSNA-blahblahblah folder. And if SoldOut menu requires AdobeFlash.tml updated or installed or whatever, this is all honky doory.

So, apologies, but I won't take your aggressive advice yet, cause well, I've progressed through the game and if this is just a peculiar little update required, and if it just requires me to get off my shanky legs and go finish the Cradle, then~

Also, it would be rather helpful, before I take any action, to check with an Eidos Engineer/Moderator or just another player, are my save files currently, well, as they are supposed to be saved? :whistle:

29th Aug 2010, 15:50
In My Documents should be a folder that is named Thief-Deadly Shadows

This should contain the saves for the game, regardless if it is SOLDOUT or MASTERTRONICS or the US EIDOS versions.

If that folder is missing from your system there is something wrong.

Any of you UK players out there that has the SOLDOUT version that does not have the folder in My Documents?

29th Aug 2010, 17:40
Might be a dreadful combination;

Windows Vista

SoldOut (I'm pretty cautious when it comes to sub-labels like this one)

Pre-2007 Game

Usually, all the pre-2007 games need some extra to be done in order to play on vista (Codecs and such)

Not to mention Thief being simultaneously published to PC, so mind there might have not been enough caution for the notorious windows vista.

But at least the save games folder I have seems to be correct, with the saves themselves, 'current save', user options and SaveIndex.ion

Hopefully I can walk away with this with both my saves and my thief DS.

29th Aug 2010, 19:40
It may well be the VISTA. Vista handles files in a really wierd way.

If you have the bucks try to find the SOLDOUT/MASTERTRONICS Thief the COMPLETE COLLECTION.

A set of DVDs that has GOLD, TMA, and TDS ready to run on XP/VISTA.

I have the first printings of TDP, GOLD, TMA, and TDS. All installed and run well, but I got the COLLECTION and have all three on a XP machine.

They run with no tweaks or forced installs and (I avoided VISTA like a plague) it has been claimed by members that it installs and runs on VISTA with no problems.

All the games one this set is patched to the lasted versions and might be a solution for you for the future.

18th Dec 2012, 19:18
well i didn't see a concret answer and a have been able to fix it, so i'll post what i did

there is a default.ini file in c/program files/thief/system
wich has an entry named SavePath=..\save

the .. stands for the prior folder in wich the default.ini is located wich would be c/program files/thief

but there is no save folder in c/program files/thief so i created one

then i entered the registry as said in one of the post and changed the value of savegamepath to c/programfiles/ thief/ save

wich is located in hkeylocalmachine/software/wow6432node/ionstorm/thief

and guess what, it worked

the strange thing is that i don't see any files in the save folder, but when i start the game i'm able to find the saved game so it doesn't matter

hope this helps anybody