PDA

View Full Version : Thief2 Problem



Keeper_Andrei
5th Jan 2008, 17:37
Hi!I have a problem with Thief2.When I enter the mission the game crashes immediately or after a few minutes.I have Windows XP service pack2.My machine specifications are:Intel Pentium 2.8 Ghz Dual Core,1 Gb DDR2 and a Ati X550 video card.Please help!:scratch:

Has anyone encountered this problem?Thief1 has the same problem.I would be very gratefull if someone could help me.:)

Stay in the shadows!

Peter_Smith
10th Jan 2008, 05:05
These days, this is a very common problem.

You need to set affinity of the thief process so it runs on only one CPU. Use the Task Manager / Processes list to find the process. Right click on the process name, enter Set Affinity, and uncheck one of the two CPUs. If this works, there are ways to make it permanent. The most popular way is to download IMAGECFG, copy it to Windows\System32, and run it with the statements in a BAT file that is located in your Thief2 folder:

processor.bat
-------------
imagecfg -u thief2.exe
imagecfg -a 0x1 thief2.exe
pause

Make sure to back up the original EXE first, as IMAGECFG changes it. If you have a smallish EXE and a larger file called THIEF2.ICD, you may need to set affinity on the ICD file as well.

Another way is to download and use the program ProcessWatch, which sets affinity on launch. You can watch any number of processes with that.

You can do the same thing with Thief 1.

There may be other things you need to do. Let us know how this works and whether you have any other problems.

Keeper_Andrei
12th Jan 2008, 14:30
It doesn't work :(
The processor affinity was already set on only one processor for the Thief2 process.
I've downloaded ProcessWatch and set the Thief2 process on only one processor.Now after loading the screen goes black and only Ctrl-Alt-Delete works.
I have not tried Thief 1 yet.
2 friends of mine had the same problem with Thief2 and Thief Gold.

Thank you for your help.

Peter_Smith
12th Jan 2008, 18:10
Please post the specs of your system including OS, video card, and video card driver versions - it may help diagnose this.

Please explain whether or not you have, effectively, two EXEs for Thief 2 or one. If you had two, you would see in your Thief 2 program folder one small EXE file, thief2.exe (around 245 KB), and a larger file, thief2.icd (around 2601KB). If you do have the two, then there will be two processes running, and I think you need to set affinity to one processor for both of these. This can be done in ProcessWatch even if one of the two resists change using IMAGECFG, which is possible.

If you have only one thief2.exe (around 2601KB), then you only need to set affinity for that one process.

In either case, start Thief, stop at the first menu level without starting a game, and use the Process Manager to check whether the affinity change has taken hold. Having done that, make sure you keep the affinity set at one processor.

Other things you can do for Thief 2:

If movies are hanging, use an alternate version of the movie codecs:
http://www.thief-thecircle.com/download.asp?fid=876

If, on starting a game, you get a black screen or a texture error message, remove the semicolon from the line ;safe_texture_manager in the file user.cfg

Turn on v-sync if it runs too fast.

If you have an Nvidia card, use 163.75 drivers. 169.xx are broken.

If you have an ATI video card, use Catalyst 7.12. This enables fog, which previously was broken.

Let me know if any or all of this works, and which steps were necessary. And don't forget to post your system specs.

Peter_Smith
12th Jan 2008, 18:13
I have previously listed what is needed to make Thief 1 work. It is slightly different. Check here.

http://forums.eidosgames.com/showpost.php?p=718279&postcount=2

Keeper_Andrei
14th Jan 2008, 19:34
Motherboard:Elitegroup P4M890T-M
Intel Pentium 2.8 Ghz Dual Core
1 Gb DDr2 533 Mhz
160 Gb Sata Maxtor
Asus Ati Radeon X550 256 DDR PCI-Express Driver version 8.24.0.0 & Ati Catalyst 7.8
Windows Xp Service Pack 2

I hope I didn't forget anything.
I have 2 files as you said.I have checked the affinity and it is set to only 1 processor even after I start the game.
The intro movie from the first mission works well.No problems there.
I have removed the ;safe_texture_manager line from user.cfg but it's the same as before.

I finished Thief 1 on my old computer.In my opinion it is one of the best games ever made.Thief2 didn't work on that computer.So I waited for the new computer.When I got it I played Thief3.Now that's a game well done.I know it's kinda late but congratulations on a great game.A 10/10 in my opinion.It fully catches the classical Thief atmosphere.:thumbsup: I dind't get to finish Thief3 but I will do it.I think I am going to install it right now :D
I'm glad Eidos got the job of making the last Thief.To bad that the series will not be continued.

Thanks for the help and the patience :D

Peter_Smith
15th Jan 2008, 08:51
I have removed the ;safe_texture_manager line from user.cfg but it's the same as before.

No, I said remove the semicolon from the front of the line. The semicolon is a comment character. Removing it makes it active. You need
safe_texture_manager
in the file.

Keeper_Andrei
16th Jan 2008, 19:30
I thought the whole line.Sorry I got it wrong.
Anyway I trid it and it doesnt't work :confused:

Peter_Smith
17th Jan 2008, 02:20
It is not clear to me what you have done and what you have tested. Please post a blow by blow description of all that you have done to fix it, including whether (and how) you verified that you were using only one processor. You said "I have checked the affinity and it is set to only 1". What does "it" mean? There are two processes, thief.exe and thief.icd. Each must be set, and each must be checked.

Sorry, I think the safe_texture_manager applies only to Nvidia, so that was probably a waste of time. I'd leave it there until it works, then set it back.

Keeper_Andrei
21st Jan 2008, 13:51
It's working now.Sorry,I didn't set the thief2.icd process affinity properly to one processor.I used ProcessWatchV2.Thanks a lot! :D :D :D

You can close this thread.Thanks for your help!