PDA

View Full Version : Blank screen on launch on Vista x64



Bahrni
2nd Jan 2008, 22:07
I know there are other mentions of this problem in other thread, but I haven't seen any response that actually fixes the problem so I'm adding my own voice (politely) requesting some help.

I'm running Vista x64 and bought K&L through Steam. When launched I just get a blank screen, although the Steam overlay is available and the Live login stuff (which seems utterly redundant when its functionality is already provided by Steam, but that's another point). I've managed to enter the key I got from Steam, but that's it. The screen flickers sometimes and the intro/demo movie plays every so often, but otherwise nothing. I've disabled AnyDVD as EIDOS suggested (which is a pretty daft point for a STEAM purchase that DOESN'T COME ON CD/DVD) and disable Windows Desktop Management (goodbye pretty transparency) and still nothing happens. I haven't tried mucking about with the DirectX settings for audio as that doesn't seem to fix the problem for anyone discussing it either. I never actually get any kind of error message, but I have to end the task (when windows reports it doesn't repond) to get rid of it.

Has anyone in fact got this game to run on Vista x64? So far it seems a frustrating waste of my money. I have Oblivion, HL2, FSX, Tomb Raider Anniversary and even the notoriously fickle Crysis running fine on my machine and it seems that K&L is just appallingly badly programmed. Given the pretty graphics shots I foolishly assumed that it would at least be compatible with DirectX10 if not natively written for it, and thus would run under Windows Vista. If it involves disabling any more system components, I think it really should be labelled as XP only as having to disable assorted services and programs in Vista to get anywhere does not count as "working" in my book.

My system specs are:
Vista x64
Shuttle XPC SN25P
Nforce4 motherboard
8800GTS 320GB
2Gb 3200 RAM

All drivers are the latest available. If anyone HAS successfully managed to get this game to work under Vista x64, can they please reply with how? Any help gratefully received.

Kneo24
3rd Jan 2008, 00:40
And what processor do you use?

Bahrni
3rd Jan 2008, 01:33
Athlon64 X2 4200+ - Like I say, good enough for Crysis et al.

Kneo24
3rd Jan 2008, 01:37
And you've already installed the dual core optimizer?

Bahrni
3rd Jan 2008, 02:06
Thanks, but the dual core optimiser is for XP, it doesn't work under Vista 64, but after some digging on other forums I've worked out what's wrong. Directx9. K&L seems to need some part of Dx9 that isn't natively included on Vista64 with all it's Dx10-based fun.

Having now run the October 2007 DirectX9 redistributable installer from the Microsoft site, K&L is now running fine. I don't know whether the oversight of not including whatever dx9 components it requires is a relic of purchasing through Steam or whether shop-bought versions have the same mistake, but at least I can now find out what the game is like! I can't help but wonder if K&L was even tested on Vista to let such a basic mistake occur.

Thanks for the help anyway.

Kneo24
5th Jan 2008, 15:54
You're the first Vista user I've seen to state that it doesn't work under Vista.