PDA

View Full Version : Problems on startup



PeaceMaker
21st Dec 2007, 04:07
Hello, I'm having a problem with kane and lynch. Whenever I attempt to launch the game, it launches but the screen freezes black. I get no error message, just a black screen and occasionally the trailer will start to play but at the most, thats all I can see. Has anyone else experienced this problem and if so, how did you fix it?

PeaceMaker

Edit: I have checked the system requirements and every thing is above the minimum and recommended requirements. Also, I'm running vista if that may have anything to do with the problem.

inline4me
21st Dec 2007, 04:26
I am having the same problem here. When I launch the game, I get the trailer to play. I can also access and log into windows live using the home key. I have never been able to see the main menu or actually get as far as playing the game. It just keeps playing the trailers... all three of them... over and over :mad2: ...
I have Windows XP and my computer is well above the minimum specs. All of my drivers are up to date, and I have directx 9c installed. I have even tried 3rd party drivers too. I also downloaded the new release of windows live from microsoft. Someone please help, I think i just blew 50 bucks on a game that won't work.

PeaceMaker
21st Dec 2007, 04:35
I am having the same problem here. When I launch the game, I get the trailer to play. I can also access and log into windows live using the home key. I have never been able to see the main menu or actually get as far as playing the game. It just keeps playing the trailers... all three of them... over and over :mad2: ...
I have Windows XP and my computer is well above the minimum specs. All of my drivers are up to date, and I have directx 9c installed. I have even tried 3rd party drivers too. I also downloaded the new release of windows live from microsoft. Someone please help, I think i just blew 50 bucks on a game that won't work.

Are you running it through steam, by any chance? That could be relevant.

inline4me
21st Dec 2007, 04:36
yea i am running through steam

Candle
21st Dec 2007, 14:26
Turn off anything like daemon tools. Try changing your soudn accelleration under dxdiag.

I don't know about this game from steam though.

timbro
30th Dec 2007, 16:42
I am having the same problem here. When I launch the game, I get the trailer to play. I can also access and log into windows live using the home key. I have never been able to see the main menu or actually get as far as playing the game. It just keeps playing the trailers... all three of them... over and over :mad2: ...
I have Windows XP and my computer is well above the minimum specs. All of my drivers are up to date, and I have directx 9c installed. I have even tried 3rd party drivers too. I also downloaded the new release of windows live from microsoft. Someone please help, I think i just blew 50 bucks on a game that won't work.

I have the exact same problem as you.

Specs

AMD X2 5000 @ 2.7 ghz
3 GB DDR2 800
geforce 8800 gts 320 MB
windows vista 64 bit

also i am running on steam

bothered
30th Dec 2007, 17:23
Me too, as seen in this thread. http://forums.eidosgames.com/showthread.php?t=74473
It seems almost everybody is having problems with it. I uninstalled it and am now redownloading it from Steam. Six hours now on a 20mb line and it's only at 55%. The whole thing sucks.

inline4me
7th Jan 2008, 16:11
did you get it fixed?

bothered
7th Jan 2008, 18:05
did you get it fixed?
I've given up trying. I'm hoping Eidos do something and release a patch. Until then I'm not going to waste any more time on it.

JohnyNFullEffect
10th Jan 2008, 21:50
Hey all,

After reading this and realizing I was in the same boat, I did more searching and found that K&L needs components from DirectX 9.0. So either Vista x64 or Steam is not letting Directx 10 work with K&L.

This is the solution that worked for me.

Go here:

http://www.microsoft.com/downloads/details.aspx?familyid=1A2393C0-1B2F-428E-BD79-02DF977D17B8&displaylang=en

And download this:

directx_nov2007_redist.exe

Once you install the package and reboot, K&L works like a charm. Looks like it isn't a waste of $50!

Good luck!

inline4me
29th Jan 2008, 22:42
Woohoo, that was it! I finally played the first two chapters of the game. Thanks for the info:thumbsup:.

Moderator please stickey this post for us Steam Users!

NEOscuro
31st Jan 2008, 00:26
Hello,

Welcome all to the club! It doesn't matter where you got the game from; this is happening to half the PC users, no matter if they got it from STEAM or from the store. The fact is that half of the PC users can't start the game, get a black screen, crash to desktop or get to play to the third chapter like myself and then it crashes always in the same place. Don't waste your time playing with sound and video settings, drivers, etc., etc., etc.; I have tried everything **** already. The problem is the game. :mad2: We all have to sit, hope and pray that a patch will someday come out and cross our fingers that it will solve our problem. :lmao: Thank you.