PDA

View Full Version : Does Anyone else have slow game play?



Agent 23
27th Nov 2007, 23:45
It is like everyone is swimming through water. I have a NVidia 7200 512mb video card and core 2 duo 2Ghz 2MB ram, and I tried to turn down the detail to low and set my card to performance and not quality, and it still is like sludge...

Takai29
27th Nov 2007, 23:55
It is like everyone is swimming through water. I have a NVidia 7200 512mb video card and core 2 duo 2Ghz 2MB ram, and I tried to turn down the detail to low and set my card to performance and not quality, and it still is like sludge...


Hey Agent 23, sounds like you're describing a problem 'similar' to the issue many of us have been seeing, but not exactly the same.

What keyboard and mouse are you using? What sound card?

Agent 23
28th Nov 2007, 03:42
A Logitec keyboard and a cordless mouse... I am playting off a laptop but my hardware should be able to handle it... SigmaTel High Definition Audio CODEC for sound...

jaywalker2309
28th Nov 2007, 09:12
It is like everyone is swimming through water. I have a NVidia 7200 512mb video card and core 2 duo 2Ghz 2MB ram, and I tried to turn down the detail to low and set my card to performance and not quality, and it still is like sludge...

The 7200 is the low end 7 Series. it has the hardware features but does lack the horsepower of the 7800/7900.

Also having a faster Dual Core CPU could be bottlenecking things too, since your CPU will be waiting for the Graphics card to catch up.

The biggest performance hits come from Post Filter, AA, and Shadows. Have you tried having all these turned to minimum? and resolution set to lowest.

I know you said you tried low settings, but just making sure

Also changing your graphic card settings in the control panel sometimes doesnt work (set this back to default so that the applications control it)