PDA

View Full Version : 3D Problems!!!



Briko
21st Nov 2007, 21:36
I have just finished constructing a new head mesh in Metaseq. I saved the mesh correctly as a .dfx file, but when I imported the new mesh into Strpix, my mesh was distorted. Most of the distorted shapes were only small discrepancies that I didn't mind... but the lips were so deformed, I almost wanted to cry. All the points and lines are there, they are just in slightly wrong places. I’ve tried over and over again, but I can't fix the problem!:mad2: Here is what I've discovered so far.

I made my mesh in Meta. When exporting the mesh as a .dfx file, one of the things I do is multiply the mesh by 0.01 ( I do this because I multiply everything by 100 before working in it). Just because I was so desperate, I tried exporting it without multiplying by 0.01. When I imported the mesh to Strpix, the face was 100 times too big (like I expected) but it was not distorted. I concluded that my problem must be occurring when Meta multiplies my mesh by 0.01. So, I manually resized my mesh and placed it in the correct position. This time, I was able to export the mesh without needing to multiply it by 0.01. I figured that everything would turn out correctly this time…but it didn’t. I still had the same problem.:(

Please somebody help me!!

aktrekker
22nd Nov 2007, 08:14
If I remember right, you have to check Triangle have 4 sides in Meta when saving.

Briko
23rd Nov 2007, 03:27
Yes, I did check the "triangles have 4 sides" box, but I forgot to say that in my first post. That's not the problem, but thank you for letting me know that I excluded that information.

aktrekker
24th Nov 2007, 04:26
Doing a forum search I found the following:

Originally posted by MDN
My general rule is opening the object in meta with the size,
1.000 x 1 if it's a static object.
1.000 x 2 if it's a lara, baddie, key mesh.
when saving it, save it (in dxf form) the same as you opened it except the digit is negetive. ie
1.000 x -1 if it's a static onject.
1.000 x -2 if it's a lara, baddie, key mesh.

Don't forget that when opening it, open it with the 'invert faces' feature on. When saving it, make sure that the feature is off.

Also, someone was able to fix a problem by unchecking Save filename as layer.