View Full Version : Thief 3 intro loop (I can't acess the affinity)

10th Oct 2007, 10:44
I am new here, and I am definetely NOT a computer expert. But one thing I can say, is that I am addicted to the Thief Series.

I have encountered the problem (which others have aswell) with the intro loop in "deadly shadows" Now my problem is, that the task manager won't let me set the affinity to one CPU. It says Access denied when i try to change it. it only denies me access to the thief related processes. I can change all the other processes but the ones I need to. Quite annoying actually. I use Vista by the way.

Another thing, when I first run the game after install, it runs fine, untill it suddenly crashes, and the when I restart the game, the looping begins.
my processor is AMD Athlon 64x2

I hope someone can help me on this, fortunately I have my old computer still so I can play it there, but I would most certainly perfer to play it on the new one:)

11th Oct 2007, 05:58
I had always thought that T3 would run on two processors and that only T1 and T2 required setting the affinity to one processor. I just checked on my computer (XP Pro SP 2), and that is the case after T3 proper starts running. I have no trouble getting into the set affinity menu with the T3main.exe process, and, when I do, I see it set at two processors. It could be a problem unique to Vista or the way the T3 software was installed. Sorry, I can't help you with Vista. Could be some security thing. I would do a search for Vista and see what I can find.

I am not sure what the deal is with the "intro loop". I don't know what an intro loop is. I have all those short ad videos bypassed by hiding the files. You might post a link here to the discussion of the intro loop problem. That might shed some light on it.

11th Oct 2007, 07:36
Thx for the answer. I mangaged to solve the problem right after i posted the thread. LOL. Typical. I just needed to access the processes from all users. (or something like that) maybe it has something to do with the fact that I had set the game to run in XP compatibility mode. Now it only uses CPU0Anyway, it works and I am happy that it does (now the only problem is the amount of time I spend playing the game, LOL)

Have a nice day.