View Full Version : Ford Street Racing Major Problems

21st Sep 2007, 21:42
I have 6 controllers, none of them seems to work with this game, dont matter what i do, none of them are working. I need some advice on this, please.

Also, i get this message:

"error: EV_Stack:534:Trying to pop a stop when there isn't one"

I only seem to get this message when i use a no cd patch, but when i play the game in the bottom CD-rom drive, it works fine, still the control issues are a problem.

Please help

22nd Sep 2007, 05:45
Please help, someone. I really wanted to play this game on the pc, but i guess if nobody can help me, i will buy it for xbox, which i was going to do anyway. i wanted both versions.

23rd Sep 2007, 14:39
Alright, can someone try this game for me, and test out the controller issue.

23rd Sep 2007, 16:13
Have you had a look at the support website and tried contacting Eidos tech support? They don't visit this forum so..

24th Sep 2007, 03:08
I haven't contacted eidos about it, where do i go about doing this?
I looked around at many support sites, but none of them helped solve the issue.

24th Sep 2007, 09:04
The site is here:


You'll need to register there first before you can mail them your question though.

24th Sep 2007, 16:25
Thanks, and btw do you own the game, maybe you can test it out for me :D

24th Sep 2007, 17:57
Sorry but I don't have the game, otherwise I would've tested it out.

24th Sep 2007, 19:46
Alright i will just reg and send a message to tech support. Now if the problem doesn't get solve, i will just buy the xbox version, either way i want this game to my collection. Ford Racing games are awesome, expect for ford racing 1 on the psx, that game is too hard. But ford racing 2, 3, mustang( legend lives ), ford vs chevy, and street racing are fun.

peace. :thumbsup:

29th Nov 2007, 04:23
yeah i just got this game from the local video store to rent and it does the same error.

so bummed out because it looks so good and runs quite smooth on my computer.

if you find out how to fix it please post the fix here.