PDA

View Full Version : Thief Dark Project, and Deadly Shadows problem (please help)



Zeus
9th Aug 2007, 12:41
Ok hi I'm new here and having some problems with thief games.

First Ill start with the older thief game... I recently bought the thief double pack which had thiefs 1 and 2. So I installed them and everything but neither thief 1 or 2 would work, I just got a black screen about the "texture memory" when I tried to start the first mission. I did some searching and used the "safe texture manager" fix for thief 2, and it worked great, I'm on the "casing the joint" mission already. But thief 1 has the same problem I had with thief 2, just a black screen when i try I start the training, but there is no safe texture fix. I went on the TTLG forum and tried some of the fixes in the FAQs, like rolling back my nvidia drivers to the 8x.xx range which didn't work. I tried getting one of the fixed exe files on this site

http://www.thief-thecircle.com/media/patches/

but all it really did was just took away the cd-check and made the error box of "3d card does not report texture memory" go away instead now it's just a black screen and when I open the task manager it just says not responding. Then I tried getting the latest drivers from nvidia, 162.18 and they did not work. So basically to sum it up so far, I can't play Thief 1, but thief 2 works great with the "safe texture manager" fix.

Now onto deadly shadows. This one is a horrendous bug. First off, I am using the steam version (I had a retail copy but I lost it so I bought it on steam). Now I started it up and as it was loading the training mission my computer just randomly rebooted itself, when it got back to the desktop it said "windows has just recovered from a serious error" which was a windows stop error caused by something with the drivers. So I tried it again, this time I actually got into the training mission and played all the way through. But...I decided to close down the game to go eat breakfast so I got back to desktop and clicked on "My Computer" to go look for something, and boom, the computer rebooted again with no warning. I just double clicked on "My Computer' after exiting TDS and an immediate reboot just came out of nowhere. So basically, the reboot bug only occurs AFTER exiting the TDS program (or during loading of an area), if the comp reboots, the bug does not happen again unless it crashes again during loading, or after exiting the program.

I reinstalled my latest nvidia drivers and reinstalled the game to no avail. This bug does not happen on ANY other game that I have and I would really like to know how to fix this because I'm a bit annoyed that I spent $20 for something that has done nothing but crash my computer.

I should mention that I used to own Deadly Shadows hard copy, and it never did this. It was the same version as the steam one (1.1). I also had another bug caused by my Saitek USB keyboard, but some googleing helped me fix that quick. But I can't keep doing this, having my computer randomly reboot is not a good thing, so if I could get some quick help that would be great. Thanks

Specs:
Nvidia Geforce 6800 256 mb (latest drivers 162.18)
2 GB RAM
AMD Athlon 64 processor 3700+
Creative X-Fi sound card

Edit- I've just tried the latest Omega Nvidia drivers, both with and without the fixed Thief 1 .exe file and they did not work, I got the same bug. Also the Omega Drivers did NOT work with Thief 3 either, it crashed my computer again within seconds of loading the training mission and a windows error report shows this.


You received this message because a device driver installed on your computer caused the Windows operating system to stop unexpectedly. This type of error is referred to as a "stop error." A stop error requires you to restart your computer.

If I could get a response that would be great.

Peter_Smith
11th Aug 2007, 17:23
Thief 1 will not run on any Nvidia driver of the 9x.xx series and more recent (1xx.xx). You have to revert to an older Nvidia driver if you want to run T1. I recommend 84.56 as a stable version that has also been modded successfully to support newer 79xx video cards. First go to Nvidia archives and try their 84.56. If that doen't work or it doesn't support your video card, go here (http://www.xtremesystems.org/forums/showpost.php?p=1744187&postcount=302). To install it, deinstall your old one, reboot, cancel out of found new hardware, and install 84.56.

As for the second problem, there have been several reports of the Steam version of TDS not running. I have no idea how to solve it. My first suggestion is to scan the TTLG.com Thief General forum FAQ page to see if you might have missed something. Then, I would try deinstalling it and installing it again after the older drivers are in place. That probably will not work. Then I would contact Steam and ask their support. Please let us know the outcome, good or bad.

It might be helpful to start another thread entitled "Steam version of TDS does not work". That might gather forces, and maybe you will find a Steam customer who has made it work who can help out.

Kyudos
13th Aug 2007, 23:18
Grrr! This could be my problem (see main TDS forum) - my 'modern' Forceware drivers...

I think it is extremely disingenuous of Valve / Steam / Eidos to continue to sell TDS without any warning that it is unlikely to work on a modern computer without some extreme arsing around. A prominent warning should be given or a patch should be issued - I've effectively paid for a game I can't play...

Kyudos
14th Aug 2007, 21:10
Try turning off the 'Bloom' visual option - it appears to have stabilised things for me (along with single core affinity - see here (http://forums.eidosgames.com/showthread.php?t=71652))

Zeus
15th Aug 2007, 01:27
Thanks kyudos, turning off bloom fixed the game for me. It runs perfect now. They should add this to the FAQ. Thanks again kyudos!