View Full Version : Pixel Shaders v1.1

24th Jul 2007, 16:20
What is the most economical AND effectively functioning solution for the Lego Star Wars "Pixel Shaders v1.1" message error? And if it requires a new video card, what is the most economically-priced card that corrects this error?

8th Aug 2007, 02:32
theres a proggy called 3danalyze, google it, download it, select your lego star wars exe and go to emulate HW TnL caps on the top right. the click run and ur away. run this every time or ull get the pixel shader error. this works for all games that say that, i use it for just cause, tomb raider legend, and lego star wars II(not needed to actually play but gives more graphics effects like plastic reflections) hope this helped, did i my case!

27th Aug 2007, 13:08
Thanks to Sebbo1298 for this post which has solved my problem; I came to it via Google & am adding to the post in case others come across the same problems that brought me here.

I was experiencing problems running Star Wars I & II on a laptop with Intel Integrated Graphics (Intel 945GM chipset with Integrated Graphics Media Accelerator, GMA950).

Both games returned an error message along the lines of "PixelShaders v1.1 not supported by the graphics card."

Intel support were unable to help.

I eventually came across the relevant posting on the Intel website: http://support.intel.com/support/graphics/sb/CS-011910.htm

You can successfully get round the problem as Sebbo1298 has described.

10th Feb 2008, 23:20
Although I appreciate the efforts of those mentioned above, I have to say that this solution does not fix this situation for all Intel card users.
My nephew has the Intel 82845G card, and this solution does not work for him. We are continuing to try other combinations to see if we can 'crack the code', but so far it doesnt look good.
As I said I appreciate all the work done by those before me, but if you do not give specs on your card and only say "Intel", it gets some of these little boys all excited, only to be let down when the solution turns out to not work.
I am glad to see that simong did this! :)
Lets all list our 'solutions' with cards specs, shall we?

22nd May 2008, 22:04
I tried doing what was suggested on this forum as well as an archived post that I found. And it didn't work. When I tried to extract the 3Danalyzer files from the zipped folder, it did them all except dat1.000, dat2.000, and dat3.000. I tried numerous ways of getting them out and the computer keeps giving me Error 0X80004005. When I did run 3Danalyzer (without the dat's) and clicked all the correct buttons and whatnot (as described in previous posts) it gives me one of two errors (I have tried this multiple times).

Error 1:
Could not copy
to C:\Program Files\Giant\LEGO Star Wars Game\ForceDLL.dll !

Error 2:
Could not copy
to C:\Program Files\Giant\LEGO Star Wars Game\openg132.dll !

I'm running Lego Star Wars using Windows Vista via Parallels on an iMac. My chipset model is ATI, RadeonHD2600. I could really use some help. *sigh*