PDA

View Full Version : Thief 1 (Dark Project) crashing



MistyDP
15th Jul 2007, 23:32
I hope you all can help me!

I decided to dig out T1 and give it another go, only to meet with frustration. I've spent the last hour trying different fixes. I am running Vista Home Premium and I have an ATI Raedon x700 pro video card. When the game starts up, I get this window stating that Thief requires a video card that is 100% Direct X compatible and if it crashes, to update my video card drivers. Well, it does crash. I usually can't get past the first room in the training before the graphics just freeze (music still plays).

I have version 1.33 of Thief. I don't know if there is a patch out there that I might need. I'm going to continue to check but I wanted to try posting here.

Thanks for your help!

Peter_Smith
16th Jul 2007, 06:18
Try the workarounds mentioned here:

http://www.ttlg.com/forums/showthread.php?t=112669

Please let us know if you get it running and what you did.

MistyDP
16th Jul 2007, 21:32
Still no luck. I've got a ticket in with Eidos tech support.

I've tried:

Updating video and sound drivers
Running as administrator
Running as XP and 98/me compatibility
Downloading the patch (1999)
Turning off hardware in game options

I am not running a dual core processor. So I am totally out of options.

MistyDP
17th Jul 2007, 05:51
I'm beginning to think it's a sound issue.

I have a Sound Blaster Audigy 2 ZS card. I've downloaded a couple different driver patches with no luck in fixing the game. The reason I think it's a sound issue is the crashes usually occur when someone goes to speak, or when a particular noise is supposed to occur, thats if I get in at all.

MistyDP
17th Jul 2007, 21:28
After hours of researching, I FINALLY figured it out. It seems to be working OK now.

http://www16.brinkster.com/salvage/thief/darkengine.htm

I don't have a dual core processor, but I must have one that uses hyperthreading because this worked.