View Full Version : TRA Audio goes bad, requires reboot

14th Jul 2007, 22:06
TRA appears to have a couple of new problems that work together to provide problems that weren't in TRL (might be termed "regressions" -- things that used to work but no longer do).

I normally play TR[A/L] or other games interspersed with other tasks [work, email, browsing, etc...] It's good to have it "on tap" to provide a break and blow off some steam periodically. But some new problems makes TRA more difficult to use. I'm not sure why various decisions were made, but some of choices have decidedly "user-unfriendly" effects.

The "top-level" of this problem is that after TRA is "restored" from not having focus (i.e., it was "minimized") it doesn't properly reset audio for its needs. This is "manifest" by a progressive degradation in sound quality. A few hours (with it having been minimized), and returning to the game, audio has little random "pops" and cracks in it -- like a scratched, old LP record. After several hours or a day or more of being up, the sound usually decays to the point of being unlistenable -- I end up having to MUTE the sound to tolerate playing. It has gone from small pops and glitches to a chronic static -- like an AM radio station that is getting progressively weaker -- more and more static, loud pops, mixing-in of "white-noise" sound ("shshshshsh").

To fix the problem I need to reboot my machine. That's what makes it such a royal pain. If this problem had been problem in TRL (I don't remember it being a problem but haven't retested), I would have just exited and restarted the game. This is far from ideal, since I lose my place and "saves" are disabled when replaying a level.

I'm not to the point yet where I can play all the levels (one at a time) without taking a break (actually, I'm not yet "there" with any of the levels in TRA :o ). Specifically, I can't expect to pick up playing where I left off after hitting a checkpoint when replaying a level. Nor can I save my place by creating a named restore point as the Save menu is disabled. This isn't a user friendly feature (even though it may have been present in TRL). Why can't users "stop playing", then return to playing later and pick up where they last left off? It's a simple concept: when you pass a checkpoint, it records it as your current location so if you exit game and re-enter, "continue" picks up where you left off.

Whatever the reason -- the result is I don't want to exit the game because it won't save my place, so I can't easily reset the audio even if the next problem didn't exist.

The main problem with "exiting" TRA is having to reboot my machine to restart. Someone decided that certain popular Microsoft utilities cannot have been run, *ever*, since reboot. It's not that they can't be run while you are starting TRA or while you are in TRA, it's that you can't run them any time after a reboot and before starting TRA. If you run the util, something changes on the machine and the user-unfriendly DRM refuses to allow you to play -- the web-message tells me that this incompatibility is deliberate. The popular util is in the top 100 popular utils of all time. From a May 25, 2007 "What's New" entry:

Process Explorer Recognized by PC WORLD in Top 100 Products of 2007 (http://www.pcworld.com/article/id,131935-page,13/article.html?wt.svl=whatsnew)
"We’re proud to announce that PC WORLD Magazine has ranked Process Explorer at #75 in its annual "Top 100 Products" issue!"
Why should TRA _care_ if I've used a process-monitoring utility since bootup? It doesn't prohibit, only, starting TRA if it _is_ running, but you are prohibited running TRA if you have *ever* run ProcExp since bootup. How insane is that?

But I thought I'd found a work-around by just leaving TRA running in background while I did other tasks and switch to TRA when I needed a break, but this sound/audio going fuzzy problem is doing its best to allow such healthy (in that one takes breaks from playing) usage.

While fixing the sound might is an option and would be good -- why must TRA care what Microsoft (or other) utils I run to create and maintain administration and security on my system? Is TRA (or its DRM) attempting to hurt my security like the Sony rootkit fiasco?

Please, at least, fix this obnoxious "checking". It really hurt legitimate customer usage.


P.S. If you don't know what Process Explorer does, it is like an extended Task Manager, but it keeps a traveling ribbon-graph of CPU usage and what programs were using the most at any time in the history of the graph (maybe goes back a few minutes) among other things. One can also use it to increase the priority of a game program over other programs, or allow TRA to be the only program using a 2nd processor! Very helpful!
It can be downloaded from microsoft via: http://www.microsoft.com/technet/sysinternals/Utilities/ProcessExplorer.mspx

30th Jul 2007, 16:45
I have the same problem with the sound in Legend and the Anniversary demo, except in my case it's there all the time (the annoying sounds can be heard immediately after the game starts) and I don't have Process Explorer.
I searched the Internet and found out that it's a known issue with some Creative Sound Blaster cards.

The only real fix that I found and that works in my case is leaving Yahoo! Messenger on. Yeah, I know, silly, but it works for me. Don't sign in, just start the application and leave the window open. It reduces the annoying sounds significantly, even though they don't dissapear completely.

I'm not sure it'll work for you, too, but I think it's worth a try.;)

30th Jul 2007, 17:01
Why can't users "stop playing", then return to playing later and pick up where they last left off? It's a simple concept: when you pass a checkpoint, it records it as your current location so if you exit game and re-enter, "continue" picks up where you left off.

Huh? I must be missing something. Your description of how it should be, is exactly what happens in TRA. Checkpoints do get recorded and you can resume playing from the last checkpoint after you've exited the game. :scratch:

For sound cracking, have you tried lowering DirectX hardware acceleration?

31st Jul 2007, 09:28
The poor sound quality problems with TRA and TRL (PC versions) using certain cards has been a much discussed issue in the forum. Apparently Creative sound blaster live cards are big offenders, I'm not sure what others have the same reported problem.

I use an SB Live Digital 4.1 with latest drivers (2003 I think!). It's no longer supported by Creative and I get the static sound pops and garbled audio from the start when playing TRL and TRA, though it's given me no problems on any other games, and I've played a lot of games. TRA doesn't suffer as badly for me but it's still there.

Using dxdiag to lower the acceleration to 'Basic' seems to work for some people, not for others. I've also tried the trick of opening Windows Task Manager while the game is running, going to the 'Processes' tab, right clicking the tra.exe (or trl.exe) and setting the priority to 'Low'. Workarounds are a pain I know, but that seems to help, though only for a short while. After about 15-20 minutes into the game, it's back to the pops, squeaks and crackles. The Yahoo messenger tip is a new one to me so I'll give it a try. Can't say I'll be holding my breath though.

In despair I finally gave up and invested in another sound card (£7 on ebay) that isn't made by Creative. Right now I'm waiting for it to drop through my letterbox. Whether it'll make a difference or not, I can only wait and see, but I'll keep you posted.

What I'd really like to see here is a sticky thread listing all the sound cards that people say have given them problems, and all the ones that seem to work fine. That would help immensely in decision making. I wonder who'd start it though ? Here's my contribution;

Crap sound quality even with workarounds; Creative Sound Blaster Live 4.1.

Good sound quality without workarounds; No idea yet, but watch this space.


1st Aug 2007, 19:02
I have a Creative Labs SB Audigy SE.
When I first got this card, I had to lower hardware acceleration to stop the annoying crackling.

Then, shortly after the release of TRL, Creative Labs released a new driver and although non-WHQL, it did fix the crackling sound problem.

Now, just recently, I went and installed the latest Win XP driver from Creative for my Audigy SE that IS WHQL and the same crappy sound came back in TRA AND TRL!!

I have since gone back to the previous version driver I had, and all is good now.

I don't have the driver version numbers handy, but the one for my Audigy that DID work for TRA and TRL were released sometime in 2006 near the beginning of the year I believe.

I have no plans on going to Vista, but I can only hope Creative can get their act together soon, as it seems their drivers have all been getting worse lately and XP support will probably stop soon (if it hasn't already).

4th Aug 2007, 15:55
No offense to Creative, I'm sure they make some decent cards, but their driver support has always sucked. Trying to find the right driver in itself is a chore and a half. It's a bit of a lucky dip at the best of times. If your card is considered antique (i.e. more than 3 or 4 years old) then forget about any support. They'd much prefer you spent money on a newer card, even if the old one was working fine. Personally, I'll avoid Creative labs cards from now on.

Anyway, I got a new card today. A cheap clappy Chinese made Sweex 7.1 digital (£30, only slightly more than the game cost me) and it seems to be working fine with the drivers that came out the box, at full acceleration. Yay at last. :)

P.S., the £7 card I bought on ebay last week turned out to be a no-hoper. Wasn't even XP compatible despite the sellers assurances. I'm currently negotiating a refund.