View Full Version : Lego Star Wars & Windows Vista

20th Jun 2007, 23:30
I was able to install the orig Lego Star Wars under Windows Vista, but the game won't start. Says I need to insert the orig CD-ROM (which is in there already). I'm assuming this issue is due to the SecuROM system that tries to prevent users from running pirated versions of the game. But I assure you this is the orig CD from the game box.

Note: I have installed and successfully run Lego Star Wars II on this machine (users must be "Administrators" to get past this SecuROM check, but it does work). I've also had this copy of the orig Lego Star Wars previously installed and working on our WinXP box which has since bit the dust. I've also tried running the game under WinXP compatibility mode, to no avail.

So what do I have to do to get the orig Lego Star Wars to run under Vista ?

27th Jun 2007, 08:02
I had exactly the same problem. Eidos support more less ignored the problem
because of the unsupported OS :mad2: , but SecuROM warp-speed 24x7 ww support solved the problem in minutes :thumbsup: .

Follow the instruction on securom.com/support.
- Launch analysis by right clicking Lego Star Wars executable
- zip it with dxdiag output file
- send the zip file to support@securom.com

I got a new executable and that solved the problem.

27th Jun 2007, 12:52
Your advice is entirely correct. I ended up discovering on my own that the SecuROM copy protection was the issue and contacted them via their website.

The procedure described above is what they suggested and it, indeed, worked. I'm currently pursuing a similar issue with SecuROM on the LucasArts/Obsidian game Star Wars Knights of the Old Republic II and have high hopes for the same outcome.

I'm not a fan at all of DRM/copy protection which gets in the way of legitimate buyers & users, but SecuROM does score big points for fast, competent support (and for doing the job that Eidos/LucasArts should be doing - shame on them).

Russ Thompson
20th Oct 2007, 15:44
Unfortunatly, I do not know what a zip is or how to go back and forth sending fixes between web sites. My son would buy lots of this stuff ie we would buy it for him, he is a nut on Lego Starwars. Edios and Lucas needs to know that we will return this to Target make a big enough stink that they take it back and move on to any game he wants not manufactured by edios.

It's nice you guys understand jumping around on computer fixes I don't, I also don't change my own oil, but both with a reason. Neither do I understand, Neither do I have time to figure out.

Lucas / Lego / Edios I agree you need to fix this. :( :(

Jacob's Dad

27th Nov 2007, 05:11
Here's the response I got from securom support - this fix worked fine, and I'm now playing Lego Star Wars on Vista :)



Thank you for your e-mail. Please rename your original 'LEGOSTARWARS.EXE', (located here C:/PROGRAM FILES/GIANT/LEGO STAR WARS GAME/LEGOSTARWARS.EXE), to 'LEGOSTARWARS.OLD'. Then click on the link below or copy and paste it into your web browser. From the 'File Download' window click 'Open' and extract the new 'LEGOSTARWARS.EXE' into the same folder and re-start the application.

The link for the new file is:

19th Apr 2008, 01:31
i did that and got this message binkw32.dlll iwas able to play this game and now it wont play i get legostarwars.exe stop workin:lmao: :lmao: http://forums.eidosgames.com/images/smilies/schlapplach.gif

Captain Sarcastic
15th May 2008, 20:44
I was having the OP's problem under Vista Home Premium, with the out-of-the-box version of LSW. But with patch 1.2 installed I've found that the game appears in Vista's Games list, and starts perfectly (and so far has been running without a hitch) when run from there. YMMV obviously!