View Full Version : Croft Manor checkpoint bug?

4th Jun 2007, 22:05
Ok, I got my lovely game disc, installed, everything fine. Runs like a dream, sound is great, graphics and gameplay, fine.

I started off with the Manor to get some practice in. I did several areas, got the grapple, did some of the areas that the grapple is used for. Got to the pool room, passed over a checkpoint, and quit.

I passed over several checkpoints between getting the grapple and getting to the pool room.

I come back to the computer later, load up again, and proceed to the pool room, do some stuff, take a jump and press the grapple button . . . and nothing happens.

I have no grapple!

I went back to the gym, and it had rolled back to before I had finished it! I had to go get the grapple all over again, do the gym all over again, and the pool room.

I didn't quit at all incase it did it again.

I completed it and got to the music room, got the screen showing me the stats of what I had collected and what I had missed. Exited to main screen, looked at the extras I had picked up.

But when I load the Manor again, I am back to the main hallway with the fire still on! And everything undone again. I think that the extras stayed in the list, but if I want to properly complete and get everything in the Manor, it means every time I load I have to go from the same semi-done checkpoint :(

I have started a new profile but have not had time to test it out on there again, and frankly I don't know if I want to do half of the *whole* Manor and then find out I constantly have to re-do it.

Anyone else had a similar problem?

5th Jun 2007, 03:31
I just discovered this problem right now. Just completed the whole manor house with all 8 artifacts and they are gone. Whats worse is the normal game I started is gone too.

5th Jun 2007, 06:34
Well that sounds serious if the checkpoints aren't working for the game too, given that the only way to save means you end up back at the last (incorrect) checkpoint.

I'm going to try uninstalling and reinstalling the whole game, see if I have the same problem with Croft Manor, and see if it affects my overall game.

If I still have this problem, do the people that make the official patches etc. / give out bug fix solution keep an eye on these threads or should I email someone about it, does anyone know?

5th Jun 2007, 10:49
It could be something to do with this : http://forums.eidosgames.com/showthread.php?t=68786

(although I dont get any error messages, maybe because I'm using steam)

5th Jun 2007, 11:11
It could be something to do with this : http://forums.eidosgames.com/showthread.php?t=68786

(although I dont get any error messages, maybe because I'm using steam)

I haven't had error messages about my profile, but I'll keep an eye on that. I don't have Steam, I'm just playing it off the disc.

I'll try out with a new profile and install tonight, if I have the same problems I will try the other fix mentioned in that link there, and say what happens.

6th Jun 2007, 00:43
I had this happen once. No messages about profiles or anything, but when I returned to the game next day, it loaded a checkpoint some way back from where I had been the previous day. This was in Croft Manor.
What I then did was to quit to main menu after passing the next checkpoint and then immediately return to the game. This time, it had saved my location correctly. After that, it saved correctly every time and I am now some way through the actual game and it has not messed up again.
Something weird, though : I installed the game on my girlfriend's computer. Same game from same DVD. For her, it did the same thing but at a different checkpoint in Croft Manor and it has not saved her game since. I can tell you she is NOT happy. As she had 99% completed Croft Manor (only needed to get the Music Box drum back the the music room to finish, we tried copying my savegames and profile file onto her PC so that it would show a completed Manor and then starting a new actual game. This seemed to work, but then we realised (obviously) that it had retained the info about how many artefacts and relics I had collected. The relics were also in the glass cases in the Manor library. It fixed the problem with the saving but she wants to find the stuff herself so is having to start the game again from scratch. Boy, is she mad?!

6th Jun 2007, 04:15
Yeah thanks for the idea, I tried exiting after a checkpoint and returning immediately and it worked.

Now I have another bug though, less serious this time. Another one of the water cogs was on the boxes whilst I already had it, and I couldn't pick it up. When I placed the one I had I could pick up the second one so even though I've completed the level I have an extra useless cog in my inventory lol. Oh well.

6th Jun 2007, 05:08
Cool! A bit like being able to get 4 secrets out of 3 in one of the levels in Tomb Raider III (only a bit less nerdy).
Glad that trick worked with the saving problem. Maybe my girlfriend will listen when I try to get her to do that now. She was too upset to listen yesterday! Not that it's much use to her now as she has deleted her savegames in anger. She was in such a bad mood yesterday. And she's usually lovely. Amazing, the power of Tomb Raider! I think it was the thought of having to do that walk-run and jump again to get the 8th elephant in the Croft Manor gym. Must admit that took me a few tries!

6th Jun 2007, 16:57
Ok. I uninstalled, reinstalled as standard onto my set Program Files folder (before I did custom install and put it on another drive as I had no space), went straight into the game, and got three checkpoints in.

So far so good.

I'm going to load up the Manor now on that profile and see what it does to my game . . .

6th Jun 2007, 18:48
I've pinpointed it!

I made a profile, HelenGame and one HelenManor.

I started the game on HelenGame.

Then I started the Manor on HelenManor. After every significant thing - picking up something etc, I quit completely and checked if I'd gone back any checkpoints.

It's the water that does it. Got the wrench, no problems.

Turned the water on, filled the bucket up.

(I don't know if it's related, but although I saw the fountain heads spurt water in the cut scene, when I ran past them it triggered it again, one after the other although by now they were on already)

Went inside, put out the fire, got the arrow - I DIDN'T get one of those screens where it says "found item: arrow, ok to enter", she just made a comment about it and picked it up.

The save game point in the front of the hall by the note then didn't work - I ran all over it but didn't get a checkpoint note until I went into the swimming pool area. Ran back to the main room, checkpoint worked there.

Quit the game, re-loaded - the fire is still on, the arrow is where it was, I have an empty bucket instead of a full one, but no wrench. And all of the game on the HelenManor profile has been cleared.

HelenGame still has the progress on it.

So I suppose advice for now, if you're really desperate to do the Manor, then don't go past getting the wrench at the top of the gym! Or at least, make separate profiles. I really hope that there is a patch for this soon.

6th Jun 2007, 22:55
Hmmm. My girlfriend got the problem at a different point (in the pool room, I think).
We have fixed the game now though and it's working fine so far.
What seems to happen is that the program forgets where it has saved the games. If she saved a game manually, the savegame would appear in the savegame folder, but would not be available in the 'Load' screen. We found that you can launch the game by double-clicking a savegame file. The game then fires up and loads that game. We saw this as a solution to the saving problem in the main game, though not in the manor. However, after doing this once, we found that it now saves games correctly. It seems that it needed 'reminding' of where it was putting the saves.

7th Jun 2007, 07:43
I find it very interesting that my game 'forgot' back to the same point twice in Croft Manor.

Thank you for the tip about loading by double clicking the save game files :)

7th Jun 2007, 14:56
It happens to me, too. What a drag. :(

25th Jul 2007, 22:24
I'm playing the Manor and have gotten thrown back to the same exact point every time so far....I cannot BELIEVE that Eidos put this game out without properly testing it first....this is a MAJOR bug, that it doesn't save the game properly at checkpoints! I get to the point where I have to shoot the switch behind the painting, then go to the sundial, etc, go through the entire maze, get all the stuff, get to a checkpoint right after that...and TWICE now when I start to play the game again, after stopping for the day, I find that I am back to having to shoot that stupid switch behind the painting.

Does anyone know when Eidos is going to put out a patch for this? I have tried some fixes I've seen online and nothing has worked so far. :mad2:

26th Jul 2007, 13:30
Like I said...just make sure you exit to the menu and then resume the game to make sure it has saved it. If you do this before shutting down for the night, you should be OK.

27th Jul 2007, 17:11
Like I said...just make sure you exit to the menu and then resume the game to make sure it has saved it. If you do this before shutting down for the night, you should be OK.

I tried that already; it didn't work. It didn't save it. *shrug*

2nd Aug 2007, 22:45
If you're running Vista, run the game as administrator. That did it for me.

3rd Aug 2007, 08:20
If you're running Vista, run the game as administrator. That did it for me.

Thanks for trying to help....but I don't have Vista...

Anyway, what I ended up having to do was just leave the game running over the course of two days (last weekend), and I just went through the entire Manor.

After I got through everything, out of curiousity I quit then went back in to see if anything had been saved since that checkpoint in the library.

It hadn't, but at least I got through the Manor. Not a good idea to leave the computer and game on constantly but it was just for two days.

Now on to the game itself...it's just too bad that there is this glitch and Eidos released the game with these problems. And no downloadable patches/fixes for it yet... :mad2: