PDA

View Full Version : certain briefing movies cause T2 crash - solved



Komag
14th May 2007, 05:54
I would get crashes with the recent FMs Dracula and Lord Alan's Factory. They start loading up, but when it comes time to actually start, the point where the briefing movie (if any) would play, they crash with the typical Windows error message asking to send report to Microsoft or not.

After researching on these and other forums, I concluded it was a codec problem that only a few people ever come up against. This is entirely different from the very common problem of all Thief movies not playing anymore, which can be fixed a few ways, listed in FAQs everywhere. No, this is something with an unknown solution, something that is rare enough and also hard enough to pin down that the most common solution is to just watch the briefing movie separately and turn it off for the game, which is no solution at all.

I have K-Lite codec pack installed on my computer, with "ffdshow" and "vobsub" active.
I noticed that when Dracula would crash, I would see the "vobsub" green arrow icon leftover in the system tray, but when I moused over it it would just disappear, so the icon was a ghost, having already turned off. This told me perhaps vobsub or ffdshow is at the root of the codec conflict. Also I knew that Dracula uses Indeo codecs too.

Soooooo

I went into my K-Lite program shortcuts and started "Codec Tweak Tool", in which I scrolled down to all the sections "Disable the following filters" (there are three or four sections) and disabled anything close to "ffdshow", "vobsub", and "Indeo".

Then I tried Dracula again and it quit (but not crashed) with a message saying it needed Indeo, so maybe I shouldn't have disabled the Indeo ones (but I just wanted to clear the slate from the K-Lite). So I just installed the Indeo 5.11 installer (available on the Dracula site and elsewhere, usually "iv5setup.exe"), and then Dracula worked! Woohoo! Lord Alan's Factory works now too, great!

I probably should have just turned off one thing at a time and tested it that way to know for sure the exact culprit, but at least now I know pretty close. I'm guessing that most likely if you just turned off the "vobsub" and maybe also the "ffdshow" it will work.

bikerdude
5th Jun 2007, 10:04
So I just installed the Indeo 5.11 installer (available on the Dracula site and elsewhere, usually "iv5setup.exe"), and then Dracula worked! Woohoo! Lord Alan's Factory works now too, great!

bah, Komag you should know better, the indeo codecs is an old one! but thanks for the heads up on the ffshow, namless has had a prob with that. looks like a lot of taffers are usbing the k-lite codec pack.

biker