View Full Version : Square Enix Account: Password Issues

15th Jun 2013, 17:20
Unable to log in to your account due to having issues with your password? Contact customer support (https://support.eu.square-enix.com/contact.php?id=612&la=2).

If you cant log using the one time password leave it blank and just use the regular password without using the one time password... it helped me that way...*

15th Jun 2013, 17:35
I used my Square Enix ID and Square Enix account at log in and left the one time password blank, still wouldn't let me start the game. Have any other recommendations?

16th Jun 2013, 12:07
I was having trouble logging in as well, then I switched over to try it on Explorer rather than Firefox. Not sure what the difference was but it let me in with Explorer. Now if I can just get the program to download.

15th Aug 2013, 23:39
Good evening, i post this here because i unfortunately don't remember the Square Enix Account Password of my original Account, nor my Security Question and it's answer.

Since i don't know the last two mentioned, i can't follow the steps of the Recovery Password things.

I haven't been using the Account for a long time, buy i want to know beacuse the release of Final Fantasy XIV: A Realm Reborn (In that account i got a lot of things registered).

What can i do?

Thank you very much and sorry for the inconveniences.

21st Aug 2013, 02:16
Hello guys

I've forget my Secret Q&S, what should i do ?

21st Aug 2013, 21:13
I'm not sure if this is just me, but couple days ago, my SE security token app reset it self as if it's not registered. Luckily, I have my emergency removal password and I able to removed and registered it to my phone once again. However, it happened again the next day where it asked me to register to the phone. I have to wait 24 hours before I can remove the token once more, and it would be really pain in the butt to keep doing so. Now, I don't know how the app keep the registration info but I don't know it's the SE account server or it's my phone who is the culprit to this problem. It would be great if anyone have any information regarding this issue.

Thank you

28th Aug 2013, 19:48
Hello everyone, I am writing here to try to solve my problem with one time password in practice yesterday download the app on my phone, configure the account and so far so good .... Today I am going to come into play I open the application on my phone and this requires me to new nick,date of birth and registration key application account .... Now I'm stuck because the application wants the data that I can't provide it in when not having the one time password because I can't get into my account .... Do you know how I can fix?

4th Sep 2013, 20:10
up...pls cna anyone let me an answer....no repsonse from supporc center what can i do..... -.-"

6th Sep 2013, 02:49
I have the same problem and customer service so far not answered any of the emails I send.
For anyone who is thinking of using the Software Token IS VERY BAD do not use the app.

13th Oct 2013, 11:03
Had this problem multiple times. Each time for me without fail, it's after my phone has run out of battery or I've switched it off. At this point it's become more trouble than its worth to keep the one time password on my account as every time I need to apply the emergency password removal and then re-apply the token software. Seriously it shouldn't be that difficult to fix. So basically I agree, it's a rubbish app at this point.

29th Oct 2013, 18:46

I cant change my password because i cant remember what i put my age when i was younger. plz help?

2nd Dec 2013, 02:07
I dont ever recall setting emergency removal password.

I changed phone over the weekend without access to my old one which I used to use authenticator on.

Now I cannot replace it without this emergency removal pw. Please help.

8th Apr 2014, 13:47
This is the 5th time Square warned me someone been acting foolish and I need to reset my password! I am sick to death of them doing this!!!! Stop harassing me you morons! It's me and I am doing what I want with my account stop forcing me to reset!

8th Apr 2014, 15:13
What are you talking about? What message are you getting?

3rd Jun 2014, 01:18
I am unable to access my account on the store page. Everytime I click the forgot password link from "https://store.na.square-enix.com" I get redirect to "https://membership.square-enix.com" after entering my email address I get redirected again to "https://secure.square-enix.com" when I put my email address in there is says that I was emailed a password change link. When I change my password it says it was done successfully but then when I try to log back in on the store page I get the INVALID PASSWORD message. I have no idea what is going on. I emailed the support page but all I got back was a "please click here to change your password link" which of course doesn't work. Can somebody please help me because I can also not find a phone number to call????????????????????????????????????????????????????????

3rd Jun 2014, 16:16
Have you tried to get in touch with chat support (https://support.eu.square-enix.com/contact.php?id=612&la=2)?

4th Jun 2014, 07:36
square enix support sucks it has the worst work times on phone calls and EVEN their chat support has the same times closed at 5-6PM? open at 9am? and only mon-fri really? worst ever

13th Jun 2014, 19:49

I am looking for advice here please.
Sold the phone, which had an application with the security token installed. Restored the phone to manufacturing setting prior to selling but forgot to log in and remove the security token settings from my game account. Now I can't log in because it's asking me for the security token, which I obviously don't have access to anymore. I installed another application on the new phone, but I can't get because again, it's asking me for this security token. I can't even delete my account anymore nor cancel the subscription without this token! Absolutely ridiculous! Please help

9th Aug 2014, 18:57
I've been trying to log in for a while now and it keeps saying my password is incorrect!! I don't know what's going on! I need to log on to activate my Software Token but it won't let me. I've used my email address AND Square Enix ID COUNTLESS TIMES! Am I doing something wrong. I can log on to the site perfectly fine with both my ID and email address. It's just that it wont let me into the account management system. If anyone has a solution, that would be greatly appreciated. :mad:

18th Oct 2014, 19:25
I'm having a problem. I recently switched phones - I no longer have that phone. It's asking me for an Emergency Removal Password code to remove the software token from my account. The problem is...how can I do that if I can't use the software token application because I have a new phone? It's asking me to use my software token in the place I can't use it. The email for said emergency removal password token takes me to another screen to log in but I still need to use the software token app to log in. I'm not sure if this makes sense to anyone.

It's the weekend so I can't contact customer support.

22nd Oct 2014, 10:27
I made an account on Square Enix the day Final Fantasy XIII came out (if not, it didn't passed many days after).

But now I wanted to re-enter the the account and I can't acces because of Password.

I tried to recover my password but I forgot which security question I choosed.

I wanted to know if someone of Square Enix could help me please.

10th Nov 2014, 04:34
I am 5 hours in to trying to log in to a game that I paid $50 for. I can log in on my computer but not my phone or ps4. I have also had to reset my password 6 times now. Why in the hell do I have to have a phone a laptop and a ps4 to play a game. I dont need help I give up the game just went in the trash.

1st Jan 2015, 19:40
Ive lost my phone and can only login in the forums, so now i need some help guys . I did not write down the removel code . Could you guys delete my token app on my acount becus i would love 2 play the game again . in the support section of the site ive read that i needed to contact you but could not find a link of email so i thought lemme check the forum. Greetz gr3garius

12th Jan 2015, 11:19
I'm trying to reset my password for the 1000th time because each and every time i try to login it's telling me it's wrong when i know what my user and password is but it's been giving me an error in the password reset screen saying the ONETIME password cannot be only letters or numbers but the product that gives this password is ONLY numbers....

The fact that the page itself is generating an error against it's own device functionality being only numbers is extremely annoying.... Please destroy this page and just send us a random letter / number password to login with to OUR e-mail directly, going through such an annoying process that is fighting against itself is becoming a difficulty that is making me never wish to want to interact with the company or it's products ever again.

13th Dec 2015, 03:48

I haven't used my account in a long time & i've changed mobiles a few times since then & I can't remove the security token.

Any admins/tech support please help....

Thank you

24th Dec 2015, 12:05
can't login or register at https://secure.square-enix.com/account/app

i tried to use the same info as I'm using for this page/forum but it just says wrong ID or password
I tried to register a new account but when i come to the "retype your email" I just can't type in @, it just won't let me and so the email is not correct and I can't register

25th Dec 2015, 00:37
same issue here on mog station, been trying to log in for 2 days to redeem a product key and it keeps saying wrong username and password.. even thou is the same info i use on this site.:scratch:

19th Mar 2016, 01:13
I made account long time ago on my normal email account I use so the account name i use on it i forgot the password to it so i went to recover it the system where asks for the email i used so can send recover link for it but it says there no square enix account under it even know i enter everything right but still don't work. I thought uh i try register with it then so i did and says email has already been taken so i am confused why i can't use the forgot square enix ID or Password. I then made this account under my old email address that i use once in a while so I dumb enough forgot the password for this didn't right it down as i wanted to test the recover thing as i thought it did it again for this account it says there no square enix account with this email address.

I am sorry late at night and so i tried to word best can is there anywhere i can recover any of these accounts password??

19th Mar 2016, 17:49
I havnt played for a very long time so I tried to reset my passward got the code to do so and got to the page to do so I enter all my info but when I got to security question it don't work I don't know what to do can anyone help

1st Apr 2016, 20:22

I have lost my password... I have no idea what it is. And i cant find ANYWHERE to reset it... Also, how do i the Square Enix ID that i need for games?