PDA

View Full Version : Thief III - not load anymore after crash



Faults
30th Mar 2007, 09:14
Hi,

I have odd problem with Thief 3. Sometimes it crashes in random places and after that it wont anymore load. I killed manually T3.exe and T3main.exe from task manager process list, but that not help. Neither if I reboot my computer. When I try to launch Thief only those 2 processes pops in process list, but nothing happens. After reinstall it works. I had to reinstall Thief three times now. Quite annoying. Any ideas? Some file corrupts on crash maybe?

I have AMD Opteron 175 (dual core). I use imagecfg to disable second processor when running Thief. I also checked from processes list affinity thing that there is only one CPU selected.

Nvidia 7800 GT, 2048mb ddr1 and Windows XP. Those are other specs

tcrew
11th Sep 2007, 13:59
Hi
Similar problem here. At least I might guess why you have to reinstall to run it again. In my case the problem is that, when game crashes, most of the files from the 'System' directory are REMOVED !!!
Please confirm if this is happening for you too.

I do not know the solution but behaviour is very odd! I have tested two TDS releases, US and Europe. Both v1.1 and both do the same.
I tested several options:
- selecting 1-proc operation only (for core-duo machne) for t3.exe and t3main.exe and hight priority
- selectin XP compatibility

Nothing helps.

Steps to crash are as follows:
- install and run
- you can see/break intro ads
- then select 'new game'
- then press 'OK' (when brightness slider is shown)
- then press 'Start' (when objectives are shown and are being read)
- now game is abaut to be loaded, the load progress bar (diamonds) shows immediatley as it was indeed, black screen as background. About that time files are removed.

Anyone can tell what and why files are removed? I am guessing if they were not removed game would start...

tcrew
12th Sep 2007, 12:14
I should mention system spec:
- intel dual core
- nvidia 8600
- vista 32b
- nvidia beta driver 163.67 + vista hotfix

tcrew
13th Sep 2007, 18:51
In addition to previous post, most o the files from System directory are removed except the following:
binkw32.dll
eax.dll
metadata.ion
t3.exe
T3Gamesys.t3u
T3Main.exe

But one file is created here:
TravelData

Any hints?

kingtriad
24th Mar 2008, 16:35
I experienced the exact same problems as described by tcrew.
After many hours of hunting, it seems that the problem is related to how the OS (prob. Vista only) handles Saved Games.

This is my solution -

1) Start with a completely fresh installation of the game. This will ensure that all files in the System folder are present and havent been removed previously. Run the v1.1 Patch straight after installing as well.

2) Create a new folder for save games, preferably one can be accessed by all Users (eg. C:/SavedGames/Thief - Deadly Shadows).
3) Go to Start -> Run -> regedit

4) Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Ion Storm\Thief - Deadly Shadows

5) Right-click SaveGamePath and click Modify...

6) Change this value to the path of the save game folder created earlier (eg. C:/SavedGames/Thief - Deadly Shadows).

7) Run the game

Where it would crash previously (with black screen with health bar / light gem at bottom), now it runs Ion Launcher.exe automatically after a few seconds.

I had tried all the fixes to CPU Affinity, imagecfg.exe and XP compatibility before this without success. The game seems to run fine with just this Registry change.

PS. my specs -
Sony Vaio AR41S laptop
T7500 2.2Ghz Dual Core
2GB RAM
GeForce 8600M GT
Vista Home (32bit)
DX10

ReddShadoe
7th Apr 2008, 01:06
I just registered for this forum solely to post this thank you! I had been Googling for weeks trying to figure out why my Vista system kept crashing with the power gems and compass after loading up. I kept reading about disabling cores (I have quad core), but it didn't help. After crashing at that screen, any new attempt to launch Thief would result in "Thief has stopped working..."

This registry fix and SavedGames folder trick worked like a charm, so glad to see this awesome game will not have to be shelved.

:thumbsup: :thumbsup: :thumbsup:

Melic
30th Jul 2009, 15:47
Hi,
I was wondering if anyone found a fix to tcrews problem, as i am having the exact same problem.



Steps to crash are as follows:
- install and run
- you can see/break intro ads
- then select 'new game'
- then press 'OK' (when brightness slider is shown)
- then press 'Start' (when objectives are shown and are being read)
- now game is abaut to be loaded, the load progress bar (diamonds) shows immediatley as it was indeed, black screen as background. About that time files are removed.


I have tried all the fixes listed, except for the registry change because those registry entries do not exist (after a fresh install + patch)

Any assistance would be greatly appreciated,
Melic.

EDIT: I found what went wrong; The registry entry was in a different place, it was in
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Ion Storm\Thief - Deadly Shadow

I dont know why mine had an added folder :/
Also this entry did not showup using the registry search function.

Garret47
31st Oct 2010, 17:17
hello there, i know this is a pretty old thread but i've just registered specifically to post a further question and i really hope someone here can help me. originally i had the same problem loading my saved games after a crash (at the end of St Edgars Church), with only one difference (it got stuck on the load page in the menu rather than later on as the others have described). i found this thread and decided to try the suggested fix however i'm not even passed the second step before hitting a problem that as far as i can see (after a short while forum trawlinf) is highly singular if not totally unique. the game refuses to patch, have tried 3 seperate patches from here, gamershell and fileplanet and each time i am told

"Patch Error: Old file not found. however, a file of the same name was found. no updates done since file contents did not match"

could it be because i bought the game on the SoldOut label? i've never had any trouble with soldout software before though this is the first time i've used it with vista... any ideas? never completed the game before and this has started happening just as i was really getting into it, please help!

Garret47
31st Oct 2010, 18:23
game had installed fully updated, so it was soldout... but it wasn't a problem... i'll make another post when i know if the fix for the original problem has worked

Garret47
1st Nov 2010, 20:28
fix did not work, no files missing from system directory, st edgars again, bumped into a guard and decided i wasn't happy so i reloaded and it just got stuck on the loading screen, ctrl+alt+del was all i could do. tried loading an earlyer save and got the same result, even tried changing ionlauncher to xpSP2 compat and run as admin, no avail. starting to depress me slightly :( i don't even know if this is going to be seen by anyone before this age of darkness the keepers keep mentioning arrives......

bloodhunter
29th Jul 2012, 16:45
I have the same problem, the game loads up to the moment when you begin the mission, then diamonds briefly show up, flash of a background picture with Garrett and that's it, the game stops working.
Have tried the registry fix many times, uninstalled the game as well.
My game is original 1.1v and has worked on this computer before :(
I have Vista 32bit on a HP laptop.
No idea what to do :( Have tried setting the alignement and running as admin and swithing off the cores, running out of options :/