PDA

View Full Version : Thief 3 Problem - Read please!



gissoni
18th Feb 2007, 13:19
When I try to play T3,It runs normally until the First Load (After the "Eidos" And "Nvidia" Logos),When It reaches the load,the game closes and go direct to desktop...
I Already Tried to Reinstall,I've Installed 7xxx and 6xxx Nvidia Drivers and Unplug the USB's,nothing works...please,someone Give me a hand :mad2:

PC : Sempron 2.6+,Geforce 5200,1gb Ram,Hd sansung spinpoint 80gb,Asus A7V600-x

theBlackman
19th Feb 2007, 21:25
If you are running XP, then START>RUN>CONTROL PANEL>ADMINISTRATIVE TOOLS>EVENTS.

Check SYSTEM and APPLICATIONS. At this point, clear both files (lists) you can do this in the upper right FILES section.

Find and run a VIDEO DRIVER CLEANER. Then re-install the latest drivers.

Do a complete uninstall of TDS from the ADD/REMOVE. When that is done run a SEARCH for any TDS reference and DELETE IT. Run a Regseeker or cleaner program.

Then re-install and try again.

If the drivers for the VCARD don't seem to work, run the VIDEO CLEANER again and install your next choice of drivers.

After EACH attempt at any of the listed "tweaks", if it fails: CHECK THE EVENTS.

CHECK: SYSTEM>DEVICE MANAGER for any large yellow ! and make sure the device mentioned is operating properly.

Then replay (or try to the game). As soon as it crashes, look at EVENTS. There will be a RED X marking the error that crashed you, or a Yellow warning sign.

A right click on the line will give you more information as to what specifically caused your problem. There will also be a numerical error code. You can GOOGLE that code and get more information.

gissoni
26th Feb 2007, 02:57
It didnt work....and dont appear anything in the event thing...=(

trancer-necromancer
25th Mar 2007, 02:31
thief 3 is not working on my system. i downloaded and installed the demo and the game loads and the video plays, when i press esc it shows me the menu for a second, then the video plays from start again! if i try to press esc continiously and click on the new game/options menu, game becomes stuck.

cpu: amd athlon xp 4800 dual core
video: nvidia 7800gtx
ram: 1gb
video driver:latest


any ideas whts up?

Peter_Smith
25th Mar 2007, 05:19
Do a search for "dual core". That may be your problem. For a start, set affinity of the Thief process so it runs on only one processor. Good luck, and please report back with your solution if you find one.

trancer-necromancer
25th Mar 2007, 07:27
thanks Peter your suggestion worked. ran the game, then pressed the window key and then changed the affinity. and then had to click on the process again, select bring to front to get it back to fullscreen again.