PDA

View Full Version : Linksys WRT54G Router finally able to create server.



jwhal
17th Feb 2007, 15:50
I had to set my router to DMZ and disable the UNnP as stated in other threads but this did not work for me until I updated my routers firmware.

It didn’t work with the original firmware I was running that came with the installation disk.

This router has 6 different versions so you need to look at your installation disk for what version you have mine was ver 5 and go to the linksystem site and update.

To update go to linksys.com in there download section find the router ver you have and download the latest firm ware.

In your router settings click the administration tab then the firmware upgrade tab click browse direct it to the file you just downloaded then click update.

When done while still in the Administration click the management tab and disable the UNnP.

Next click the Applications & Gaming tab then the DMZ tab and enable DMZ and set the host IP to 192.168.1.100 which is the default start IP the router starts giving your computers unless you changed that in the Basic setup tab.

This is what I had to do to get my router set up to create servers with Battlestation Midway no port forwarding no downloading gamespy just setting my gamespy settings in game and registering a name and password.

I hope this works for others it worked for me.

BlackLotus
17th Feb 2007, 17:59
I had to set my router to DMZ and disable the UNnP as stated in other threads but this did not work for me until I updated my routers firmware.

It didn’t work with the original firmware I was running that came with the installation disk.

This router has 6 different versions so you need to look at your installation disk for what version you have mine was ver 5 and go to the linksystem site and update.

To update go to linksys.com in there download section find the router ver you have and download the latest firm ware.

In your router settings click the administration tab then the firmware upgrade tab click browse direct it to the file you just downloaded then click update.

When done while still in the Administration click the management tab and disable the UNnP.

Next click the Applications & Gaming tab then the DMZ tab and enable DMZ and set the host IP to 192.168.1.100 which is the default start IP the router starts giving your computers unless you changed that in the Basic setup tab.

This is what I had to do to get my router set up to create servers with Battlestation Midway no port forwarding no downloading gamespy just setting my gamespy settings in game and registering a name and password.

I hope this works for others it worked for me.

I had the same problem... You didn't have to put your PC on a DMZ (which is extremely risky...), the problem was the UPnP part. I had done some testing with that the day after the game came out and reported the problem to Eidos's tech support right away...

The game server seems to dynamically create a "dnpsvr" connection on port 6073 UDP pointing to ip 192.168.1.255 and if it's still present in the UPnP connections the before you start a server, it will crash to desktop with the "battlestationsmidway.exe encountered an error..." error. I was able to confirm this by clearing the UPnP cache before creating a server which worked. The permanent solution is to disable UPnP until Eidos fixes the game... Leaving UPnP disabled may cause problems with other applications such as MSN Messenger (for file transfers, voice chat or remote assistance)...

Evilmonkee
17th Feb 2007, 21:12
I too got this to work but I didn't need to go on the DMZ.

Previously, I needed to disable UPnP just to be able to join a server. I was still unable to host a game though. I am using a Linksys WRT54G v6 router on Comcast cable w/windows firewall enabled(no other software FW). I had also opened/forwarded all the ports listed in the readme and here on these forums, but I was still unable to host a game.

I thought I had the latest firmware for my router(version 1.01.1) but after seeing this post I decided to check for an update. Sure enough there was one release on 2/7/07(version 1.02.0).

After upgrading the firmware and leaving my router settings the way they were(UPnP=disabled, DMZ=disabled, relevant ports forwarded), I tried hosting a game and it worked!

I'm not sure what it was in the new firmware that made the difference. The changes are listed below.

Firmware 1.02.0
- Improves compatibility with BitTorrent.
- Resolves issue with not being able to block HTTP or PING on computers that are specified in the list of PCs.
- Resolves issue with presenting bogus error message when user is trying to set ‘upstream bandwidth’ to AUTO and save the setting.


It would be nice if disabling UPnP wasn't still required. I haven't noticed any negative effects after doing so, so I guess I can live with it. It's nice to be able to host a game now.

jwhal
17th Feb 2007, 21:36
Turned off the DMZ and forwarded UDP ports 6500,1042 and 2302 and all is working fine.

For some reason it was just the old firmware other then having to disable UPnP everything seems normal.

Hinge
24th Feb 2007, 22:06
upgrading to firmware 1.02 solved my hosting/joining problems as well.