View Full Version : cannot connect to multiplayer

10th Feb 2007, 21:05
Ok, sorry if this has been covered but i've searched the threads multiple times and never found a solution that worked. When i start up the game i click on multiplayer and internet game, then using a new gamespy ID i made just for this I click "login selected" and it says "nickname error". I tried installing gamespy arcade and going through that, but it doesnt even show the game. it shows the demo, which i have installed, but not the full game. with my original gamespy ID is says its unregistered and then i try to register and it says "nickname error". Can anybody please help?? I'm trying really hard not to get angry about this..

11th Feb 2007, 08:32
Another gamespy troubleshooter. Brings back memories from Battlefield2 where it are all the same issues and goes with all games who uses logins via Gamespy!

1st, you dont need Gamespy arcade at all unless you want to manage your profile in specific details! although, you can do this via http://www.gamespyid.com

2nd, if you already have a Gamespy ID, you can use that one to log in. if the nickname, emailadress and password are equal then on your id. Login with your details and check the registered nickname on http://www.gamespyid.com

3th, if you dont have an account and want to be sure you've got somewhat the nick you wish, register via https://login.gamespy.com/login.aspx (use the right pane to register)

Even I had troubles registering my nickname in BF2!

11th Feb 2007, 16:36
My problem lies not with logging in, but joining games.

I have an existing Gspy account that I have logged in with, and can see available games.

Yet have I been able to play however. I select a game, it pauses, clickes a few times, and says "lost connection" or Unable to connect or something of the like.

I have been thru these forums top to bottom, tried opening ports suggested. I know I am opening the ports in the right place because I had to do it to get BF2 to work, and that works fine. I dont have a router, I have an ethernet switch because I have 2 IP's for 2 PC's. But in my troubleshooting, I removed that from the loop, and connected directly from my cable modem to my PC...

Are there more ports? Is there truth to what I read about trying a fresh account on g/spy?

I'd sure love to try this game....:mad2:

11th Feb 2007, 17:30
well, i made a third new gamespy account, and that didnt work, then i was screwing around and did the same thing i had done several times before and voila! it randomly worked. great, so now i can connect and join servers and get into the gameplay that i paid 40 bucks for. oh wait, never mind, theres horrendous ping that makes my ships and planes uncontrollable and ever actually hitting anything impossible. so this game is basically unplayable for me. great

11th Feb 2007, 18:23
I didnt registered an new account on gamespy as my 4 yr old account succesfully logs in and I can play well. I know it is somewhat missing. Yet what are the pings of hosts you're trying to jump into. Dont trust hosts with 0 ping and dont trust servers with pings over the 150's. Even a ping of 90 can be deceiving...

Btw, do you SPI/QOS enable or disabled. Be sure that both are disabled since both of these are certainly providing me headaches!

Perhaps what could help is viewing the Hosts response time instead of ping?

11th Feb 2007, 19:00
not really sure what SPI/QOS is all about. how do i go about disabling this?

11th Feb 2007, 20:01
I am having the same problem, i try to log in with one of my 3 gamespy accounts and it gives me the error "unregisterd or expired nickname" and then when i try again i get nothing just the "please wait" screen forever. I have been to gamespyid.com and checked that my profiles are correct and they are. I have turned off windows firewall and nothing seems to work. Please help me!

19th Feb 2007, 09:59

I had the same problem, couldn't get my new accounts to work, just got the "Unregistred or expired nickname" message. I could login to gamespyid, and there was nothing there saying it shouldn't work. However, I downloaded gamespy comrade, and tried to log in with my nick, wich didn't work, so i logged in with my email adress instead, and got a message that something was wrong with my nickname. Although no one else had it, I had to edit my options in Gamespy Comrade to another nickname and back again to the first one to get it to work. Then i could log in to Comrade, and it also worked in battlestations midway!

Problem solved! (I hope!)


vnb warden
19th Feb 2007, 11:37
i too get the nickname error, but i just click through and it lets me play, its quite odd

i only see around 4-8 servers on the list, does that sound right

ps: PC version

19th Feb 2007, 13:44
Yes there's always something of 4 to 8 servers available. To my experience, the Connection Lost message is because the server is full before you tried. (The booklet says, refresh the list, but I don't see a refresh button, so just keep trying)

20th Feb 2007, 15:25
Can we say a patch is needed. :mad2:

23rd Feb 2007, 22:50
question does it even work if you get past this crap mine yet to work and has all these symptoms tried everything they have with the same results. And why is this with gamespy any way they told me they dont even have access to this game exept demo crap $40 down the tube oh ya wow the 4 hour single player!

23rd Feb 2007, 23:13
Can we say a patch is needed. :mad2:

yes you can and one is in teh works.