PDA

View Full Version : Problems with Thief Gold and Windows XP



avva_necate
27th Sep 2006, 14:50
Hi!

I want to play with my Thief Gold under Windows XP HE, but I've a problem. I installed the game by typing ":\setup.exe - lgntforce" from Start Menu -> Run. The installation works without any problem, the intro and the movies works and I can change the options for the game.
But, when I start any mission or the training, the level begins and then (from 5 sec to 2-3 minutes) the game freezes! Nothing works (but the sound of game goes on), and I have to do an hard reboot from the reset button!
I have read the FAQ and all the problems about movies and codecs, but the movies (intro and movie for mission 1 and for trainig) work well. The problem is when I begin to play the level.

What must I do? Please, help me!

My specs:

OS: Windows XP HE 2002 SP2
RAM: 960 MB
CPU: Intel Pentium 4, 3.06 GHz
Graphic Card: Sis 661FX/GX Mirage Graphics
Hard-Disk: 200 Gb (FAT32), 2 partitions of about 91 MB
Audio: Realtek AC'97. I have also installed the ASIO4ALL drivers.

Thanx.

Bye,
Ste

avva_necate
28th Sep 2006, 20:22
Update about this problem:

I have checked the compatibility for the thief.exe. I tried compatibility for W95, W98/ME, W2000, but the game does not work, because the screen becomes black at the beginning of any level and I have to close the game with ctrl+alt+del.

I tried to put the hardware option off in the game options, and I have found a little little difference. When I play a level, the game freezes as always, but I can close the game and return to Windows by ctrl+alt+del. So i can avoid the reset button.

Info added: my thief gold is an european version.

I hope someone can help me. :-(

Thanx.

Bye,
Ste

cradle_curdled
28th Sep 2006, 23:58
Did you refer to the "Game crashes" section of this FAQ (http://support.eidosinteractive.com/GI/CustomerSupport/FaqSearchResults_AltList.jsp?game=122&platform=3&problemType=10)?
Specifically, the dual-processor fix and Intel video card sections might cure your problem.

Also, you definitely don't have to mess with the compatibility mode to get Thief Gold running in XP; just run it normally. When I set my comp mode to Win98, it actually invoked this famous black screen that everyone talks about. As soon as I reverted, no problem.

avva_necate
29th Sep 2006, 13:44
Did you refer to the "Game crashes" section of this FAQ (http://support.eidosinteractive.com/GI/CustomerSupport/FaqSearchResults_AltList.jsp?game=122&platform=3&problemType=10)?
Specifically, the dual-processor fix and Intel video card sections might cure your problem.

Also, you definitely don't have to mess with the compatibility mode to get Thief Gold running in XP; just run it normally. When I set my comp mode to Win98, it actually invoked this famous black screen that everyone talks about. As soon as I reverted, no problem.

I see the FAQ page, but my problem is not related to the presence of the dual core CPU. I don't have a dual core, just a Pentium 4.

Ste

Eshaktaar
29th Sep 2006, 20:23
I see the FAQ page, but my problem is not related to the presence of the dual core CPU. I don't have a dual core, just a Pentium 4.

StePentium 4 uses hyperthreading, and that's what causes the freeze.

From TTLG's FAQ:

When activated, Intel's Hyperthreading makes it appear that you have two CPUs. Pentium 4 D and Athlon 64 X2 processors have 2 cores on one chip - they are dual processors.
Make sure that Thief is set to only use 1 processor with High, or Realtime priority. Dark Engine games don't like dual processor systems unless they are configured in this way. Salvage has written a great FAQ on how to do it easily. You can find his FAQ here (http://www16.brinkster.com/salvage/thief/darkengine.htm).

Peter_Smith
30th Sep 2006, 01:24
Eshaktaar is right in that hyperthreading, if enabled, makes a single processor look like dual processors to the operating system. Use the Task Manager (ctrl-alt-delete) and check the Performance tab to see if the hyperthreaded dual processor emulation is enabled. If you see two processor windows, treat it is dual processors and follow instructions for same. Another option is to turn off hyperthreading in the BIOS and deal with a single processor only.

avva_necate
30th Sep 2006, 12:13
yeah! Great! Great! It seems to work! It works!

Oh yeah!

I thanx you all. Thanx u, Eshaktaar, Peter Smith, cradle_crudled! I can play at the thief gold, now! :) :D ;) :D :)

Thank you! The great Thief Gold returned alive on my PC!

Bye,
Ste