View Full Version : Do I need a older or a newer driver.

23rd Jul 2006, 19:00
I have tryed the naval battle of the tutorial and it's working perfectly on my pc. Nevertheless I can't play land battles, neither the tutorial nor the ones in the campaign. I always get a blue screen at the beginning and then the PC restart. A couple of times after it restart I had a message regard my graphic card. It's ATI Radeon X600 256mo, the driver version is ata2dvag.dll6.14.0010.6530 and date From 3/8/2005, it's just a month before the release of the game. I have read that someone had this problem and he put a old driver (catalist 5.09), today it's 6.6 I believe. That's really weird. Can't we have a new patch instead! I don't know how to do those things. Is anyone could tell me what to do? I am going to spend days on it and my pc won't work!

23rd Jul 2006, 20:27
If you can find newer drivers try them. Also the restarting could be due to your computer (well most likely the graphics card) overheating.

You can disable the rebooting by:

right clicking my computer/properties/ the advanced tab/restart and repair settings (or something, I'm translating from a Dutch version so..), uncheck automaticly restart the computer. See what that gives, a long with the driver update.

25th Jul 2006, 23:21
I am afraid it doesn't work. I have now a blue screen and I need to shut down the laptop manually.
I don't get it, I bought the laptop last october and I ask for upgrades like 512mo + the ATI Radeon X600 256mo. The driver is dated just a couple of month before the game was released. It can be over heated either, because it happen even when I just switch on my PC.
Could it be from the CD, I bought from an ebay shop for $14 shipping included. The boxe was pretty bad, and for this price I am just wandering if they sell what eidos put in the trash. Did it happen to somebody else?

27th Jul 2006, 13:34
The CD should only be checked at the very start of the game, so no, can't really imagine it has anything to do with it.
Otherwise I could not really tell what's wrong, for every game there are a few hardware combinations that simply don't work with it for arcane reasons, I hope you are not one of the unlucky guys in this case :(
You might still try to play around with the settings of the catalyst driver (I think the newest as @m advised is always the better choice btw).

27th Jul 2006, 17:18
:mad2: I went to the ATI web site to try to get a newer driver. After a couple of hours spent following exactly the instructions, I had a resolution of 800*480 and when I was using the mouse wheel to scroll down the internet page, it was in slow motion and painful for the eyes. So I when to the HP web site ( it's a HP laptop) and downloaded the driver again. 5 minutes later I was back to the beginning. The updated driver they gave me didn't sort the games problem so. Anyway, I tried the patch 'friendly laptop' because I can't zoom and it still doesn't work. I can't load my troops in my ships either. I have played 2 eras with just the management, it is so poor. Besides all those problems of a game that doesn't work, it is a fairly bad game. I used to play the paradox entertainment games and Rome TTW. I can't find a descent game about the early 19th century and it's a shame, it's one the most interesting period.

29th Nov 2006, 15:28
Hi I got same problem , in battle my game crash and auto restart the game.
I think it`s this my sound , coz I try to turn off my sound and no crash, I have SB Audigy 4 ,it was some slapy sounds before crash .

14th Jan 2007, 13:52
For ATI Radeon graphics cards you need 5.09 drivers (or before).