PDA

View Full Version : What The ***k!!!???



BrandonB
2nd Jun 2006, 03:30
Ugh! So Hitman decided to lockup, it crashed. Now every time I try to start the game IT CRASHES! God... I'm speechless... OH GOD NOOOOOOO! :mad2: :mad2: :mad2:

Xcom
2nd Jun 2006, 03:42
Have you tried rebooting pc before starting it again?

BrandonB
2nd Jun 2006, 03:43
Have you tried rebooting pc before starting it again?

Nope... kinda late for that though. I just uninstalled it and am reinstalling it lol. Probably should have thought about that, such a n00b moment right there. :rolleyes:

Xcom
2nd Jun 2006, 03:45
Reboot anyway..

It can happen with certain crashes that DirectX will get in a locked state, and that it will always crash unless you reboot.

BrandonB
2nd Jun 2006, 03:49
Reboot anyway..

It can happen with certain crashes that DirectX will get in a locked state, and that it will always crash unless you reboot.

Ok, downloading the nVidia beta drivers right now and gonna install em. I'll reboot then.

BrandonB
2nd Jun 2006, 04:04
Thank god... that worked. phew

BrandonB
2nd Jun 2006, 05:26
God damn it! Now its crashing every time I try to go to the "A new life" mission. It crashes in the middle of loading, just straight to the desktop.

Reien
2nd Jun 2006, 07:24
This is...well...sort of poetic...In a bad kinda way....the way you kept bashing the FX cards and now It wont work on your 7900GT...honestly I am feeling for ya man. I hope you get It sorted out :(

smlaci
2nd Jun 2006, 09:01
have you tried reducing the sound card hardware acceleration from full to basic?
in dxdiag that is.

stegman
2nd Jun 2006, 10:12
***deleted due to unfairness***

stainit
2nd Jun 2006, 11:25
Not happy at all.

I just bought this game, and installed it.
I watched the NVIDIA splash screen, (quite nice).
I watched the little movie; with the blackbird flapping around.
He landed on the statue/grave, and hops around a bit, the camera pans down in to the long grass, with the bird watching quizzically as we go....then
BOOM!
Back to desk top!!! :mad2:

What the hell is this all about!?
I restarted: same happened.
I shut down all other running programs: Same happened.

Now i find out that there’s a patch our already, and the "Crash-To-Desk-Top" is a common problem with this game.
Looks to me like the publisher was cracking his whip over this and demanding release before proper testing, resulting in a game that released with a patch on the same bloody day (forgive the pun)

Help me please.
{This kind of thing can turn a decent, upstanding individual to turn to psychopathic, non-profit based, killing sprees. http://www.hardwaregeeks.com/board/images/smilies/votei8.gif }

I too am having the same problem, right after that short bird/cemetery movie it crashes right to the desktop, I'm sort of releived another person is having this problem but it doesn't fix it none the less. I unistalled the game and dowloaded the demo for hecks sack, and same thing happens, I later found out that the game uses pixel shading 2.0.

My system specs are:
Windows XP SP2
AMD Athlon 1700+
512 RAM
NVIDIA GeForce4 Ti 4200

I have all the latest drivers and the latest DirectX, and ofcourse my video card does have pixel shading 2.0.
Since I don't have pixel shading 2.0 it makes the game crash to desktop every time after the bird thing.

Now, I have the game uninstalled and the demo installed with the demo FPS patch, I went in hitmanbloodmoney.ini and edited it to have:
DefaultScene=M00/M00_intro.GMS
and guess what it goes straight to the mission movie, once in the game I went into the graphic settings and turned most of the settings down, it stills looks pretty freaking great and it runs like a charm. I get to the part were you grab the shotgun, lock-pick the door a blast the two black guys sitting around the table, but once I shoot it crashes to the desktop, since the gun fire animation or whatever it's called uses pixel shading 2.0.

Kind of disapointing not being able to run the game because Eidos didn't implement an option to turn off or lower the pixel shading.
Well, I hope they give us a patch with that option for the GeForce users or if a 3rd party could that would be nice too.
Oh and I know the video card is old but it's still works like a charm with the games I have i.e HL2, and don't bother telling me to go buy a new one since it works just fine when I edit the .ini file, and my money is going to something alot more important as of right.

DucusSumus
2nd Jun 2006, 13:18
Bummer. Patch to 1.1 and lower sound acceleration in DxDiag.

stegman
2nd Jun 2006, 15:31
You can turn down the pixel shaders.
It says how to do it in the read me file (i'm at work now so cant tell you how to do it.)

BrandonB
2nd Jun 2006, 17:19
This is...well...sort of poetic...In a bad kinda way....the way you kept bashing the FX cards and now It wont work on your 7900GT...honestly I am feeling for ya man. I hope you get It sorted out :(

I dont think it has anything to do with the gfx card (or atleast I dont think so) it might be just poor programming. But if it is the gfx card hopefully a new patch will fix that. OH GOD WHYYYYY! WHYYYY MEEEE!!!! (where the hell is the cry emoticon?)

Reien
2nd Jun 2006, 19:46
Did you try lowering the sound acceleration? I know Its a long shot, but you never know.

Xcom
2nd Jun 2006, 19:58
I too am having the same problem, right after that short bird/cemetery movie it crashes right to the desktop, I'm sort of releived another person is having this problem but it doesn't fix it none the less.

Unfortunately, your video card is not supported.

stainit
2nd Jun 2006, 22:05
Unfortunately, your video card is not supported.
I know, but meh, I've been browsing for a while on the hitman forums and I see alot of people with a Ti4200 who bought the game, I can still run the game by editing the .ini, and I got the gun-shot crash to stop, it's smooth and the FPS is just fine, so if people with very little knowledge of game devloping or however it's called can get a game to run on a un-supported system than why can't EIDOS? Just release a patch letting people choose which pixel-shading they want, it's not impossible. If Half-Life was able to detect which pixel-shading version you had and adapted to it 1.5-2 years ago why didn't they give it a shot here?

Xcom
2nd Jun 2006, 22:25
"Unsupported" means IO didn't develop the game with this card in mind. It wasn't tested and therefore, there probably won't be any fixes for it. People with Ti4200 bought it at their own risk.


If Half-Life was able to detect which pixel-shading version you had and adapted to it 1.5-2 years ago why didn't they give it a shot here?

Because, as you say, it was 1.5-2 years ago.

stainit
2nd Jun 2006, 22:40
Yes I know what unsupported means, if Half-Life had the technology to do it 2 years ago than EIDOS had the means to.

Xcom
2nd Jun 2006, 22:54
Means - yes, but for whatever reason they chose not to. I can only speculate why that is. Maybe they figured GF4 was generally too old to run the game anyway (shaders or no shaders), maybe it wasn't financially possible, maybe it meant sacrificing a lot of funky features and hence making game's graphics look outdated.

stegman
8th Jun 2006, 10:33
I know, but meh, I've been browsing for a while on the hitman forums and I see alot of people with a Ti4200 who bought the game, I can still run the game by editing the .ini, and I got the gun-shot crash to stop, it's smooth and the FPS is just fine, so if people with very little knowledge of game devloping or however it's called can get a game to run on a un-supported system than why can't EIDOS? Just release a patch letting people choose which pixel-shading they want, it's not impossible. If Half-Life was able to detect which pixel-shading version you had and adapted to it 1.5-2 years ago why didn't they give it a shot here?

How did you stop the gun shot crash?

stainit
8th Jun 2006, 14:49
How did you stop the gun shot crash?

here:

ATTENTION: I can run the game on FX5200 with shaderquality low/medium, no gun crashes, no saving crashes, and no loading profile crashes.

Here is what to do:
1.) make sure you have a clean install of blood money. ie no patches from eidos or netraider's patch applied.

2.)open the "xx_main.zip" files in each of the mission folders and delete the three glowxx.fx files located in the shader folder that geoff mentioned.

3.)be sure to do this as well to "hitmanbloodmoney.zip" and "saveandcontinue.zip" otherwise, you will encounter the saving/loading crash problems.

4.)add the shaderquality line to the ini file and execute. eveything should work.

additional notes: it may be possible to delete lines/routines in each of the glowxx.fx files instead of entirely deleting the files themselves. but until someone figures out how to do that, this should solve a lot of problems. Good Luck.

EDIT: I am playing A Vintage Year with shaderquality medium and it looks great and runs smooth. The invisible wall anomaly is present in some areas and also one minor drawback as a result of using the shaderquality line: the map is no longer visible! but this may be a plus for those of you who like a challenge.

Its also important to mention that I have set all of the rendering options in the game to the lowest setting.

or you can just edit them:

OK, any1 who wonder i found the line that causes the gun fire crash in the glow00.fx glow13.fx files.

open those files find this line[it apears manny times, you only alter the first 1]:

FogEnable=<FogEnabled>;

modify this line like this:

FogEnable=<FogDisabled>;

you do the same in the 2 glow00.fx and glow13.fx files, save them and reupload them into the main level archive (i.e hidout_main.zip, but you do it for all the levels).

That's it, game won't crash on gunfire but still some texture is missing (sky, light glow) you probably won't feel anything missing when you play in-doors.

ENJOY!

B.W : This is a foolish solution so i am still waiting for the game developers to make a patch for this!

stegman
8th Jun 2006, 15:04
this is very interesting.
I have a GeForce 4 and have managed to start training mission, but after climbing the trelis and picking the lock on the door it crashes when i try to shoot the two guys.
Even i should be able to play the game now!!
I'll let you know how i get on.;)