View Full Version : england game freeze xbox 360 - HELP!!!

26th Apr 2006, 11:56
After beating the snake boss in the england level the game freezes when I attempt to slide down the slope.

I have read this is a know bug if you attempted to pull levers prior to meeting the boss. I dont want to spend hrs replaying the level so is there a fix, level skip or patch?


26th Apr 2006, 23:23
360 version of the game.
Freezes right after you pull the lever after getting the bronze cross!!!!!:mad2:
I also didn't pull a lever before the monster so I doubt that is part of the bug.

This is my 20th something system in 26 years and I have never had a console freeze up totally on me. Looks like I may have to return the system(it sounds like a jet engine too). Completely unacceptable.

3rd Jun 2006, 05:07
Yep me to... my 360 will not allow me to play past this point. The game keeps freezing over and over.

Its sad really...i would love for Eidos to respond.

15th Jun 2006, 03:27
I'm playing on the XBOX 360 and I've just killed the serpent outside the castle. You then slide down during the interactive play. You hop the gate and then swing over to the ledge and pull the lever. Everythings fine when I pull the lever, but when I enter the tunnel the game freezes up and I can't do anything. I've tried using a different TR: Legend disk, however it does the same thing. Does anyone have any answers?

15th Jun 2006, 23:14
How many saveslots did you use? Did you overwrite?

16th Jun 2006, 07:55
Not that l know anything about an XBox 360, but l hear a lot of people have been having trouble with the power brick overheating, which causes the console to freeze. Where is your Power brick? If you elevate it so it has better all round ventilation (place it on a small box for example where it is just touching on the edges of the box) does it still freeze. You could also try adjusting the default settings to see if that makes a difference

17th Jun 2006, 01:37
Solution: PlayStation3 is the way to go =D it's gonna have better graphics too when it comes out.

18th Jun 2006, 23:59
Just as the two earlier post have explained, my system locks up right after I get past the 2nd serpent on the England/King Arthur level, pull the level, and attempt to slide down the long hallway/tunnel revealed by the lever pull. Only way to recover is to reboot the box (please no M$FT jokes, OK?)

Is there any fix available for this? It happens EVERY time I try to go down that tunnel, so I'm effectively blocked from playing any more of the game.

...And I'm sure it has nothing to do with thermals - my XBOX hasn't had any probelms whatsoever, except in this one part of this one game where it consistently locks up every single time. Its clearly a problem with the game itself. At first I thought I might have a defective disk, but after seeing no visible flaws on it -- I can't believe that it would just be an amazing coincidence that two other people are reporting a flaw in exactly the same place.

21st Jun 2006, 18:36
Yah...im having the same problem and Eidos just tells me to return the game for a new copy (wont help). This weekend i'll try playing through the game without saving to see if that helps since some people from the other forums were saying it had something to do with the save file - ill post on here if it works.

27th Jun 2006, 19:26
I also have the same problem at that king-arthur/england level.
Every time, it freeezes up when i want to go past the gate...
So it's clear its a BUG in tomb raider legend, and Eidos just don't give a **** about their customers.
(they already collected the money you wasted on them ;-) )
In the future,... i just download games,.. and i won't pay a penny for it anymore.

Don't get mad,.. get even!! don't buy anymore **** form Eidos.

15th Sep 2007, 21:52
I have the same problem as everyone else here above me on my Xbox 360.. I have tried everything incl i got a new cd because i thought that was the problem. I have not tried to delete all of my savings because i dont want to do the whole game over again, because i have got all of the crosses.. So does anyone know what to do??:scratch: I have sent an message to Eidos about this so i hope they reply.