PDA

View Full Version : Crash on startup



Suluras
16th Apr 2006, 00:30
The game crashes just after the intro video. I don't get to see any error messages because Visual Studio 2005 automatically attempts to debug it.

any ideas?

DirectX Diagnostics Report


------------------
System Information
------------------
Time of this report: 4/16/2006, 00:33:02
Machine name: DAN
Operating System: Windows XP Professional x64 Edition (5.2, Build 3790) Service Pack 1 (3790.srv03_sp1_rtm.050324-1447)
Language: English (Regional Setting: English)
System Manufacturer: RD480_
System Model: AWRDACPI
BIOS: Default System BIOS
Processor: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ (2 CPUs), ~2.2GHz
Memory: 1022MB RAM
Page File: 561MB used, 1927MB available
Windows Dir: D:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.3790.1830 32bit Unicode

------------
DxDiag Notes
------------
DirectX Files Tab: The file d3d9d.dll is a debug version, which will run slower than the retail version.
Display Tab 1: No problems found.
Display Tab 2: No problems found.
Sound Tab 1: No problems found.
Music Tab: No problems found.
Input Tab: No problems found.
Network Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D: 0/4 (retail)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

---------------
Display Devices
---------------
Card name: Radeon X1900 Series
Manufacturer: ATI Technologies Inc.
Chip type: Radeon X1900 Series (0x7249)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_7249&SUBSYS_0B121002&REV_00
Display Memory: 512.0 MB
Current Mode: 1600 x 1200 (32 bit) (60Hz)
Monitor: Plug and Play Monitor
Monitor Max Res: 1600,1200
Driver Name: ati2dvag.dll
Driver Version: 6.14.0010.6606 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail
Driver Date/Size: 3/22/2006 04:57:34, 412672 bytes
WHQL Logo'd: n/a
WHQL Date Stamp: n/a
VDD: n/a
Mini VDD: ati2mtag.sys
Mini VDD Date: 3/22/2006 04:57:09, 2212864 bytes
Device Identifier: {D7B71EE2-3109-11CF-7C6A-182BA1C2CB35}
Vendor ID: 0x1002
Device ID: 0x7249
SubSys ID: 0x0B121002
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel: ModeMPEG2_C ModeMPEG2_D ModeWMV8_B ModeWMV8_A ModeWMV9_B ModeWMV9_A
Deinterlace Caps: {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
{3C5323C1-6FB7-44F5-9081-056BF2EE449D}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{552C0DAD-CCBC-420B-83C8-74943CF9F1A6}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
Registry: OK
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
DDraw Test Result: Not run
D3D7 Test Result: Not run
D3D8 Test Result: Not run
D3D9 Test Result: Not run

Card name: Radeon X1900 Series Secondary
Manufacturer: ATI Technologies Inc.
Chip type: Radeon X1900 Series Secondary (0x7269)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_7269&SUBSYS_0B131002&REV_00
Display Memory: 512.0 MB
Current Mode: 1360 x 768 (32 bit) (60Hz)
Monitor: Plug and Play Monitor
Monitor Max Res: 1600,1200
Driver Name: ati2dvag.dll
Driver Version: 6.14.0010.6606 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail
Driver Date/Size: 3/22/2006 04:57:34, 412672 bytes
WHQL Logo'd: n/a
WHQL Date Stamp: n/a
VDD: n/a
Mini VDD: ati2mtag.sys
Mini VDD Date: 3/22/2006 04:57:09, 2212864 bytes
Device Identifier: {D7B71EE2-3129-11CF-7C6A-192BA1C2CB35}
Vendor ID: 0x1002
Device ID: 0x7269
SubSys ID: 0x0B131002
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel: ModeMPEG2_C ModeMPEG2_D ModeWMV8_B ModeWMV8_A ModeWMV9_B ModeWMV9_A
Deinterlace Caps: {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
{3C5323C1-6FB7-44F5-9081-056BF2EE449D}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{552C0DAD-CCBC-420B-83C8-74943CF9F1A6}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
Registry: OK
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
DDraw Test Result: Not run
D3D7 Test Result: Not run
D3D8 Test Result: Not run
D3D9 Test Result: Not run

-------------
Sound Devices
-------------
Description: SB X-Fi Audio [D8E0]
Default Sound Playback: Yes
Default Voice Playback: No
Hardware ID: PCI\VEN_1102&DEV_0005&SUBSYS_00231102&REV_00
Manufacturer ID: 1
Product ID: 100
Type: WDM
Driver Name: ctaud2k.sys
Driver Version: 5.12.0001.1144 (English)
Driver Attributes: Final Retail
WHQL Logo'd: n/a
Date and Size: 10/29/2005 21:22:10, 763520 bytes
Other Files:
Driver Provider: Creative
HW Accel Level: Full
Cap Flags: 0x0
Min/Max Sample Rate: 0, 0
Static/Strm HW Mix Bufs: 0, 0
Static/Strm HW 3D Bufs: 0, 0
HW Memory: 0
Voice Management: No
EAX(tm) 2.0 Listen/Src: No, No
I3DL2(tm) Listen/Src: No, No
Sensaura(tm) ZoomFX(tm): No
Registry: OK
Sound Test Result: Not run

---------------------
Sound Capture Devices
---------------------
Description: SB X-Fi Audio [D8E0]
Default Sound Capture: Yes
Default Voice Capture: Yes
Driver Name: ctaud2k.sys
Driver Version: 5.12.0001.1144 (English)
Driver Attributes: Final Retail
Date and Size: 10/29/2005 21:22:10, 763520 bytes
Cap Flags: 0x0
Format Flags: 0x0

-----------
DirectMusic
-----------
DLS Path: D:\WINDOWS\SYSTEM32\drivers\etc\GM.DLS
DLS Version: 1.00.0016.0002
Acceleration: n/a
Ports: Microsoft Synthesizer, Software (Not Kernel Mode), Output, DLS, Internal, Default Port
Microsoft MIDI Mapper [Emulated], Hardware (Not Kernel Mode), Output, No DLS, Internal
SB X-Fi Synth A [D8E0] [Emulated], Hardware (Not Kernel Mode), Output, No DLS, Internal
SB X-Fi Synth B [D8E0] [Emulated], Hardware (Not Kernel Mode), Output, No DLS, Internal
SB X-Fi MIDI Port [D8E0] [Emulated], Hardware (Not Kernel Mode), Output, No DLS, External
Microsoft GS Wavetable SW Synth [Emulated], Hardware (Not Kernel Mode), Output, No DLS, Internal
SB X-Fi MIDI Port [D8E0] [Emulated], Hardware (Not Kernel Mode), Input, No DLS, External
Registry: OK
Test Result: Not run

-------------------
DirectInput Devices
-------------------
Device Name: Mouse
Attached: 1
Controller ID: n/a
Vendor/Product ID: n/a
FF Driver: n/a

Device Name: Keyboard
Attached: 1
Controller ID: n/a
Vendor/Product ID: n/a
FF Driver: n/a

Device Name: Microsoft USB Office Keyboard Hot Keys
Attached: 1
Controller ID: 0x0
Vendor/Product ID: 0x045E, 0x0048
FF Driver: n/a

Device Name: Microsoft USB Office Keyboard Hot Keys
Attached: 1
Controller ID: 0x0
Vendor/Product ID: 0x045E, 0x0048
FF Driver: n/a

Device Name: Microsoft Wireless Optical MouseĀ® 1.0A
Attached: 1
Controller ID: 0x0
Vendor/Product ID: 0x045E, 0x008C
FF Driver: n/a

Device Name: Microsoft Wireless Optical MouseĀ® 1.0A
Attached: 1
Controller ID: 0x0
Vendor/Product ID: 0x045E, 0x008C
FF Driver: n/a

Poll w/ Interrupt: No
Registry: OK

-----------
USB Devices
-----------
+ USB Root Hub
| Vendor/Product ID: 0x10B9, 0x5237
| Matching Device ID: usb\root_hub
| Service: usbhub

----------------
Gameport Devices
----------------

------------
PS/2 Devices
------------
+ Microsoft USB Office Keyboard
| Vendor/Product ID: 0x045E, 0x0048
| Matching Device ID: hid\vid_045e&pid_0048&mi_00
| Service: kbdhid
|
+ Terminal Server Keyboard Driver
| Matching Device ID: root\rdp_kbd
| Upper Filters: kbdclass
| Service: TermDD
|
+ HID-compliant mouse
| Vendor/Product ID: 0x045E, 0x008C
| Matching Device ID: hid_device_system_mouse
| Service: mouhid
|
+ Terminal Server Mouse Driver
| Matching Device ID: root\rdp_mou
| Upper Filters: mouclass
| Service: TermDD

----------------------------
DirectPlay Service Providers
----------------------------
DirectPlay8 Modem Service Provider - Registry: OK, File: dpnet.dll (5.03.3790.1830)
DirectPlay8 Serial Service Provider - Registry: OK, File: dpnet.dll (5.03.3790.1830)
DirectPlay8 IPX Service Provider - Registry: OK, File: dpnet.dll (5.03.3790.1830)
DirectPlay8 TCP/IP Service Provider - Registry: OK, File: dpnet.dll (5.03.3790.1830)

DirectPlay Voice Wizard Tests: Full Duplex: Not run, Half Duplex: Not run, Mic: Not run
DirectPlay Test Result: Not run
Registry: OK

-------------------
DirectPlay Adapters
-------------------
DirectPlay8 TCP/IP Service Provider: Local Area Connection - IPv4 -

-----------------------
DirectPlay Voice Codecs
-----------------------
Voxware VR12 1.4kbit/s
Voxware SC06 6.4kbit/s
Voxware SC03 3.2kbit/s
MS-PCM 64 kbit/s
MS-ADPCM 32.8 kbit/s
Microsoft GSM 6.10 13 kbit/s
TrueSpeech(TM) 8.6 kbit/s

-------------------------
DirectPlay Lobbyable Apps
-------------------------

------------------------
Disk & DVD/CD-ROM Drives
------------------------
Drive: C:
Free Space: 21.1 GB
Total Space: 152.6 GB
File System: NTFS
Model: ST3160023AS

Drive: D:
Free Space: 93.5 GB
Total Space: 152.6 GB
File System: NTFS
Model: ST3160023AS

Drive: E:
Free Space: 117.0 GB
Total Space: 152.6 GB
File System: NTFS
Model: ST3160023AS

Drive: F:
Model: PIONEER DVD-ROM DVD-106
Driver: d:\windows\system32\drivers\cdrom.sys, , 0 bytes

Drive: G:
Model: PIONEER DVD-RW DVR-109
Driver: d:\windows\system32\drivers\cdrom.sys, , 0 bytes

--------------
System Devices
--------------
Name: Creative SB X-Fi
Device ID: PCI\VEN_1102&DEV_0005&SUBSYS_00231102&REV_00\4&2309E86D&0&B0D0
Driver: n/a

Name: Realtek RTL8169/8110 Family Gigabit Ethernet NIC
Device ID: PCI\VEN_10EC&DEV_8169&SUBSYS_240A147B&REV_10\4&2309E86D&0&88D0
Driver: n/a

Name: ALi 7101 Power Management Controller
Device ID: PCI\VEN_10B9&DEV_7101&SUBSYS_240A147B&REV_00\3&61AAA01&0&F1
Driver: n/a

Name: Standard Dual Channel PCI IDE Controller
Device ID: PCI\VEN_10B9&DEV_5288&SUBSYS_240A147B&REV_10\3&61AAA01&0&F9
Driver: n/a

Name: PCI standard PCI-to-PCI bridge
Device ID: PCI\VEN_10B9&DEV_5249&SUBSYS_00000000&REV_00\3&61AAA01&0&D0
Driver: n/a

Name: ULi USB 2.0 Enhanced Host Controller
Device ID: PCI\VEN_10B9&DEV_5239&SUBSYS_240A147B&REV_01\3&61AAA01&0&E3
Driver: n/a

Name: ULi PCI to USB Open Host Controller
Device ID: PCI\VEN_10B9&DEV_5237&SUBSYS_240A147B&REV_03\3&61AAA01&0&E2
Driver: n/a

Name: ULi PCI to USB Open Host Controller
Device ID: PCI\VEN_10B9&DEV_5237&SUBSYS_240A147B&REV_03\3&61AAA01&0&E1
Driver: n/a

Name: ULi PCI to USB Open Host Controller
Device ID: PCI\VEN_10B9&DEV_5237&SUBSYS_240A147B&REV_03\3&61AAA01&0&E0
Driver: n/a

Name: ULi M5229 PCI Bus Master IDE Controller
Device ID: PCI\VEN_10B9&DEV_5229&SUBSYS_240A147B&REV_C8\3&61AAA01&0&F8
Driver: n/a

Name: PCI standard ISA bridge
Device ID: PCI\VEN_10B9&DEV_1575&SUBSYS_00000000&REV_00\3&61AAA01&0&F0
Driver: n/a

Name: Texas Instruments OHCI Compliant IEEE 1394 Host Controller
Device ID: PCI\VEN_104C&DEV_8023&SUBSYS_240A147B&REV_00\4&2309E86D&0&90D0
Driver: n/a

Name: AMD Miscellaneous Configuration
Device ID: PCI\VEN_1022&DEV_1103&SUBSYS_00000000&REV_00\3&61AAA01&0&C3
Driver: n/a

Name: AMD DRAM and HyperTransport(tm) Trace Mode Configuration
Device ID: PCI\VEN_1022&DEV_1102&SUBSYS_00000000&REV_00\3&61AAA01&0&C2
Driver: n/a

Name: AMD Address Map Configuration
Device ID: PCI\VEN_1022&DEV_1101&SUBSYS_00000000&REV_00\3&61AAA01&0&C1
Driver: n/a

Name: AMD HyperTransport(tm) Configuration
Device ID: PCI\VEN_1022&DEV_1100&SUBSYS_00000000&REV_00\3&61AAA01&0&C0
Driver: n/a

Name: Radeon X1900 Series Secondary
Device ID: PCI\VEN_1002&DEV_7269&SUBSYS_0B131002&REV_00\4&123D6358&0&0110
Driver: n/a

Name: Radeon X1900 Series
Device ID: PCI\VEN_1002&DEV_7249&SUBSYS_0B121002&REV_00\4&123D6358&0&0010
Driver: n/a

Name: PCI standard PCI-to-PCI bridge
Device ID: PCI\VEN_1002&DEV_5A34&SUBSYS_00000000&REV_00\3&61AAA01&0&10
Driver: n/a

Name: PCI standard host CPU bridge
Device ID: PCI\VEN_1002&DEV_5950&SUBSYS_00000000&REV_01\3&61AAA01&0&00
Driver: n/a

------------------

coronaz
16th Apr 2006, 00:35
I had this same problem but then I disabled the next gen options and full screen effects and the game ran ok. Even though with my specs the next gen option should at least not crash the game... I have emailed tech support and awaiting a reply...

Specs:
Windows XP x64
Athlon 64 3200+ S754
1GB RAM
Gainward G6800GS 512mb PCI-E (v84.21 drivers)
Expox NForce4 SLi S754 Mobo
Creative Audigy 4

Dre
16th Apr 2006, 23:47
I had the same problems, black screen after intro video/crash, had to reboot everytime.

Looking under control panel and video adapter hardware acceleration, i found a check box for combined writing.

After unchecking this box needed to reboot and game works fine now.

Dre
16th Apr 2006, 23:58
I had the same problems, after intro video black screen/crash had to reboot everytime.

Under control panel for my video adapter and menu solving problems with hardware acceleration i found a checked box for combined writing.

After unchecking this box had to reboot and game works fine now.

Suluras
18th Apr 2006, 10:12
thanks for the suggestions guys. Unfortunately they didn't seem to work for me. I have just remembered that catalyst AI is enabled, so when I get home I will disable it before giving tomb raider another try.

DABhand
18th Apr 2006, 16:42
You will have to disable VS2005 from debugging automatically, its part of the protection to stop people from having a sneaky peak at the coding.


Setup VS to not start automatically on windows startup, if you need to use it later then you can by running it.

Suluras
18th Apr 2006, 20:34
You will have to disable VS2005 from debugging automatically, its part of the protection to stop people from having a sneaky peak at the coding.


Setup VS to not start automatically on windows startup, if you need to use it later then you can by running it.

thanks, I don't suppose you know how to disable it? I have been searching through the internet but no luck so far.

Leak
18th Apr 2006, 20:51
thanks, I don't suppose you know how to disable it? I have been searching through the internet but no luck so far.
Set "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\Auto" to 0.

But I'd rather hazard a guess that it's actually DEP (Data Execution Prevention) from SP2 that's making the game crash; more info about it can be found here (http://support.microsoft.com/kb/875352).

np: Grabuk - Flechten (Pingipung Plays: The Piano)

Suluras
18th Apr 2006, 21:17
Set "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\Auto" to 0.

But I'd rather hazard a guess that it's actually DEP (Data Execution Prevention) from SP2 that's making the game crash; more info about it can be found here (http://support.microsoft.com/kb/875352).

np: Grabuk - Flechten (Pingipung Plays: The Piano)

you were correct, DEP was my problem. I disabled it for trl.exe and it works fine now. Many thanks.

DABhand
18th Apr 2006, 22:22
There ya go new things learned :P


Didnt realise DEP was being a pain for most, Ive never had problems with it at all.

Leak
18th Apr 2006, 22:26
you were correct, DEP was my problem. I disabled it for trl.exe and it works fine now. Many thanks.
No problem... :)

np: Kraftwerk - Music Non Stop (Minimum-Maximum (Disc 2))