PDA

View Full Version : Another SBLive sound problem...



Thorin Oakenshield
8th Apr 2006, 17:46
I had the demo installed which runs PERFECTLY:cool: I get the full game and now I get a clicking sound. Sometimes on odd occasions I'll get graphics glitches too.

Just lately TRL has been crashing. If I try to restart it I get a directx error "Failed to initialize Direct3D with current settings". After a reboot I can restart TRL and nothing is wrong with Dx9.0c on my comp :confused:

Does the patch fix these issues?

Athlon 64 3200+, Chaintech Apogee Geforce 6800, 2G Giel ram, SBLive! 5.1

Thanks in advance

crimsonsmoke
8th Apr 2006, 18:17
I'm getting similar problems - read my thread.

I think this has something to do with the creative sounds cards, especially Live! 24 bit.

No, unfortunately the patch doesn't fix any of these issues.

I'm also experiencing graphical glitches and I know for a fact that my X800XT isn't breaking/damaged: all drivers are up to date; I'm playing Oblivion, which is a far more taxing game in comparison, and I don't notice any graphical issues; my card isn't over clocked; and no other games display artifacts, etc.

These simple annoyances should have been sorted out way before release. Either that, or the beta testers were a bit rubbish.

Thorin Oakenshield
8th Apr 2006, 19:21
I have issues with hardware setting in Battlefield 2 with my soundcard too:(

I won't be buying another creative product.

FrozenFire
8th Apr 2006, 21:13
The game runs fine on a Sound Blaster Live! Platinum here.
Possible solution for your problem: Disable On-Board sound on your mainboard chipset. It can cause a lot of problems when a soundcard and the On-Board sound chip are activated.

Thorin Oakenshield
8th Apr 2006, 23:10
Onboard sound is deactivated in my bios. The main problem I have which gets on my nerves :mad: :mad: :mad: I start TRL, I see the eidos trade mark bumpf then I get a black screen but like when you alt & tab (i.e windowed & always on top). If I try to restart TRL I get the directx error and I can't play any other 3d game either unless I reboot:mad:

TRL is buggy if it breaks directx when it crashes. BTW when I reboot dxdiag shows NO errors and all other games work fine until TRL crashes again. Looks like this game is going back on the shelf until eidos fix it. The demo works fine so whatever they did in the full version...

sup2069
9th Apr 2006, 04:09
disable hardware acceleration for your sound card.

Go to run, type in dxdiag, then to sound. Slide the slider to "no acceleration", close out and play the game!


Yea I have the same card as you, this sucks.

Thorin Oakenshield
9th Apr 2006, 12:10
I tried that too. After a few minutes of perfect sound quality it starts to echo and distort.

I reinstalled it again:mad: last night and everything seems ok now.... I'll see how it goes. Thanks for the input ;)

sup2069
9th Apr 2006, 14:30
Yea your right, I got passed the dirt bike mission then the studdering sounds came back. My only advice would be to complete a check point (if in the middle of it) and save. Dont try saving halfway through a checkpoint then quit. The game will only place you back at that checkpoint! Exit the game, reboot game, then reload your file.

Havnt tried it yet, but it should help.

DABhand
9th Apr 2006, 19:48
I tried a bit of jiggerypokery if you will. This worked with a few Creative Cards ive tried, it may work for others. Aslong as it has EAX support.


This involves changing settings in your registry, so if you dont feel too happy doing it then dont.


But for others willing here we go


1. Press START then goto run, in this type regedit and press ok

2. Now in Regedit window, navigate to the following (click on the + to the left of each name)

i) HKEY_CURRENT_USER
ii) SOFTWARE
iii) Crystal Dynamics
iv) Tomb Raider : Legend (click on this)

Now you will see these options

EAXSupport - click on this and change the value from 0 to 1
UseReverb - click on this and change the value from 1 to 0

Make sure you set the audio settings back up to full again in dxdiag.


(also if your having problems with the Shader3 still being laggy or jumpy, click the + on iv) option and you will see a graphics folder, at the bottom will be 2 entries Shader2 and Shader3, to enable one set it 1 and disable with 0)

sup2069
10th Apr 2006, 02:28
Thanks, gonna go try this. I had EAX on but I didnt know reverb had anything to do with it.


EDIT: Just tried, didnt work :(

Legendary Lara Croft
10th Apr 2006, 23:55
disable hardware acceleration for your sound card

Start-Settings-Control Panel- Sounds and Audio Devices-Speaker Settings Advanced- Performance- Hardware Acceleration-None

I really hope there will be patch to fix this problem

Rascalius
11th Apr 2006, 01:37
Same problem here (same sound card too, SB Live 24). Even with the acceleration disabled I still have to restart the game every 45 mins or so because the clicking sound comes back. Pain in the butt! :mad: And forget the new patch too, it doesn't change a thing.

DABhand
11th Apr 2006, 03:27
I really need to find out why this is doing it. Seems to be Bass control, it set way to high and causes the boom affect like stuttering.

But I fixed with the registry, I guess its not a 100% fix, but it has to be something, perhaps the codec they use for sound play back it could be that thats not compatible with some creative cards.

Templarmk1
11th Apr 2006, 10:05
Hi DABhand I have these same problems and the one of the guy's at technical support is giong to contact the developers about it. However I've tried all of the things to stop this buzzing sound and is ruining the game somewhat. Deactivating hardware acceleration doesn't stop it at all neither does the registery things with EAX and reverb. Like You said I think it's the bass that's doing it. Can you tell me what you did in the registery to cut it out please?:)

Thorn
17th Apr 2006, 14:09
Thanks for the suggestions; reducing acceleration, registry settings, disabling onboard sound. None work :eek:

#1 Google hit for "tombraider legend sound": Creative support forums:

Audigy LS has major issues with Tomb Raider Legend (http://forums.creative.com/creativelabs/board/message?board.id=soundblaster&message.id=57338)

I agree it does sound very much like distorted bass, like taking 5.1 sound, mixing LFE channel into the stereo channels with the LFE boosted way too high. You can even tap out a beat to it. At least for me, the crackling is an extra layer of sound added over top of otherwise undistorted music, sound effects and speech.

DABhand
18th Apr 2006, 02:56
Ive tried other number of things, and had a sneaky peak at what they used and tried other codecs, but nothing.


Even tried tweaking my drivers I have but nothing again.


Game engine at fault basically, sorry to say.

Parasite27
19th Apr 2006, 23:40
Turning Hardware Accel off works for a short time and then the sound gets really screwed up and you need to restart the game.
Its a code problem.
Lets face it just one more example of a company rushing a game out the door before its done to make a few bucks.
Lets hope they at least release a patch that fixes the screwup.
While their at it perhaps they can fix the fact that I can stand in the middle of rocks and walk thru some of the walls hehe.
And viewing the japan girl model in the extras crashes the game. :D

LCisYum
20th Apr 2006, 02:18
This is the exact same problem Project Snowblind had. From the same developer too, Crystal Dynamics. I don't think they even released a patch to fix this problem. So I highly doubt they will fix this problem, base on their past "actions" to fix this sound problem.

Joel B
20th Apr 2006, 15:45
I'm having the same problem with the sound. I think I have a seperate on board sound card aswell, could somebody please tell me how I could disable my soundblaster live and reactivate the on board sound?

DABhand
20th Apr 2006, 20:08
It means either the following..


1. Right click My Computer > Properties > Hardware > Device Manager

In here disable the SoundBlaster and if your other card is active also (should be listed under the sound and game controllers) you may just need to restart windows for it to be automatically used, or you may have to do the following also...

Start > Control Panel > Sounds you will see under the 3rd tab that your sound etc will be set to Soundblaster Live card, change them to your other soundcard by using the drop down arrow and selecting.


2. If you card isnt showing then it may have been disabled in the BIOS, which you can get into when starting your PC, it is usually Delete key to get in and look for integrated peripherials in the BIOS and set AC97 or Sound to enabled.

Then disable soundblaster card in device manager etc.

aka Wombat
22nd Apr 2006, 02:30
WTF!! i wait all this time for a game that finally has 16:9 compatible but CRACKLES OMFG FIX IT NOW!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

GoranAgar
22nd Apr 2006, 08:44
Ok, for a good laugh. Does anyone have a driver that is newer than 2004?

I recently reinstalled my Windows and used the SB-Live driver disk to install the driver. Then I went online to update the driver but the little program told me I had the latest driver installed. Odd, because the soundcard is quite old. But when I check the driver date in DXDiag it says the driver is from 2001.

However, when I reduce the sound acceleration to BASIC the noise problem is gone.

Funny, in'it? :D

Nerevar
22nd Apr 2006, 08:55
In Creative-terminologi 2001 is up-to-date. Mine's also from 2001 - 9-10-2001.

GoranAgar
22nd Apr 2006, 10:19
I hear there are even people out there that still run Windows 98 on their computers. :D :p

crimsonsmoke
22nd Apr 2006, 13:07
So, is anyone actually going to fix this or do I have to close/start up TR:L every 45 minutes?

This is really dumb. I shan't be purchasing another crystal dynamics game... ever.

Nerevar
22nd Apr 2006, 14:48
I hear there are even people out there that still run Windows 98 on their computers. :D :p
And have you heard one single of those people complaining that Legend runs too slow, or they have sound issues, or flickering graphics, or non-functioning keys, or crashes? :cool: :D

aka Wombat
22nd Apr 2006, 19:25
WTV im NOT EVEN RUNNING sblive, i have M-Audio Revolution 5.1 -drivers are the latest and those are from 2004 and the audio is problematic, but only sometimes...still its annoying cause games like F.E.A.R. CoD2 Elder Scrolls IV all don't have this problem ... like i said fix it now! :eek:

Parasite27
23rd Apr 2006, 16:41
Ok, for a good laugh. Does anyone have a driver that is newer than 2004?

I recently reinstalled my Windows and used the SB-Live driver disk to install the driver. Then I went online to update the driver but the little program told me I had the latest driver installed. Odd, because the soundcard is quite old. But when I check the driver date in DXDiag it says the driver is from 2001.

However, when I reduce the sound acceleration to BASIC the noise problem is gone.

Funny, in'it? :D

(that fix only works for 20 to 30 mins before it comes back)
And you have to restart the game.

JunoJIm
28th Apr 2006, 19:18
Yup !!!

I have a SB Live card, and the stuttering, after trying all the fixes, except the PCI latency - that sounds like root of the problem, some sort of sampling or priority problem.

Maybe going back to Win98 is the answer... I still have the disc... :D

Matrix_Moments
29th Apr 2006, 20:37
Hi, loads of people here mentioning the hardware acceleration as a fix to this (ie, turn it right down), but I've found that I only get rid of the problem if I do that as well as turn the conversion rate right down.
THe other thing that seems to improve matters from ok to perfect is if you make sure your device settings are 48khz and 16bit, instead of 96 and 24, which a lot of games seem to struggle with (like COD2).
Try it, post on here if it makes a big difference, then maybe Crystal will realise what's up and stop using us all as beta testers!

M-M

Agama
8th May 2006, 09:15
Check out the link below, it might solve the problem:

http://forums.creative.com/creativelabs/board/message?board.id=soundblaster&message.id=59138