View Full Version : PC Control Glitch/Problem, Need a Patch

3rd Apr 2006, 15:26
Seems the game has a problem remembering your control configuration/button layout each time it saves a checkpoint, so when you continue your game you have to remap your buttons each time, even if you manually save the game before you exit then load that save each time it still happens, I am not alone, i am using the 360 Joypad for PC which works great apart form this problems, 4 out of the 10 muttons I mapped move out of place, Anyone think they will release a patch for it?, how do you go about informing Eidos about it, especially a few days before the game is even out...

3rd Apr 2006, 15:39
First they will wait if the problem appears to exist in the full version as well.

3rd Apr 2006, 19:35
Can you describe your problem more clearly?

Does your configuration actually change as soon as you cross over a checkpoint.. Or does it only change when you quit out of the game and restart it?

4th Apr 2006, 19:56
I can confirm the control problem, I believe it happens on exit.. and maybe has something to do with the config parsing that the game does on start up. (I think it might be something to do with that, because the same button will be listed multiple times under an action, and a few actions will be assigned the same button.. so it seems like something that is happening when it reads the configuration data on start up)

4th Apr 2006, 21:09
What the other guy said, some of the buttons are mapped incorectly on exit, some of them are mapped to different buttons than the ones I specified, some of them are mapped to more than one button and some of them are not mapped at all..I experience the problem with these functions only "PLS, Health, Next Weapon, Binoculars, Interact, Grapple", and it only happens once you completely exit the game to the desktop. If you just quit the mission your playing and reload another one or a different checkpoint then the buttons don't change, only when you fully quit the game and start it up again...

8th Apr 2006, 16:48
I agree - I just spoke to Eidos about this.

The configuration is by default stored in the registry under

HKEY_CURRENT_USER\Software\Crystal Dynamics\Tomb Raider: Legend\Input

And this is what happens if you try to set a button


You end up with two -- or in the Grapple case - Three assigned keys/buttons

Pretty annoying to say the least.

Please fix this


- D

8th Apr 2006, 16:50
Do you still get this with the patch?

8th Apr 2006, 16:52
Yup :(

16th Apr 2006, 19:48
I've got the same problem. As explained above all is fine until you exit out of the game. Then when you re-load it goes back to the default settings - which have two buttons doing the same thing for some controls.

It took a while to work out how to reduce them to one control each - clicking on it, typing a letter, then hitting delete. Clicking on it again and setting the new controls - not really user friendly.

The whole contorl screen seems buggy anyway - that it resets the focus of the contorl area, so that what you are editing becomes the bottom line. It is really annoying having to scroll down - you can't even use the mouse wheel.

If anyone finds a fix for the "loosing controls" that would be great.

19th Apr 2006, 22:14
I too can confirm this bug. It really is annoying. I don't play as often now because of it. Legend is a great game, but it's a hassle to play. Why didn't they include any configuration(.config) files? This is the first game I've seen in a long time that doesn't have any.

btw does anyone know if this bug is limited to the gamepad? I haven't tested with keyboard.

Edit: I would like to point out that one of the devs was informed of this bug during a chat session.

sermongar: Will be release soon an official patch to fix some bugs and improve Next Generation graphics in PC Version compatible with more graphics card?, and some no refelexion water about some NVIDIA cards for example, Geforce 6600GT? And when I run my game, I have to reconfigure my gamepad's buttons each time.
MorganGray: We will be releasing patches to correct the issues with some ofthe cards out there, so expect more visual goodness to arrive. The gamepad issue is unknown to me, what pad are you using?
sermongar: I'm using Logithech rumble pad 2
MorganGray: I'll look into that with our QA

I don't believe this bug is limited to any specific gamepad. I am using a Game-Elements Rumble Pad.

20th Apr 2006, 18:31
Well seems the 1.1 patch fixes the control issue for the Retail PC version, all my joypad control maps are now saved when I exit the game and are the same when I relaunch, just a shame Eidos shipped a game with a Major Bug in it, even with prior notice of the problem and then have the nerve not to inform people about it..., anyway seems the fix made it's way into the patch, so don't I even get a "Thankyou" for notifiying you of the problem GoranAgar, how about a free copy ofthe new Hitman game when it is released?...

20th Apr 2006, 20:05
Thank you. If I'll ever meet anyone from CD or Eidos US personally, I'll inform them of what you did. :)