PDA

View Full Version : Please give more controller options. (or am I missing something?)



Nuladen
1st Apr 2006, 19:47
I just downloaded the demo and cannot play as it's taking input from my rudder pedals and giving me a permanent forward-right input. It's not an option to unplug/plug my rudder pedals in everytime I wish to play :(

Am I missing somewhere in the controls section where I can tell it to ignore everything but keyboard and mouse? I would be happy if I could work out how to use my PS2 pad with converter but cannot seem to assign that either?

Seems a tad silly that the game is happy to take input from a device I don't want it to and yet won't let me set input from a device I do want input from.

Or am I missing something obvious?

Thanks,

Nul.

tantenas
1st Apr 2006, 20:03
Well, I've used the converter I bought form Play.com and everything worked fine.
Just make sure that is the only thing plugged in and then go to Options> Button Configuration to assign your keys (which is a bit annoying since there are more keys to assign than PS2 controller buttons so you end up having to do somethings with the keyboard)

The other major problems is you can't (as far as I know) control the camera with the PS2's right thumbstick.

Nuladen
1st Apr 2006, 20:16
As I already said, it's really not an option to remove all other controllers, more to the point we shouldn't have to. There is no way I am going to climb under my desk, spend several minutes unplugging all the wrong things just to play a game then crawl back under there to attempt to plug them all back into the same USB ports they came out of. A nice little ini file with DisableJoystick like Oblivion has would be nice and lets face it, not too much to ask :)

Nul.

yesrushdt
1st Apr 2006, 20:28
The other major problems is you can't (as far as I know) control the camera with the PS2's right thumbstick.

I was able to with my logitech gamepad. Make sure you have the gamepad axes set as in the picture below and you should be able to use the right analog stick to control the camera.

http://img332.imageshack.us/img332/259/trldemo5st.jpg

Nuladen
1st Apr 2006, 20:43
Well I fixed my problem, had to edit the registry to give false calibration data to the axis that were causing me issues. All works now and I can play :)

My preorder is saved :)

Nul.