View Full Version : CD not recognized

6th Sep 2005, 16:47
I have purchased Imperial Glory today and when I tried to install the game, my computer couldn't read the CD (it said there wasn't any CD inserted). No matter what I tried, I got the same results.
Please tell me what can I do about It. Can I get a new CD or is something else I should do? Or at least, is there any way I can return the game and get my money back?
Please excuse any language mistakes, because English is not my maternal language.

6th Sep 2005, 17:13
Return the game to the store you bought it from and ask for another box.

6th Sep 2005, 20:30
No, download the patch.

6th Sep 2005, 22:17
The patch works without having installed the game? :confused:

7th Sep 2005, 09:13
Oh wait, I didn't read the problem correctly, sorry.

Try transferring all files from the CD's/DVD to you harddisk and run setup from there. It might work. If not, return the disk.

7th Sep 2005, 14:27
Thanks for suggestions.
I can't transfer the files, because I can't even see them. When I insert the CD and try to see the files, I get the message "Insert CD in the drive" or something similar.
Do you think I can really return the CD to the store?

7th Sep 2005, 14:37
I don't know where you live, but at least in the EU countries and I am sure in the USA too, you can return the box with the game for a replacement and they have to give you another copy. If you live in a country that does not have such protection (don't know where but...) then you could directly contact EIDOS to get a replacement CD but it usualy costs something. Though if you have the receipt and it is less than 90 days I think, then they have to give you a replacement, perhaps for free? But go to the store and tell them the cd is damaged and you demand a replacement. Just don't waste any more time and have you receipt with you!