PDA

View Full Version : Help please with 3d3 devide problem



morrison6070
8th Jul 2005, 15:48
ok first i'm very upset whit the fact that lego doesn't work on my computer ....when I installed lego star wars for the first time the system told me that I needed the ''Pixel shader V1.1'' to run the game ....then to solve the problem I bought a new Video card...a ''GeForce FX 5200'' I know that its not that good but its supposed to work whit ''Lego Star Wars'' . So I Installed my new video card and i've installed the game and when I started it a message box appeared and it said '' Failed to create D3d device application will now exit''...and i've tried everything to make the game work. So if there's someone who can help me.... this is too ridiculus :confused: :confused: :confused: :mad:

Witi
9th Jul 2005, 19:32
I think I saw another post of a guy that has the same problem that you. Try read the other Threads because a lot of people has the same problems but make new threads and the Admins have to answer each.

morrison6070
12th Jul 2005, 19:20
When I said that I have tried everything its true.....Anything that I have tried on this forum didn't worked......so does anyone have an idea of what is the problem ...??!?!?! :confused: :(

ibda12u
16th Jul 2005, 18:41
This was a solution for me, I went out and got a FX 5200 and had the same problem till I used the older nvidia driver as explained below.

From here:Tech Support Page (http://support.eidosinteractive.com/GI/CustomerSupport/FaqSearchResults.jsp?problemType=5&searchText=&game=177&platform=3)
----------------------------------------------------------------
When trying to start Lego Star Wars I receive an error stating "Failed to created d3d device. Application will now exit."
There are 2 possible causes for this error to occur. The most common cause is your video card. If you are running an video card which does not support Hardware Transform and Lighting (TnL) or Pixel Shader v1.1, then Lego Star Wars will not run. You will need to upgrade your video card to a model which support both Hardware TnL and Pixel Shader v1.1.

The other possible cause is your video card driver. If you are running an Nvidia video card with the latest driver version (77.72), then Lego Star Wars will crash with the "Failed to create d3d device" error. You will need to download and install the previous Nvidia driver to run this game. The link below will take you to the download page for Nvidia's previous driver version 71.89. Download it and install it per the instructions on the download page. Click the link :Driver Installation Hints Document". Once you have installed the 71.89 version, Lego Star Wars should run.

http://www.nvidia.com/object/winxp_2k_71.89.html

---------------------------------------------------------