PDA

View Full Version : Help Please! Game won't start!



afleetalex02
27th May 2005, 22:21
Hello all,

I Need your help!
I got Imperial Glory yesterday, and after installing it with no problems (or so I thought), the damn thing won’t run. All it says is “the application can’t be initialized” ………what the hell does that mean? I tried everything….re-started, uninstalled, reinstalled, restarted again, turned off my Norton Antivirus (same as RTW)....no luck. Rome Total War runs perfectly on my computer....

My specs are:
Dell Dimension Desktop 3000
Intel Pentium 4 Processor (2.80 GHZ)
512 MB Shared DDR SDRAM
80GB Hard Drive
Integrated Intel Extreme Graphics 2 card
48x CD Burner/DVD combo


what gives?

Mike_B
28th May 2005, 08:32
It's your video card.

See this thread (http://forums.eidosgames.com/showthread.php?t=50181) for more details.

Also just because the game may have some similarities with another game does not mean that it will work as well. Rome Total War uses a different engine as IG, most games use a different engine if they're from different companies. Just thought I'd mention this, best way to make sure or a game will work is to try the demo.

afleetalex02
28th May 2005, 16:39
thanks for the help
I am very upset with this whole situation....it's a ******** joke. :mad:

Jamiebhoy
29th May 2005, 01:17
it seems a pretty common problem mate. me and at least 2 or 3 others have came on here complaining of the same thing. i had to return my copy on thursday, as the refund date would have expired. think ill use the vouchers and try RTW until something can be sorted about this