PDA

View Full Version : Lego StarWars startup "emulator detected" error and workaround



SAHorowitz
3rd Apr 2005, 15:30
I keep getting this error on starting up (which I did not get when I was running the demo): "Emulator detected! Please deactivate virtual drive and emulation software." I am not sure exactly what it means, but I did find a temporary workaround. If you feel comfortable going into your registry, do the following:

1) Run Regedit to edit the registry

2) go to HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

3) Right-click on MountedDevices key and click permissions

4) Then with the "Administrators" group highlighted, click deny read.

5) It will give you a yes/no warning. Click yes.

6) Run the game --won't get the error

7) do steps 1 to 5 after running the game and this time unclick the deny read

This is only temporary until someone (hopefully Eidos) comes up with a permanent solution. I am not sure what this error means, but this works around it for now.

QuickDraw2005
9th Apr 2005, 17:02
:mad:
The message reads" Emulator detected! Please deactivate virtual drive and emulation software." I am not sure why either. I have two DVDRW drives, seral ATA hard drive, and a floppy drive. The only thing I can think of that may be considered a virtual drive is the flash card reader on my HP printer. I unplugged it from the PC and still get the same thing though. The other possibility may be the HP Pocket PC, but I disconnected that also.
I have Nero 6 burning software on my PC, but I do not see any "virtual drive" settings. That is the only software I can think of that may use something like that. I do not see any virtual drive in Windows Explorer. Can someone in support look into this? I am running Windows XP with service pack 2 and have all available security patches. All hardware have the latest released drivers\BIOS, no beta drivers. My hardware is as follows:

ABIT IC7 Motherboard - Intel 875P Chipset
PNY Geforce 6800 128MB DDR - Graphics Card
Intel 2.8 GHZ P4c CPU (800MHZ bus HT enabled)
GeIL PC3500 433MHz DDR Dual Channel ULD Series (2 x 512 MB) - Memory
Creative Audigy 2 w/IEEE 1394 port - Sound Card
Samsung 160 GB SATA 7200 rpm 8MB cache - Hard Drive
BenQ 16x dual layer DVD+-RW/+-R
MagicSpin 8x single layer DVD+-RW/+-R
3COM 3C905C - TX network card
Antec SX835 II case (came with 350w Smart Power P.S.)
Toshiba TCX 1000 Cable Modem - Road Runner Service
Logitech RumblePad 2
Logitech Wingman Force 3D joystick
HP PhotoSmart 1218 Printer with flash card reader
HP Pocket PC - PDA

QuickDraw2005
9th Apr 2005, 19:06
Second problem, when ever I put in the CDROM it tries to re-install. What gives Eidos?

I believe the source of the first problem is the Securom garbage Eidos installs on everybody's system. I believe this is causing my problem along with those other problems about not able to verify the CDROM. I paid for this software for my kids. I can not use it because Eidos does not trust us. At least they could have found another way of protecting against copying that was less intrusive and actually worked for everyone. I hope you can resolve this very quickly Eidos.

DMA57361
11th Apr 2005, 13:45
I've not played the game at all - but you might have your terminology wrong.

It's only "Spyware" if it steals information and discloses it to a third party without your concent. Try "Badly implimented copy protection"?

QuickDraw2005
11th Apr 2005, 14:34
Why is the Securom giving me an " Emulator detected! Please deactivate virtual drive and emulation software." message if the software is not spying on my system? For one thing. I do not have a virtual drive or emulation software. I do not know what it is referencing. Why does it have to be cryptic and just tell me what software it does not like on my computer. I have Nero 6 on my computer. That is the only thing that I can think of that it might complain about. Why is Securom looking at what software I have installed anyway? Why should I have to remove Nero 6 or what ever software it does not like before I can play this game I paid for? If this is not spyware what would you call it? :confused:

DMA57361
11th Apr 2005, 19:54
I can't give you a solid answer - I didn't make the game and I haven't played the game - but I know why it's been done. Unfortunatly without reasonably extreme measures as these it's quite easy to use an illegal copy of a piece of software. You know the who craze a while back in the media about people downloading MP3's over the internet? People do that with games - and other software - they download a CD image and use emulator/virtual drive software to make computers think these images are genuine CD's. This is why Emu/VDrive software is starting to get black-listed and this isn't the first game to do so.

The idea behind the copy protection is to check to make sure you're not running a fake disk or an emulated image. Obviously if you're using a genuine disk and it complains then they've made an imperfect job of it.

And it's not illegal for the to check what else is installed on your PC, just trying to protect thier . . . erm . . . forgotten what it's called . . . legal lisence or something.

It is only spyware if it looks and what's installed on your PC then sends that information to someone else. Which I seriously doubt that it does, as there would be no need.

QuickDraw2005
11th Apr 2005, 20:39
I do not blame Eidos for trying to reduce illegal copying of the software they publish. All I know is that the method they chose does not work properly on my machine. I have not even heard of Emu/VDrive software. I know I do not have emulation software on my PC or ever had it on my PC, so I know there are not any old Registry settings giving a false indication. Does any one know how to verify that there is not a virtual drive on my PC? Windows Exployer does not show one. I looked also in Disk Management in the Administrative Tools, nothing about any virtual drive. As far as I know, no software on my PC uses a virtual drive. It would be nice if the message would identify what it thinks is the offending software.
The game only costs $30 U.S. Why even bother copying it.

Spero
11th Apr 2005, 21:58
What will it be?

The amount of money lost over a little emulation?

Or the amount of money lost over a lot of pissed off consumers?

DjZ
12th Apr 2005, 08:32
you mentioned you had nero 6 installed. just check in the start menu > nero folder and see if there is something called nero image drive in there. i dont know if this has anything to do with it but that is and img emulation thing i beleve :)

QuickDraw2005
12th Apr 2005, 12:30
I checked the Nero 6 folder. I have Nero CD-DVD Speed, DriveSpeed, InfoTool, StartSmart, BackItUp, Burning ROM, Cover Designer, Express, SoundTrax, Wave Editor, and ImageDrive. The Image Drive is also in the Control Panel. When I click on it it says it is disabled and asks if I want to enable it, I said no.
If the ImageDrive is disabled, what else can I do? Un-install Nero 6? That should not be required. It is legal software. Nero 6 does not allow you to copy CD's and DVD's that are copy protected. It has to be one of the more popular legal burning packages around. Are we suppose to un-install it to play a game? According to the ReadMe.txt file, Securom leaves some files behind. Am I going to be PERMITTED to re-install NERO 6 after I finish Lego Star Wars? What If I want to burn a CD before my kids finish the game? This is not right. Having to activate software is not even as bad as this Securom stuff.
I guess I am suppose to turn over control to my PC to all those software companies who publish software I installed and let them fight it out. I wonder what the company that makes Nero would think? :eek:

Jumpin_Jebus
15th Apr 2005, 18:53
For all those having SecuRom problems, follow the procedure below.

1) Place the original Lego: Star Wars disc in your CD/DVD-Rom.
2) Re-boot the computer.
3) Open My Computer, Right-click on your CD/DVD-Rom drive, left-click Open. Open the Program Files folder, Giant folder, and the Lego Star Wars folder. Find the LegoStarWars executable file, which should have an icon that looks like R2-D2.
4) Right-click on the LegoStarWars executable file, and left-click "Launch Analysis".
5) A disclaimer window will appear.
6) To proceed, please click on the "Yes" button.
7) The application will now generate an "AnalysisLog.sr0" file within the root of your hard drive.
8) Please "zip" the file (to avoid email corruption) and e-mail it to Support@securom.com with the subject line "Analysis file for evaluation." You can use the Windows XP Compressing tool to zip the file.

SecuRom will check the Analysis file and then be able to tell you exactly what is causing the problem. ;)

RoNsTaR
18th May 2005, 16:19
Dear Jebus,

plz tell secureRom that it would be very nice to know whats sent, I just see a big bunch of numbers and cryptecal stuff in the file, why is no one allowed to see whats saved in that file?