PDA

View Full Version : Something is wrong-2nd level on alpha test.



John D.
2nd Mar 2005, 00:12
Okay I still have tons of work to do on the 2nd level of the updated version of Deep Trouble 2. However I wanted to make a quick run in Darkloader to insure there were no sensitive areas that might cause crashes in game so I saved my current level as miss21.mis (same as the original) and put it in the new version zip file. When I finish the first level and go to the 2nd updated one-instant crash to desktop! This is crazy! Anyone have an idea of what's going on? :confused: :eek:

Edit: More tests, I resaved the 2nd mission as miss20 (the first) and I can get it to start that way, however when I reach the room with the dedx ai I'm using-it crashes! Why?? It was working fine before. :mad:

John D.
2nd Mar 2005, 19:11
I think I've fixed the ai problem by shifting it's place in my deepbase.gam, but the 2nd level crashing at the start is still there.

John D.
4th Mar 2005, 06:51
Completely redid the alpha file-Deep Trouble 1 (miss.19), Dt2 pt 1 (miss.20) work fine, but when I try to start pt 2 (miss.21) still an instant crash to desktop. That's the one I've rebuilt from the ground up so there shouldnt be a problem, but there still is. :confused:

Edit: Been trying to narrow the problem down, I used an area brush to isolate the start area and portilize that area only-just in case there was some brush or another causing the crash but that doesnt work. I also switched the old miss21 file back in just to see if there was something wrong in the intraface file. The old version worked fine so something is up with the new version of the current level.

John D.
5th Mar 2005, 19:44
Okay I have an alpha where all 3 levels will open, I went back about 10 saves on the miss21 file and that one worked. I'm not sure what went wrong, but after that save I had put in a number of custom images of gears and various other objects done in photoshop. At one time I had a crash that mentioned something about a pallette error so perhaps that had something to do with it. I also noticed that one of my ai's that was holding one of Targa's daggers was crashing things which stopped when I changed the blade to the jeweled dagger in the hierarchy. I went ahead and removed some other things and I'll move more slowly now, testing things in darkloader every few saves to make sure it's functioning right.

Dromed isnt bad..........it's just W#%#$%$%#$%$!! :mad: