PDA

View Full Version : nforce2 OpenAl install problem fixed!



TLK
13th Oct 2004, 20:06
I manged to solve the OpenAl install problem that seems to plague nForce2 mobo owners that use sound cards.

I have an Asus A7n8x nForce2 motherboard and a SoundBlaster Live! 5.1 sound card. I had motherboard sound disabled and use only the SoundBlaster. No problems before in any game.

I couldn't get in-game sounds working in SSN '67, and eveytime I tried to install OpenAl I got the infamous:
An NVIDIA audio driver upgrade is required
before OpenAl can be installed. Please go to www.nvidia.com
and download the latest driver for your audio hardware

I would still get this message no matter how many times I tried to install the latest nForce2 drivers.

I solved it similar to ValkXB70 in thread
still no sound!!!!! (http://forums.eidosgames.com/showthread.php?s=&threadid=45549) but I didn't need to remove my SoundBlaster card.

I simply renabled On-board AC97 sound from BIOS, then booted. I may have needed to reboot immediately after W2K installed a default driver, but once Windows was happy again, I reinstalled the new nForce2 drivers. This time much more happened during the audio drivers install section than before. Apparently it quietly does not install if your on-board sound is disabled.

After rebooting once or twice to let Windows get everything installed and setup, I was able to install OpenAl with no problems. After that in-game sound in SSN '67 was working fine with my SoundBlaster. I didn't even have to switch preferred audio devices in the control panel because it was still set to my SoundBlaster card.

I will probably experiment further because now that I have SSN working with my SoundBlaster, I'd like to go back and disable the nForce2 audio and remove it's drivers and applications to clean up my system.

ValkXB70
14th Oct 2004, 01:47
I did try re-enabling the onboard sound card. It did not have any effect until the Audigy was removed completely.

LOL and where was this advice when I needed it :p :D :D

Just kidding, hopefully others with this problem are now happily playing away.

Ronin-X
19th Feb 2006, 02:53
I overwrote the OPENAL32.DLL file in C:\Program Files\Eidos\ShellShock_Nam67 Folder with the one located in C:\WINDOWS\system32\. And then directly started the game( without installing OpenAL) and the sound started to work. I hope this works for you guys. :)

Ghostdog15
19th Jun 2006, 05:58
I simply renabled On-board AC97 sound from BIOS, then booted. I may have needed to reboot immediately after W2K installed a default driver, but once Windows was happy again, I reinstalled the new nForce2 drivers. This time much more happened during the audio drivers install section than before. Apparently it quietly does not install if your on-board sound is disabled.


(this forum seems VERY dead so I'm not sure if I should even expect a response)

but how do you do any of that? I have the same problem and I have a Audigy SE but have no idea how to do any thing you just said there.