PDA

View Full Version : flickering in t:ds when light hits textures



gondath
29th Sep 2004, 18:45
I have a weird problem since I upgraded my computer from my 1ghz Duron to a 2600 Thoroughbred and an ECS KT600-A motherboard. Anything that gets lit up by a light source flickers insanely in Thief: Deadly Shadows, made worse when I move my view around. This never used to happen at all. I assume this is related somehow to my new hardware but I can't prove it.

I have a GeForce FX 5200 card, which is fine for running the game. I have the latest Nvidia supported card drivers at the moment, even though I used to use some later beta drivers but I still get the problem. I have all the latest motherboard drivers, too. I even did a reformat recently to clear up my cluttered system, all to no avail.

This is not the only game I've seen the flickering in since I made my changes. I also get the flickering when light sources hit player models in Call of Duty. In this game in particular, bushes, bookcases, pretty much anything not a wall or floor gets the crazy flickers. I'd appreciate any help on the matter. I'm clueless right now.

Edit: A moderator will want this moved to technical. It somehow ended up in the wrong forum.

Quillan
29th Sep 2004, 19:40
If you are seeing the same problem in multiple games, you are right, the problem is related to your hardware. Though, I can't help but wonder if the hardware problem isn't in your video card. Does that motherboard have a built in graphics processor? If so, have you disabled it in the BIOS?

gondath
2nd Oct 2004, 03:50
The board has some kind of crappy built in graphics I think but I'm not certain. I'm any event, there is no option to remove it in the bios. The machine is detecting the right graphics card. I know that much for sure. I flipped an option in the bios to display agp first instead of pci without any luck fixing the problem.

gondath
7th Oct 2004, 16:44
Anyone have any thoughts?

Underhill
7th Oct 2004, 22:05
You shouldn't go to BIOS at all, unless you're absolutely sure what you're doing. Talk to someone with experience in this area before doing any major changes to your hardware.

I hope you get some help with the graphic card. I'm sure a moderator can give you some advice what to do.

gondath
8th Oct 2004, 06:40
I'm fairly certain the problem isn't with the graphics card by now, unles for some reason it's going bad. But if that were the case, I wouldn't be able to play games at all, and I can. I'm almost convinced it has something to do with my new motherboard. I get other problems sometimes too like random lockups during games or random restarts. I would try flashing it to an updated bios, but the newer ones seem like minor changes that have nothing to do with my problem. They come in forms like 1a and 1b. Without at least a major enough revision as a 1.1, I'm not even going to bother and risk screwing something up. I vaguely remember reading somewhere about a problem between the north and south bridges of the VIA board, but I don't know if it's relevant or how to fix it in any event. I just want to play games like this one without insane flickering or the crashes I get on Doom 3.

Dwheeler
8th Oct 2004, 10:20
I also have a GeForce FX 5200, and I get the same problem, os it's not your mother board, or just you, as these problems only started after I bought this video card. Can someone PLEASE help, the game is pretty much unplayable

gondath
8th Oct 2004, 10:24
I'm fairly certain it's not the graphics card. I was able to play the game fine with my old motherboard, RAM, and processor with the very same card. The drivers don't seem to make a difference here either. Unless the graphics card has issues with my board, I don't think it's the issue.

Dwheeler
8th Oct 2004, 10:30
Well, I've only seen it in 1 game other than thief 3, but I think it's gotta be the graphics card, because everything else in our comps is different, the onlt other game I'v seen it in for me is hitman contracts

gondath
18th Oct 2004, 17:59
I have yet to fix this problem.

bravus
18th Oct 2004, 18:38
Have you tried using the Omega drivers? Google for them. They're damn impressive.

theBlackman
18th Oct 2004, 21:23
www.omegadrivers.net

gondath
23rd Oct 2004, 19:27
I switched to the latest omega drivers. Thanks for the link. I get better performance now, but the flickering continues. It's really hard for me to play the game with certain areas flickering all the time. Any other ideas?

Kheldin
1st Nov 2004, 02:46
I picked this game up when it first came out, back when i was using the 56.72 driver from Nvidia. That driver worked perfectly with Thief 3. I have since, about a few weeks ago, decided to play again, but now I'm running the 61.77 driver.. Thief 3 performs absolutely terrible with this driver on my setup. Flickering and lighting problems all over. I have since went back to the 56.72 driver, and everything is peachy again. My guess is that your using one of these new drivers from Nvidia, in which in my case, I got the same problems you are having. So try going back to the 56.72 driver.