PDA

View Full Version : Thief Deadly Shadows crashes on load



jmacmillan89
5th Sep 2004, 15:54
I recently upgraded my graphics card to a Radeon 9600 XT all-in-wonder and thought I had my issue fixed (my old card was not supported). However, I still get an exception breakpoint when I load and I'm sol. Of note, when I run the check graphics card, it says Pixel Shader version 0.0 and says my card does not support it.

Pentium 4 1.8 gHz
512 MD RAM
Radeon 9600 XT card
DirectX 9c
ATI's Catalyst 4.8 release

Any thoughts?

Thanks,
John Mac

thegrommit
5th Sep 2004, 16:59
You card supports PS1.1, so it's probably a bad driver installation. Make sure you uninstall all ATI software, reboot, cancel the prompt asking if you want to install a driver, then run the driver installer and any other software.

jmacmillan89
5th Sep 2004, 18:14
I'll give it a shot and post my results.

... later that day ....

Well, I gave it a shot and it didn't work. I'm open to more suggestions.

Mr. Perfect
5th Sep 2004, 21:19
Just a stab in the dark, but maybe reinstalling Thief 3 might help. It might think you've still got the other video card.

jmacmillan89
5th Sep 2004, 21:57
I just tried reinstalling with the same results.

theBlackman
7th Sep 2004, 04:04
Try this:

Go to www.omegadrivers.net and get the latest version for ATI.

Get the DRIVER CLEANER from the same site, or from www.driverheaven.net.


Go to www.hoverdesk.net and get the reg cleaner 1.35 (bottom left FREEWARE)

Follow the instructions for uninstalling, cleaning (RUN REGSEEKER HERE after the cleaning ) and reinstalling useing the new drivers.

If you insist on the ATI drivers from ATI, still run the unistall from your CONTROL PANEL, driver cleaner, Regseeker, and then install the updated (4.8 ATI Cat drivers).

jmacmillan89
8th Sep 2004, 12:20
I'll give that a shot bman!

jmacmillan89
14th Sep 2004, 17:06
No Luck Bman.

However, I did not totally remove all of the regcleaner items found. I just removed the ATI related ones I could find.

I am going to try to do the same thing all over again but with Thief3 uninstalled and see what happens.

theBlackman
14th Sep 2004, 18:34
Just for a point of interest. If you had a different Vcard before the ATI, then you still need to use the DRIVER CLEANER and get rid of ALL the OLD card files.

Also, Reg Seeker will list only the registry items that are no longer used. If you have removed programs or files, and we all have, sometimes these leave tags in the registry.

When you start your computer it reads ALL the registry. It loses time when it reads file tags that are no longer there. It also slows down when it chases a file through a number of registry entries to locate it.

So. I have never had a problem with deleting ALL the files REG SEEKER shows, and have had a 10 to 15% speedup on my startup.

jmacmillan89
11th Dec 2004, 18:16
I went ahead and bit the bullet and did everything you recommended. Still no luck. Dunno where I should turn for support. Any ideas?

bravus
11th Dec 2004, 21:19
Last idea: was your old video card onboard on the motherboard? If so, maybe you need to turn it off in the BIOS? It just sounds to me as though the game might still be trying to use the old video hardware. Have you had success using other games at higher rez, greater speed, etc, and can you crank the desktop resolution up to silly levels? Normally the driver stuff suggested about would fix it, but I'm just wondering if the onboard graphics are still the default somehow...

jmacmillan89
23rd Jan 2005, 23:32
Finally found it. Actually I found the answer when I got a "could not init shader system" error while trying to play HL2 for the first time. I did a search and one of the three main fixes was to make sure both DirectDraw AND Direct3d Acceleration is enabled under the Direct X Diagnistic tool (under the Display tab). My setting for Direct3D Acceleration was NOT enabled (dunno why). Well, I could then play HL2 so out of curiosity, I tried to play Thief DS. Lo and behold, it worked.

Thanks to all that tried to help. I learned a lot along the way.

Happy taffing! Go the Lytha Way!

Cheers,
John Mac