PDA

View Full Version : AIs not moving



YohnY
23rd Aug 2004, 16:00
I have a little problem. I make my first FM and I have all done. I zip everything and it seems fine. All works, but one thing is not good. AIs in game standing (like stands when you put them in dromed). But when I played trought dromed, its working.

Play by dromed - AIs moving
Play by darkloader - AIs not moving

Where is the problem?

John D.
23rd Aug 2004, 16:17
Strange, you might open your mission in Dromed and try reloading the scripts (convict and gen) and then Optimize-Build Room Database-compute pathfinding-build ai database. See if that makes things work ok.:)

YohnY
23rd Aug 2004, 17:31
I tried it at least sixtimes, but its still no working. And still lights don't working. For all the time is light gem turn on max, while I am standing in shadow. Sometings is not right, but I don't know what. I tried to load convict and gen, portalize, optimize, build room database, AI room database, pathfinding. I tried change gamesys, because I have my own (only sleepers, sitting man and some shapechanges). I did on this mission two months, two months of several nervous, little bit of sleeping and now, all is in sh... Please someone give me some advices. I send you my mission, if is no other way, but I have to do this to the end!!!

John D.
23rd Aug 2004, 18:14
Strange, usually reloading the scripts does the trick. Have you taken a look at your starting point? Make sure it has a Playerfactory link to Garrett, perhaps something might be off with that. Also double check the way you have everything set up in your FM zip file, you may want to double check with komag's tutorial to make sure everything's in the right directory.

R_Soul
23rd Aug 2004, 22:16
It sounds like a patch problem.

There's a patch (from version 1.07 to 1.18) for Thief2, and a patch for Dromed, (also from 1.07 to 1.18)

It sounds like you've patched one, but not the other.

The patch does something to the Pathfinding Database, so if one program is 1.07 and the other 1.18, the two pathfinding databases will be incompatible, hence the problem you have.

The two patches can be found Here (http://www.thief-thecircle.com/media/patches/).
(The Dromed patch is just a replacement for the .exe file, so if you ever reinstall, remember you'll still need the original files from the .zip on CD 1)

Belboz
28th Aug 2004, 06:28
the patch fixes the scripts bug eg convict and gen, the old version of dromed wouldn't save the scripts in the mission file, and the patched version does. as the ai's are controlled by the scripts and the pathfinding database, they wont work if either one is missing.

YohnY
28th Aug 2004, 23:18
Yes, you were right. The patch of dromed 1.18 work perfect. I made a new pathfinding database and reload ever of scripts and it works exactly. Thanks. My mission is on the world...

But I have some small control questions. First: My dromed change a numbers of objects in time. For example: I made a sofe (number 22) and when I start dromed for secondt time, sofa has number (38). It's normal? This is a big problem in escape-objectives.

Second: I have done my fun-mission, I want to put it on internet, but I don'T know how. What I have to do...

Komag
29th Aug 2004, 13:53
Numbers of things will get shuffled throughout the entire process, so it's best to only do objectives LAST