View Full Version : Runtime Error

12th Jul 2004, 11:21
So, I picked up Thief 3 for the PC today. I went through all the usual installation stuff with no hitches. Although now, I can't run it. Everytime I try to run t3.exe (game file) I'm immediately greeted with:

"Microsoft Visual C++ Runtime Library

Runtime Error!

D:/Program Files/Thief - Deadly Shadows/System/t3.exe

abnormal program termination"

I get the same thing if I run it straight from the CD as well. I've already got the 1.1 patch and tried reinstalling it. I'm running XP with a Raedon 9600.

Any suggestions?

12th Jul 2004, 11:32
Do you have administrator rights for XP, this will almost certainly be needed to install the game if not to play it.

12th Jul 2004, 11:32
DirectX? Reinstall of Thief? Sp1 for XP?

12th Jul 2004, 11:43
Yes I have Admin rights. My DirectX is up to date and I tried reinstalling it already. I think I've got the service pack, but I'll have to make sure

12th Jul 2004, 12:15
Got the service pack, still no luck.

12th Jul 2004, 12:22
Looks like you are missing one of the necessary dlls. You may have deleted it by accident when uninstalling something. You should check the tech forums on the net for a solution to missing C++ libs...

12th Jul 2004, 14:19
Well, I got it fixed. Turns out the only way I could get it working was by downloading a no cd patch.