PDA

View Full Version : Thief III Demo Problem



ziili
29th May 2004, 11:13
Running the demo gives me the following error:
Flesh failed to initialize!
Please check that you:
1. Have a supported video card [my card is Ati Rage 128, and the readme.rtf file has the following information:

Thief: Deadly Shadows will not run properly on ATI graphics cards using the drivers older than Catalyst 4.4. We specifically do not support these drivers. We strongly recommend you use the latest drivers from the ATI web site. If you are using multiple monitors on your computer and you set the second monitor as the “primary display” using the Display Properties control panel, the game will run on the second monitor, but the gamma setting will be incorrectly applied to the first monitor. The workaround is to select the first monitor and check Use this device as the primary monitor in its Display Properties.
When using an ATI Radeon 8500 or 9200 graphics card, the game's movies and introduction screen may be slightly distorted. This does not affect anything else in game.
If you are seeing graphical distortion during the intro screens on Radeon 9000 cards, one possible solution is to go into your Control Panel/Advanced settings and press the default key under the 3rd tab. As always, please make sure you are using the latest video drivers from the ATI web site.]

Does the aforementioned text ensure, that I cannot play this game?

Anyway, let's go on with the error points:
2. Have current video drivers [I downloaded some stuff from http://www.ati.com -> didn't work]
3. Have all required shader files [!?]
4. Have all required texture data [!?]

I uploaded the DxDiagnostic tool overview of my PC, it can be found here: http://www.zone.ee/ziili/dxdiag.txt [if you get a weird page, then click on the big oval figure in the middle of the screen, the figure has an arrow pointing right and "Edasi kodulehele! Kliki siia!" written on it, you should find it and the file is definitely uploaded]

So, finally, the graphics problem is the only one I'm having, the sound is working fine, because when I run the game, I get an exclamation with the error mentioned above, when I click the 'OK' button, I see a black screen and the sound starts to play - I hear someone say 'Eidos' etc.

Thanks to everyone who helps!

Trotterwatch
29th May 2004, 11:38
Hi

Unfortunately you will not be able to play Thief 3 due to the following reasons:

ATI Rage is not a supported card - it's pretty old and doesn't support Pixel Shaders, a technology that is essential for the usage of Thief 3.

Another problem is you have a 400mhz Proccessor, the minimum supported for this game is over 3 times faster than that (1.5ghz P4).

There really is no concievable quick fix for you to be able to play the game on your current PC. So perhaps go back to playing Thief and Thief 2 fanmods until you have the funds required to purchase a newer PC.

Sorry for the bad news btw

ziili
29th May 2004, 12:16
:( :mad: