View Full Version : Thief 2 won't install anymore

8th May 2004, 14:36
Ok this problem really illudes me. I have uninstalled Thief 2 from XP because I think I deleted something I shouldn't have because the sound in the game wasn't working anymore and when I try to install it again by double clicking "setup.exe" I hear it running the cd but then it stops and nothing comes up. I have also tryed any other way I could think of to try get it to install such as pressing the install button in panel.exe E:\setup.exe -lgntforce from run and in the compatible mode on all of it's system settings with the same result. I just don't understand because I was able to install it on XP before and I've done nothing to the install cd because I've just left it in it's box until now and I don't see any damage on it. I also tryed some of my other game cd's and there setup screen comes up and can install. I do see some hope though because when I restart my computer the Thief 2 setup screen does come up and loads to 100 % but since I can't cancel restarting my computer an error comes up saying something like "can't run Thief2 setup because windows is shutting down". So maybe I have to somehow trick my computer that it's doing a restart but how the heck do I do that? Well if it's not possible then I hope there is other ways around this. I have also tryed going away and waiting more than an hour for the setup screen to come up but it still never does.

My system specs are:

Microsoft Windows XP

Pentum(R) 4 CPU 1.50 GHZ
1.50 GHZ

256 MB of Ram

Sound card: Nvidia 1.05 (I'm guising)
Video card: Nvidia 1.05 (I'm guising)

Well I will confirm what those cards are latter including what my graphics card is if I can find them again. But right now I just have to post this now as it might take me a while to do so. So I hope someone can help me from everything I've told here so far.

8th May 2004, 16:46
Aha more wierdness!! I have now found out that when I restart my computer and the setup screen comes up an error comes up and says "sorry there's no cd in the F:\drive" when the cd's in the E:\drive and I clicked on setup.exe in the E:\ drive and when I put it in the F:\ drive and click on setup.exe in the F:\ and when I restart again it says "sorry there's no cd in the E:\drive".

8th May 2004, 19:19
Two things:

First, there are many threads, including one two threads down, where the correct setup procedure for NT, 2000, and XP is explained. In brief, run it outside the setup screen, from a Command Prompt, with the command
d:\setup.exe -lgntforce, where l is a lower case L and d: is your CDROM drive.

Second, I cannot explain your drive letter mixup. I have never heard of that before. I have installed Thief many times with two CD drives in the computer and never had an issue. It is possible that none of that matters if you install Thief from the command prompt as indicated. STill it is somewhat puzzling and worth looking into in its own right.

I suggest that, first, you boot up without the Thief disk in place. Then put a regular CD in each of the drives in turn. Do the drive letters point to the right physical drives? If so, then put the Thief CD in and try again. If this does not work, maybe the system got mixed up by a previous Thief install. Did you change drives letters, like add a new drive, or exchange physical drives, between Thief installs? If an old Thief install is at fault, you should deinstall it correctly, or if that is not possible, then remove all old Thief files and all registry entries related to Thief. Be careful. Regedit can damage your system if not used properly.

Or, maybe you have a bad install CD, which I think is unlikely. It sounds to me like a system or a registry issue.

If the drive letters do not point to the right physical drives, then that is an OS issue that perhaps could be solved using the drive manager - you could re-assign the drive letters to something else, say S: and T:, reboot, re-assign them back again, and reboot.

Those are just wild guesses, but it may give you some food for thought.

8th May 2004, 20:45
Lol, no non of anything you or I said had anything to do with the solution because this is what I had to do for it to install:

I can't believe it myself.

The only reason it wouldn't install was because of a program called "KEENVALUE". This is a program I just recently noticed on my computer 4 days ago that I have never seen before!! So I assume that it was something my internet downloaded itself onto my computer. Everytime after I pressed restart for my computer an error would pop up saying "KEENVALUE is not responding" but I pressed Alt + Ctrl + Delete before I prest restart and the applications window did not show it. I found out that it was because of me having this program called "KEENVALUE" on my computer after I uninstalled it because to my surprise the Thief 2 setup program came up after I did and so after it did that I waited for about an our and then I was able to install the game again!! I gues maybe this program called "KEENVALUE" whatever it is for is corrupt. So everyone watch out for this program floating around on the internet called "KEENVALUE" because it will only prevent you from not installing Thief 2 because it will confuse your CD drives for that game, lol!!!