View Full Version : Cutscenes won't work!

14th Mar 2004, 23:35
Ok, so I played through T2 a couple of times, but now I'm getting all nostalgic with this T: DS-talk everywhere. So, I decided not to let my thievery-skills get too rusty since it's time to rob the city once again this summer... which is why I installed T2 on my new computer. But guess what? The cutscenes won't freakin' work. No intro and no cutscene to indroduce you to the missions (the cutscenes are indeed an important part of the game). Tried to re-install, downloaded the patch, downloaded some kinda "vid fix" (from The-Circle) but nothing works. Why? The cutscenes worked on another computer, and they work when I open 'em in windows. So why wont the game connect them when it's time for briefing?

Anyone experienced the same problem? Please help me out. Maybe some smart guy who knows any tricks. Maybe something I should type in a cfg-file or whatever... I wanna play Thief II, but I just can't do it without watching the cutscenes :( it ruins the feeling (and don't tell me to open 'em manually in windows after each mission, 'cause that's lame, hehe :P)



15th Mar 2004, 00:01
Oh, don't bother! I fixed it already by reading the excellent FAQ at ttlg. Anyway, if anyone has the same problem, just do the following (this is probably suited for users with Win XP):

Scrooge's Permanent Movie Fix
1) Locate (use "Search") the file named "regsvr32.exe". It is located in the Windows SYSTEM directory (if 9x/ME) or SYSTEM32 (if 2K/XP). Copy it in your thief installation.

2) Create a text document named "RegIndeo.bat" and copy/paste the following text:
"regsvr32.exe /s LGVID.AX" (without quotes)

3) Save it (The file extension must be .bat)

Simply double-click on the file when your movies don't play.

Note: it is not needed to repeat the operation in all your installed Thief/Gold/II, simply use one of them. The "registration" process will fix the problems in all installed Thief games present

(Text above taken from TTLG FAQ (http://www.ttlg.com/forums/showthread.php?s=&threadid=75031).)

Take care :D