PDA

View Full Version : Video problems



Stormrider
26th Feb 2004, 18:11
Hey everybody! First off, hello to all of you from a fellow LoK-fan! I've played the series ever since Blood Omen, and I've never been disappointed.

Now for my problem: I seem to be having a problem with the movies in that they don't play, the screen simply shows full-screen colours shifting rapidly - y'know, first the screen is white, then yellow, then green. Sound still plays fine though. Also, when Kain attacks, the screen starts to show those colours again - but it returns to normal when his swing ends. I've disabled full-screen effects, so that problem is 'solved', but I still have movies that don't play properly, which, as you can imagine, blows. I have the latest drivers so that's not the problem. I've noticed this with other games too. For instance, in Blood Omen 2 and Spellforce the movies do play, but very choppy - and now for Defiance, they don't play at all.

My graphics card is an ABIT Siluro GeForce 4, and my machine is an AMD Athlon 2200+ running on Windows 2000.

Please give me a hand if you can, it'd help me out a whole lot.

Thanks!

KainOFthehylden
26th Feb 2004, 18:27
hi
try shifting to 16 bit instead of 32 in the graphic options
it worked 4 me in bo2

Lär
26th Feb 2004, 18:50
Are you overclocking?

Later! :D

Stormrider
26th Feb 2004, 19:00
Thanks for the response guys! I'll have a look at this colour scheme thing. Maybe shifting to 16-bit will work (I'll let you know if it does).

By the way, I'm not overclocked, so that can't be it...

Stormrider
26th Feb 2004, 19:31
Well, shifting to 16-bit colour doesn't work... know anything else which can be useful?

KainOFthehylden
26th Feb 2004, 22:17
hi
why dont u try to watch the videos from the dark chronicles
maybe they'll work from there:D

alvoryx
26th Feb 2004, 22:54
maybe change your display drivers.. install latest services pack for win2k (or install xp :p it would be much easier)..

Stormrider
26th Feb 2004, 23:24
Originally posted by KainOFthehylden
hi
why dont u try to watch the videos from the dark chronicles
maybe they'll work from there:D

Nope. No such luck either :)

And my video card drivers are up-to-date, so it can't be that either...

Lär
27th Feb 2004, 07:31
Is your vid card the "MX" version of the Siluro?? If so, you may need to tweak a setting in the registry. Run regedit and browse for:

HKEY_CURRENT_USER
--Software
----Crystal Dynamics
------Legacy of Kain - Defiance
--------1.00.000 (i think thats the version it shows??)

Look in the right side pane, and find a setting called DisableVShader. Double-click to modify, and change the value to 1. Close registry and start Defiance. Hopefully that will fix your problem. If not, you may need to open the case to your PC and make sure the video card fan is running. An overheated GPU can cause all sorts of weird graphic anomolies when running 3D games.

Later! :D

KainOFthehylden
27th Feb 2004, 08:14
maybe u should make sure that the version of directx is 9.0b
if its just 9 i think it might cause some problems
good luck:D

Jurjen
27th Feb 2004, 10:56
I recommend first upgrading your display drivers with the latest from www.nvidia.com. I think that would solve your problems, but if it doesn't, enable 'compatibility mode', which is available in the European version and the 1.1 path. I'm almost certain that would work as well, but it will also reduce performance.

- Jurjen

Stormrider
27th Feb 2004, 14:28
Originally posted by Lär
Look in the right side pane, and find a setting called DisableVShader. Double-click to modify, and change the value to 1.

yes! That did it! Movies are still a bit choppy, but FullScreen effects work now, and the movies - well, at least they play.

Thanks everybody for the help! You've made a li'l gamer happy :)

Jurjen
27th Feb 2004, 16:23
This registry option is actually one of several things which 'Compatibiliy Mode' also does.

Stormrider
27th Feb 2004, 16:25
Originally posted by Jurjen
This registry option is actually one of several things which 'Compatibiliy Mode' also does.

Compatibility mode? How do you activate that, if I may ask?

Jurjen
27th Feb 2004, 16:41
It's in the setup program. (You can get to it from your start menu.)

Stormrider
27th Feb 2004, 16:42
Oh. Okay, thanks. Forgive my ineptitude :)

Lär
28th Feb 2004, 00:50
Originally posted by Stormrider
yes! That did it! Movies are still a bit choppy, but FullScreen effects work now, and the movies - well, at least they play.

I assume you're talking about the Bink FMVs, (i.e the "intro"). I had the same problem with Blood Omen 2. I don't know what the problem is, 'cause I have a fairly decent system (Asus A7V333, Athlon XP 2000+, GF4 Ti4200, 512MB ram, 40GB 7200 RPM HD).. My fix, for BO2, was to use the binkw32.dll file that came with Soul Reaver 2. Unfortunately, this only "half worked" with Defiance. The video played smoothly, but I didn't have any sound. :( Oh well, there's only two FMVs anyway.

On the subject of registry entires: Jurgen, what does ForceWin9xMode, ForceRefDevice, and DisablePureDevice do??

Later! :D

Jurjen
28th Feb 2004, 11:12
ForceWin9xMode disables usage of WindowsNT/2000/XP specific OS functions for loading data asynchronously. It's mainly there for testing purposes.

ForceRefDevice enables to use of the so called 'Reference' D3D device, which comes with the DirectX SDK. It's a very slow software emulation of all Direct3D features, and again, is only for testing purposes. (Framerates with it are like 0.1 fps.)

DisablePureDevice disables the use of the 'Pure' Direct3D device option. This devicetype imposes some extra restriction on the program, but is a little faster, which is why it's used. In the past we've seen a few compatibility issues with it though, which is why the option exists.

Another registrykey you might want to try is 'ExtendedDialog' :)

sniperbr0
29th Feb 2004, 17:28
what does that extended dialog do???

and does the maxanisotropic option works if changed to 8??? I see no difference, and eaxsupport too, I see no difference, but it blocks my stereo wide effects in my soundmax sound driver...

is there a good option to enhance the performance running defiance on my pc??? my specs:

P4 2.4 GHZ 400MHZ BUS 512 LB CACHE
512 MB SDRAM 133
GEFORCE FX 5600 XT 256MB AGP8X QUALITY MODE AF8X NO AA
WIN 2000

Currently the vsync is to prevent the tearing on screen but it makes the game very slow and also the smoke effects affects a lot the overall performance when fighting the sarafan, the vampire hunters and the advanced hyldens in vorador´s mansion part 2 and vampire citadel as raziel

any solution to this???

Lär
29th Feb 2004, 21:10
Originally posted by sniperbr0
what does that extended dialog do???

ExtendedDialog adds extra "stuff" to Defiance's setup dialog window. When ExtendedDialog is set to 1, the dialog window should look like this:

http://www.angelfire.com/electronic2/fixer/lok/setup_extdialog.jpg

Instead of this:

http://www.angelfire.com/electronic2/fixer/lok/Defiance_Setup.jpg

Later! :D

sniperbr0
29th Feb 2004, 22:05
oh thanks, and the other options in the defiance folder in regedit???

maxanisotropic: i set it to 8 but I see no difference, does it work???
eaxsupport: no difference when enabled, but blocks my stereo wide effects, why???
disable mipmaps: does it disables the Dynamic LOD???
triple buffering: I enable but I see no difference, what does it change really???