View Full Version : Help with mouse

10th Dec 2003, 01:22
I saw a few threads about this bug from a while ago, but no one said how to fix it so here it goes. The game works fine, looks good, etc. However, the mouse doesn't work on the menus, I have to navigate with the arrow keys. The mouse just sits in the middle of the screen on the menus, while it works fine in the actual move around and shoot people part of the game.

If anyone knows how to fix this, please say so.

Mr. Hankey
10th Dec 2003, 02:13
I've been looking for a solution for this for a while, as it is the only bug left on the game for me. It doesn't seem to be a big deal to me, but I've looked through the default.ini file and I can't find anything that would fix it.

My mouse was working fine before I installed the latest ATI drivers for my Radeon 8500le (sigh...I know, I know...) and the new 3.9 Catalyst drivers. Hopefully someone will come up with an answer to this soon.

Post your system specs though, it might help, mine are:

P4 1.7 ghz
512 RAM
ATI Radeon 8500le 128 MB
Windows XP Home

My post was absolutely useless to everyone, sorry.

17th Dec 2003, 01:46
If you are having these problems DO NOT USE THE PATCH. The keyboard workarounds no longer work as double-clicks are required that we cannot do. I'm going to have to reinstall to ditch the patch and use the game again.

Mr. Hankey
17th Dec 2003, 03:54
Ah blast! Too late! Oh well, I just need to fix the default file to where I can drop items from my inventory without having to use them, doh. Anywho, if you guys know what the coding would be to do that it would be awesome. Thanks.


17th Dec 2003, 03:56
Unfortunately hankey you also have to double click in biomods, so until they come up for a fix for this or you reinstall, you can change or add mods either....

Mr. Hankey
17th Dec 2003, 04:45
Whoa whoa whoa. I just found out that actually, the mouse DOES work in the game menus. Crazily enough though, the in game mouse is rendered in the center of the screen and is immovable, but in the background is your actual mouse that does work just fine.

The thing is...uh...you can't...see it, which kind of defeats the purpose of having a mouse in the first place. The biomods can be installed and upgraded using the keyboard still (tab), but I haven't found a way to drop items from the inventory, which is a big 'no bueno.'

So now if we can just find some way to enable the background mouse to display everything will be A OK...except for all the other problems people have been having.

Try out the mouse thing on the back button for yourself, send it down to the lower right corner, raise it slightly up and to the left, and presto! the BACK button is achieved.


17th Dec 2003, 06:03
Mmm..good job Hankey. I think that with this info any decent 3d programmer working at ION could find a workaround. I have a Radeon 9700 and suffer the same problem.

17th Dec 2003, 06:05
Thanks Hank, I havent tried it yet but that makes perfect sense. I also have a Radeon 8500. HEY EIDOS, SEE ANY COMMONALITIES HERE????

Mr. Hankey
17th Dec 2003, 14:58
When I get a chance I'll take a look in the default and user files to try and find the mouse display or show functions, if there are any. Let me know if you guys find anything useful to us Radeon guys.


19th Dec 2003, 04:39
Same problem, but I got a ge force...

[EDIT] my bad... it seems when I upgraded my comp, I now have a Radeon 8500 series.... which is supported... gona check for drivers ect. Wierd my friends deus Ex works just fine and he has Radeon 8700 I believe.....

I just click widly until I hit the button... however thats pretty hard in the inventory....

19th Dec 2003, 04:47
For the ATI owners, try disabling the "ATI Hotkey poller" service (look under your administrative tools) and see if that helps. You won't be able to switch driver profiles on the fly, but it's worth a shot.

19th Dec 2003, 04:51
where are these administrative tools?

19th Dec 2003, 05:00
I have a solution! or at least it worked for me.

I went to the ATI site, clicked drivers/programs
Then I downloaded the Win XP driver for graphics cards and the Radeon Family choice. IT loaded and I reset my comp.

I started up Deus Ex and it worked! I have full control of the mouse in the menu.

I hope this works for everyone!

Mr. Hankey
19th Dec 2003, 07:26
Holy mackeral Burnt Toast you are a saint and a half! I downloaded the new Catalyst drivers for my ATI and POOF! bugs be gone! Now I can finally move my mouse again!

I humbly acknowledge your great superiority over my poor white trash.

Thanks again, and everyone who is having this problem should get the new drivers.


19th Dec 2003, 18:43
Thanks to you for pointing out I have a Radeon and not an nvidea:D