PDA

View Full Version : ati radeon 9000 mobility problems



SlavikSvensk
10th Dec 2003, 00:12
i'm running a 2.0 ghz (ram 512) processor with ati radeon 9000 mobility video card. my copy is, surprise surprise, running uber-slow and since i'm something of a computer neophyte (at least compared to people in this forum) i don't really know how to increase the performance. i've already followed a couple suggestions and made sure my vram (768) is high enough, and have tried running DX:IW in windows 2000 compatability mode, to no avail. so, anyone, help!

man
10th Dec 2003, 00:49
actually your video card shouldn't run DX:IW at all. don't try tweaking anything return the game to shop if you can.

THE MINIMUM SPECS ARE SAING:
GF3 class video card minimum, this means a card with DirectX8 hardware support. Your's is DirectX7 card

Grozbul
10th Dec 2003, 00:55
I use an ATI radeon 9000 mobility.
And the game is running smooth (or almost).
I just had to install the latest drivers, and tweak a little bit the game.

Get the drivers here: http://www.station-drivers.com/page/atidriv.htm

man
10th Dec 2003, 01:01
Originally posted by Grozbul
I use an ATI radeon 9000 mobility.
And the game is running smooth (or almost).
I just had to install the latest drivers, and tweak a little bit the game.

Get the drivers here: http://www.station-drivers.com/page/atidriv.htm

sorry:rolleyes: , but is it some kind of a new biomodefied ati radeon9000 from black market?:D

NO PIXEL SHADERS = NO DX:IW

sad but true

DeadBunny
10th Dec 2003, 01:02
Have you been to the inclinator facility yet? Several people (including me) who are playing it on a Radeon 9000 Mobility (or desktop) are having a graphical error in that area, you'll know it the second you get inside. Let me know if it occurs for you.

Oh, and the Radeon 9000 Mobility DOES have pixel shaders, and DX:IW runs quite well on my laptop in 800x600 with all the details up except for Multisampling.

SlavikSvensk
10th Dec 2003, 01:06
uh...i think you are mixing up the mobility 9000 and regular 9000. mobility 9000 supports 1.4 pixel and vertex shaders, and is directx8, not 7.

of course, vidcard biomods are welcome, whether tarsus or black market ;)

SlavikSvensk
10th Dec 2003, 01:09
here's my experience...choppy, bad framerate, worse in the inclinator but not THAT much worse. i haven't had any issues like freezing or so on.

Grozbul
10th Dec 2003, 01:10
DeadBunny, yes.

As soon as I went inside the Inclinator facility, everything that is foreground become white.

I made a couple of steps inside, and stopped because I couldn't even see when I was touchind the walls. :(

man
10th Dec 2003, 01:11
Originally posted by SlavikSvensk
uh...i think you are mixing up the mobility 9000 and regular 9000. mobility 9000 supports 1.4 pixel and vertex shaders, and is directx8, not 7.

of course, vidcard biomods are welcome, whether tarsus or black market ;)


oh, i'm terrebly sorry!

GREAT GAME, ISN'T IT!

DeadBunny
10th Dec 2003, 01:16
Originally posted by SlavikSvensk
here's my experience...choppy, bad framerate, worse in the inclinator but not THAT much worse. i haven't had any issues like freezing or so on.

But did you have the problem in the Inclinator that GRozbul describes above?

I should mention, if you ARE having the above mentioned graphical problem, could you please post your specs and what drivers your using for your vid card? Just to see if i can figure out how to fix it.

Voland
10th Dec 2003, 14:04
yup, I have mobility radeon 9000 and that exact same problem.
It doesn't happen only in the Inclinator facility. Actually, most disappointing is it happens on the last levels of the game too.

SlavikSvensk
10th Dec 2003, 16:40
i'm not having that problem, though i had something similar in the inclinator when i had the light bloom effect turned off. i turned it back on and it worked fine! well...okay, not fine...it was still far too choppy, but at least things looked okay (at the low resolution).

RamRod
22nd Dec 2003, 01:53
haha I meant to post a topic on this... anyways, my friend has been trying to run the game on his laptop with an ATI Mobility Radeon 9000. He hasn't downloaded the patch yet for those who are curious. I watched him try to play it, and when the game starts in Tarsus, everyone is black! It's not like a simple skin color though... everyone is a metallic brown, and the environment has a feces type of color hint all around it. Is it possible to fix this? If he downloads the patch and modifies default.ini will it help set the gamma right?

SlavikSvensk
22nd Dec 2003, 22:20
well, i got my system to work just fine after downloading the dx tool and setting:

a) mouse latency to 0
b) cache to 32

and otherwise tweaking the settings. i've heard that the patch actually makes things worse for some people. i'm now running 25-30 fps at low res, 20-25 at med. not perfect, but decent enough.

Akucaen
23rd Dec 2003, 06:34
Man:
The Radeon9000 is an 8500 w/ one TMU disabled, (i.e. half the performace.), it's still a DX8 card, and supports the PS's IW requires.
The mobility & normal are synonyms of each other, w/ the exception the mobility has ATi's version of power saving software, PowerPlay, IIRC. (nVidia is PowerMizer)

Slavic:
Download the latest Catalyst drivers from ATi's website, from my understanding, the normal drivers will work on mobility chipsets. Else, try & get the latest drivers from your manufacturer (Dell, HP, etc.) The best thing you could do is play at 800x600, and not turn AA or AF on. I know you might've heard this already, BUT, the 9000 is weak, and ATi caught alot of flak on the 9000's inital release. The 9100 & 9200 are variants of the 8500, but with both TMU's. (I /think/ the 9200 is built on the 130nm process like the 9600(R/P/XT), but I'm not sure. I do know it's built off of the R200 family, and isn't R300 based.)
Regardless, your best bet is to keep shadows off, and play at 800x600. You might want to lower your graphics settings as well, try medium for all (except shadows, set that to off), and try that.