View Full Version : CTD on level load

9th Dec 2003, 00:31
I just want to be sure that this is addressed, so I'll mention it again:

The only way I can load a new level or a saved game is to pop the CD tray out, wait for it to say "No disc inserted", then close the tray and hit "Retry" as was stated earlier somewhere on these forums I believe (thank you whoever figured that out).

Very annoying, especially considering all the traveling between levels you can end up doing. Please fix this. And yes, I have all the latest drivers.

For the record, once I applied the various tweaks, I haven't had many other problems with the game and am enjoying it, although I do find the lack of any kind of statement reguarding a patch disturbing.

My DxDiag in case:

System Information
Time of this report: 12/8/2003, 19:04:13
Machine name: ASUS P4
Operating System: Windows XP Home Edition (5.1, Build 2600) Service Pack 1 (2600.xpsp2.030422-1633)
Language: English (Regional Setting: English)
System Manufacturer: To Be Filled By O.E.M.
System Model: To Be Filled By O.E.M.
BIOS: BIOS Date: 11/06/03 17:38:10 Ver: 08.00.09
Processor: Intel(R) Pentium(R) 4 CPU 2.40GHz (2 CPUs)
Memory: 1022MB RAM
Page File: 158MB used, 2300MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0b (4.09.0000.0902)
DX Setup Parameters: Not found
DxDiag Version: 5.03.0001.0902 32bit Unicode

DxDiag Notes
DirectX Files Tab: No problems found.
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Music Tab: No problems found.
Input Tab: No problems found.
Network Tab: No problems found.

Display Devices
Card name: RADEON 9500 PRO / 9700
Manufacturer: ATI Technologies Inc.
Chip type: RADEON 9500 AGP Pro (0x4E45)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_4E45&SUBSYS_00021002&REV_00
Display Memory: 128.0 MB
Current Mode: 1024 x 768 (32 bit) (85Hz)
Monitor: SyncMaster 955b(T)/905b(T)/950b(T), SyncMaster Magic CM195A(M)
Monitor Max Res: 1792,1344
Driver Name: ati2dvag.dll
Driver Version: 6.14.0010.6396 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail
Driver Date/Size: 9/30/2003 21:29:58, 374784 bytes
WHQL Logo'd: Yes
WHQL Date Stamp: n/a
VDD: n/a
Mini VDD: ati2mtag.sys
Mini VDD Date: 9/30/2003 21:29:38, 618496 bytes
Device Identifier: {D7B71EE2-0D05-11CF-4E6B-0820A1C2CB35}
Vendor ID: 0x1002
Device ID: 0x4E45
SubSys ID: 0x00021002
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel: ModeMPEG2_C ModeMPEG2_D
Deinterlace Caps: {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(YUY2,YUY2)

Frames(Prev/Fwd/Back)=(0,0,1) Caps=DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2)

Frames(Prev/Fwd/Back)=(0,0,0) Caps=DeinterlaceTech_BOBVerticalStretch
{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(UYVY,UYVY)

Frames(Prev/Fwd/Back)=(0,0,1) Caps=DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(UYVY,UYVY)

Frames(Prev/Fwd/Back)=(0,0,0) Caps=DeinterlaceTech_BOBVerticalStretch
{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(YV12,0x32315659)

Frames(Prev/Fwd/Back)=(0,0,1) Caps=DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YV12,0x32315659)

Frames(Prev/Fwd/Back)=(0,0,0) Caps=DeinterlaceTech_BOBVerticalStretch
{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(NV12,0x3231564e)

Frames(Prev/Fwd/Back)=(0,0,1) Caps=DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e)

Frames(Prev/Fwd/Back)=(0,0,0) Caps=DeinterlaceTech_BOBVerticalStretch
Registry: OK
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
DDraw Test Result: Not run
D3D7 Test Result: Not run
D3D8 Test Result: Not run
D3D9 Test Result: Not run

Sound Devices
Description: SoundMAX Digital Audio
Default Sound Playback: Yes
Default Voice Playback: Yes
Hardware ID: PCI\VEN_8086&DEV_24D5&SUBSYS_80F31043&REV_02
Manufacturer ID: 1
Product ID: 100
Type: WDM
Driver Name: smwdm.sys
Driver Version: 5.12.0001.3583 (English)
Driver Attributes: Final Retail
WHQL Logo'd: Yes
Date and Size: 4/24/2003 15:06:34, 555648 bytes
Other Files:
Driver Provider: Analog Devices
HW Accel Level: Full
Cap Flags: 0xF5F
Min/Max Sample Rate: 100, 48000
Static/Strm HW Mix Bufs: 33, 32
Static/Strm HW 3D Bufs: 33, 32
HW Memory: 0
Voice Management: Yes
EAX(tm) 2.0 Listen/Src: Yes, Yes
I3DL2(tm) Listen/Src: Yes, Yes
Sensaura(tm) ZoomFX(tm): Yes
Registry: OK
Sound Test Result: Not run

Disk & DVD/CD-ROM Drives
Drive: C:
Free Space: 1.8 GB
Total Space: 4.0 GB
File System: NTFS
Model: WDC WD400JB-00ENA0

Drive: D:
Free Space: 4.0 GB
Total Space: 4.0 GB
File System: NTFS
Model: WDC WD400JB-00ENA0

Drive: E:
Free Space: 10.2 GB
Total Space: 30.2 GB
File System: NTFS
Model: WDC WD400JB-00ENA0

Drive: F:
Free Space: 27.8 GB
Total Space: 38.2 GB
File System: NTFS
Model: ST340014A

Drive: G:
Driver: c:\windows\system32\drivers\cdrom.sys, 5.01.2600.1106 (English), 3/31/2003 07:00:00, 47488 bytes:D :D

9th Dec 2003, 01:17
I just talked to a guy at Eidos and was told this is one of the securerom issues and that there is nothing we can do about it at this time. If you can however, see if you can update the firmware on your cd rom drive. He says that might work, but alas, mine has no update. (sigh), but yours might. I asked if it would be addressed in the patch and he said that he thought it would, although apparently there aren't that many people with this problem. Not sure about that as there seems to be quite a few on these forums! BTW, he told me they are working on a patch right now and it is in the testing mode, and should be out in approx. 3 days. Who knows!

9th Dec 2003, 02:15
Have you tried running in Windows 2000 compatibility mode?

9th Dec 2003, 02:59
I have tried the 2000 compatiblity mode and it worked about 3 times and then crapped out again. I really hope the patch addresses this. If anyone else has any ideas I would appreciate it.

9th Dec 2003, 03:01
BTW It might be a good idea if people with this problem CALLED Eidos customer service because the guy I spoke with said only about 35 or 40 people called with this issue of about 800 calls he has received concerning this game.

9th Dec 2003, 04:21
Yeah I tried Win2000 compatability; it didn't do anything for me. And my CD-ROM (Plextor) has no new updates.

Thanks for the info. At least I can play the game, unlike others :(

9th Dec 2003, 13:27
I had the problem where it would sit at load screen and then it would CTD. I took the cdrom out of my Kenwood cdrom drive and put it in my DVD rom. I've had no problems (well with the level loads at least) since.

9th Dec 2003, 13:32
Also, check my thread on the Audio subsystem bug... It helped me out and a couple other guys... Give it a try