PDA

View Full Version : Minor Frequent Graphical Glitches



Shrooom
6th Dec 2003, 08:47
I am getting graphical glitches pretty much wherever I look, no matter how much I change the bloom/AA/resolution settings. They change positions when I look around, but if I go back to the same exact spot, they will be in the same spot I looked. I have a Radeon 9800 with the the 3.9 drives. Since I only have this problem, major lag, and no direct sound, I guess I should consider myself one of the lucky ones:rolleyes: This is getting annoying enough that I'm about to put the game away and wait 6 months until there's hopefully a patch or two released.

Anyway, here's a screenshot so you can see what I'm talking about. I just grabbed this randomly; most places it's worse.

http://img.villagephotos.com/p/2003-12/526554/littlegreysquares.JPG

By the way, does anyone know how to get direct sound to work? And is there some sort of ini tweaking guide out there?

Thank you for all your help.


Here's my (edited) DxDiag report:

------------------
System Information
------------------
Time of this report: 12/5/2003, 23:57:49
Machine name: WINTERMUTE
Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 1 (2600.xpsp2.030422-1633)
Language: English (Regional Setting: English)
System Manufacturer: MICRO-STAR INC.
System Model: MS-6728
BIOS: Version 1.00
Processor: Intel(R) Pentium(R) 4 CPU 2.80GHz (2 CPUs)
Memory: 512MB RAM
Page File: 198MB used, 1052MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0b (4.09.0000.0902)
DX Setup Parameters: Not found
DxDiag Version: 5.03.0001.0902 32bit Unicode

------------
DxDiag Notes
------------
DirectX Files Tab: No problems found.
Display Tab 1: No problems found. DirectDraw test results: All tests were successful. Direct3D 7 test results: All tests were successful. Direct3D 8 test results: All tests were successful. Direct3D 9 test results: All tests were successful.
Sound Tab 1: DirectSound test results: All tests were successful.
Sound Tab 2: DirectSound test results: All tests were successful.
Music Tab: DirectMusic test results: All tests were successful.
Input Tab: No problems found.
Network Tab: No problems found.

---------------
Display Devices
---------------
Card name: ALL-IN-WONDER 9800 SERIES
Manufacturer: ATI Technologies Inc.
Chip type: RADEON 9800 AGP (0x4E48)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_4E48&SUBSYS_4F721002&REV_00
Display Memory: 128.0 MB
Current Mode: 1152 x 864 (32 bit) (75Hz)
Monitor: ViewSonic A90f+
Monitor Max Res: 1600,1200
Driver Name: ati2dvag.dll
Driver Version: 6.14.0010.6396 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail
Driver Date/Size: 9/30/2003 21:29:58, 374784 bytes
WHQL Logo'd: Yes
WHQL Date Stamp: n/a
VDD: n/a
Mini VDD: ati2mtag.sys
Mini VDD Date: 9/30/2003 21:29:38, 618496 bytes
Device Identifier: {D7B71EE2-0D08-11CF-4E6B-786FA1C2CB35}
Vendor ID: 0x1002
Device ID: 0x4E48
SubSys ID: 0x4F721002
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel: ModeMPEG2_C ModeMPEG2_D
Registry: OK
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
DDraw Test Result: All tests were successful.
D3D7 Test Result: All tests were successful.
D3D8 Test Result: All tests were successful.
D3D9 Test Result: All tests were successful.

-------------
Sound Devices
-------------
Description: SB Audigy Audio [C800]
Default Sound Playback: Yes
Default Voice Playback: Yes
Hardware ID: PCI\VEN_1102&DEV_0004&SUBSYS_10071102&REV_04
Manufacturer ID: 1
Product ID: 100
Type: WDM
Driver Name: ctaud2k.sys
Driver Version: 5.12.0001.0381 (English)
Driver Attributes: Final Retail
WHQL Logo'd: Yes
Date and Size: 3/24/2003 21:12:42, 502032 bytes
Other Files:
Driver Provider: Creative
HW Accel Level: Full
Cap Flags: 0xF5F
Min/Max Sample Rate: 4000, 192000
Static/Strm HW Mix Bufs: 64, 62
Static/Strm HW 3D Bufs: 64, 62
HW Memory: 0
Voice Management: Yes
EAX(tm) 2.0 Listen/Src: Yes, Yes
I3DL2(tm) Listen/Src: No, No
Sensaura(tm) ZoomFX(tm): No
Registry: OK
Sound Test Result: All tests were successful.

Shrooom
6th Dec 2003, 22:42
Can anyone help? Has anyone had a similiar problem? Thank you.

Torracat
7th Dec 2003, 07:16
Yea, I have the problemm too. same video card as well.
Actually, I am not all that happy with this card either. just got it today. Lots of little quirks about ATI it seems on various games. it is faster than my old Nvidia card. but at least Nvidia makes solid soft/hardware. I have been dealling with issues all day today...

NeoVanGoth
17th Dec 2003, 08:37
Have the same problem too. I've already seen it sometimes in Jedi Knight III, solution never found :-/

It looks like some weird Z-Buffer error, because i've seen the sqares partially in objects wich have others beyond them wich are not hidden by the bsp-tree or whatever the engine uses (doors, shower cubicles...)

I've tried really EVERY thing. The best results i get with:
Driver: costum settings, anti-aliasing and anisotropic filtering application preference
Game: multisampling 1

The game runs very smooth after the patch and some other tweaks posted in this board, but the sqares are VERY annoying to me :-/
(mine are mostly very bright *argh*)

System-Specs:
Athlon XP 2200+
Epox 8KHA+ (KT266A)
Radeon 9700 Pro (DNA drivers, Catalyst 3.10)
SB Audigy 1

btw, i had the same glitches with Catalyst 3.8, 3.9, single monitor, dual monitor
they're getting worse when multisampling is above 1

Oh please Ion Storm, this can't be sooooooooo hard to fix, the radeon runs like hell in EVERY other game (except JKIII ;) )


dxdiag:

------------------
System Information
------------------
Time of this report: 12/17/2003, 09:38:31
Machine name: NEUROMANCER
Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 1 (2600.xpsp2.030422-1633)
Language: English (Regional Setting: German)
System Manufacturer: VIA Technologies, Inc.
System Model: VT8366-8233
BIOS: Award Modular BIOS v6.00PG
Processor: AMD Athlon(tm) XP 2200+, MMX, 3DNow, ~1.8GHz
Memory: 512MB RAM
Page File: 507MB used, 742MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0b (4.09.0000.0902)
DX Setup Parameters: Not found
DxDiag Version: 5.03.0001.0902 32bit Unicode

---------------
Display Devices
---------------
Card name: RADEON 9700 PRO (DNA 1.9.3.10)
Manufacturer: ATI
Chip type: RADEON 9700 AGP (0x4E44)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_4E44&SUBSYS_00021002&REV_00
Display Memory: 128.0 MB
Current Mode: 1152 x 864 (32 bit) (60Hz)
Monitor: Plug and Play Monitor
Monitor Max Res: 1600,1200
Driver Name: ati2dvag.dll
Driver Version: 6.14.0010.6404 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail
Driver Date/Size: 11/13/2003 22:47:22, 377344 bytes
WHQL Logo'd: n/a
WHQL Date Stamp: n/a
VDD: n/a
Mini VDD: ati2mtag.sys
Mini VDD Date: 11/13/2003 22:46:58, 640000 bytes
Device Identifier: {D7B71EE2-0D04-11CF-B66A-0820A1C2CB35}
Vendor ID: 0x1002
Device ID: 0x4E44
SubSys ID: 0x00021002
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel: ModeMPEG2_C ModeMPEG2_D
Deinterlace Caps: {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=DeinterlaceTech_BOBVerticalStretch
{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,1) Caps=DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,0) Caps=DeinterlaceTech_BOBVerticalStretch
{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(YV12,0x32315659) Frames(Prev/Fwd/Back)=(0,0,1) Caps=DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YV12,0x32315659) Frames(Prev/Fwd/Back)=(0,0,0) Caps=DeinterlaceTech_BOBVerticalStretch
{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=DeinterlaceTech_BOBVerticalStretch
Registry: OK
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
DDraw Test Result: Not run
D3D7 Test Result: Not run
D3D8 Test Result: Not run
D3D9 Test Result: Not run

-------------
Sound Devices
-------------
Description: SB Audigy Audio [D000]
Default Sound Playback: Yes
Default Voice Playback: Yes
Hardware ID: PCI\VEN_1102&DEV_0004&SUBSYS_00531102&REV_03
Manufacturer ID: 1
Product ID: 100
Type: WDM
Driver Name: ctaud2k.sys
Driver Version: 5.12.0001.0253 (English)
Driver Attributes: Final Retail
WHQL Logo'd: n/a
Date and Size: 8/12/2002 10:03:30, 837548 bytes
Other Files:
Driver Provider: Creative
HW Accel Level: Full
Cap Flags: 0x0
Min/Max Sample Rate: 0, 0
Static/Strm HW Mix Bufs: 0, 0
Static/Strm HW 3D Bufs: 0, 0
HW Memory: 0
Voice Management: Yes
EAX(tm) 2.0 Listen/Src: Yes, Yes
I3DL2(tm) Listen/Src: No, No
Sensaura(tm) ZoomFX(tm): No
Registry: OK
Sound Test Result: Not run