View Full Version : Unable to end task on ion launcher.exe

mazda charles
6th Dec 2003, 07:52
Anyways, this is the first time it happened (besides other playability issues I'm having), but the game borked at the load screen. I ended up closing everything via task manager. The only problem was, Ion Launcher.exe would not close, no matter what, and that silly spinning CD cursor was on the screen. No matter what, Ion Launcher wouldn't close, and I couldn't Log Off or Restart, because the app didn't respond to log-off/shutdown command. I had to hit the reset button. Is there an attribute to this application that prevents windows from closing it? I've encountered one or two other applications that do that, but can't recall off-hand. To me, it's characteristic of a virus. Any insight into the issue would be appreciated. :)

mazda charles
6th Dec 2003, 07:53
P.S. Enjoying the game so far. :)

mazda charles
6th Dec 2003, 11:00
The issue has occured 2 more times now. It's definetly related to the DVD, because I can't eject the DVD, and, when I hit the reset button, the BIOS has a hard time detecting the drive (very odd).

It's listed as a "PIONEER DVD-ROM DVD-115."

Maybe there is a firmware update.

6th Dec 2003, 12:58
This has happened to me three times as well. For me it has happened during a load screen. The game hangs up, and I eventually did CNTR+ALT+DEL and tried to end all tasks, but they never completely ended. I had that stupid spinning DVD, and couldn't even open my DVD drive. I tried to look at the DVD drive in Explorer, but that froze things up worse.

I would say for me it definately began on a load screen each time that never loaded.

Computer is two weeks old. Drivers were fairly current, but did update video driver last night and still had another crash.

mazda charles
6th Dec 2003, 14:03
Yeah. It's exactly as you describe. I think it's the CD copy protection system trying to be foolproof...

6th Dec 2003, 15:18
Buggy i am having the same problem this is ridculous and should be seen as a buggy ill-made game.:mad:

6th Dec 2003, 22:07
I posted this problem yesterday afternoon. I thought it might be corrupted saves, but after deletion of saves, the problem persists. I've noticed the same inability of Task Manager to shut down Ion launcher and am getting very tired of the reboot process.

Gameplay issues asside, this problem is really slowing down my enjoyment of this game. Should I wait a couple months after the game comes out to buy it -- after a couple of patches have turned a beta product into a gold? I wish the FTC would step in and end this shoddy business practice (as it is now, we are screwed by the EULA. I don't care about waiting longer if the retail version is worth the price of admission.

This release has seriously tarnished my impression of Ion -- I have little interest in their other titles now and will only stay with DE because of the out-standing original.

7th Dec 2003, 00:16
I have heard about problems people have had with copy protection before (never experienced it myself), but I always thought that was explained off as old CD drives. Mine is a brand new DVD dirve, and I shouldn't be having a problem.

That Damn spinning CD really anoys me for some reason!


7th Dec 2003, 03:18
So is there a patch to get rid
of this ridiculous protection??

mazda charles
10th Dec 2003, 18:26
Does anybody know a way to get Ion Launcher to close? Will this issue be addressed in the future? I hate having to hit the reset button on my computer.

10th Dec 2003, 18:31
goto my post here: http://forums.eidosgames.com/showthread.php?s=&threadid=29653
Do the enditall2 thing
If you are talking about it loading every single time you load a level, download tweakui and disable cd autorun. get tweak ui here:

10th Dec 2003, 18:49
This same problem happened to me once mazda charles, pretty sure it was during a load too. Very annoying. My OS locked up with the cd cursor spinning, i couldnt end task, i couldnt eject the cd, and i ultimately just had to hit my reset button. Also, i was not using a DVD drive. As of right now, i'm not playing the game again until the patch is released...damn shame because i really like it so far.:( Hopefully the patch is released soon and fixs this problem.

10th Dec 2003, 20:44
Hey Eleazar. If I download the enditall 2 thing, will this allow me to play the game. Everytime I try to play, the load screen just sits there for 3 or 4 min. and then crashes to desktop with error message, "unable to authenticat disc within time period" The ion launcher isn't even in the taskbar at the bottom. Even so sometimes I'm still able to get into a game, but unusally not. Would appreciate any help.

10th Dec 2003, 22:59
Enditall is used to end all programs before you play the game. To get rid of the ION LAUNCHER you need to disable cd autorun in tweak ui. I thought it was staying around, I didn't know you were actually in game. ION launcher is needed for the cdkey protection authentication. This will fix your problem

mazda charles
11th Dec 2003, 01:59
Not even enditall can kill ion launcher once it messes up. I'm stuck eternally with the spinning CD icon. I really hate it when the program is trying to outsmart me, and it's buggy. :mad: