View Full Version : Problems reinstalling the game

23rd Oct 2003, 10:29

I had Commandos 3 installed proparly, but due to some strange reasons the game suddenly lost my saved games. Over and over again.
So I uninstalled the game, only to reinstall it. And that doesn't work!

I uninstalled the game correctly, but still it appears in my software list. When I try to install it for the 2nd time, it automatically try to do that in windows (data folder). After installing, it doesn't work as it can not find the commandos3.exe file.
What has happened, and how do I install the game again!

I almost killed the traitor :(

23rd Oct 2003, 10:38
uh oh. had this prob with c2 some months ago. what i did was formatting the C drive. have tried many many things but that was the only solution i could find. be sure that you have a boot disk (:mad: to dave cuz he forgot to tell me) and copy stuff you want to keep to another drive.

only solution mate, im sorry to say:)

23rd Oct 2003, 10:41

What happened that makes it necesarry to format the C partition? If that means I can't play the game, so be it.
Jammer maar helaas! (oops, dutch)

Anything in the Register that should be changed perhaps?

23rd Oct 2003, 10:46
mischien wel ja (oops dutch :P)
i formatted c drive, had to do anyway, so...

23rd Oct 2003, 11:56
I have very little experience with the registry. So if you know what I should do, please tell me.

I have just checked the register with Regedit (long live Xp Help) :) and found this:
HKEY Local Machine/Software/Pyro/Comm3/3.0
Should I remove that?
Advice please!

Thanks in advance,

24th Oct 2003, 02:13
Are you sure you watched it uninstall correctly. I watched my uninstall and it only worked for a few seconds and then quit. After that I had the same problems as you. No .exe after reinstall. Plus I had 4 GB before any installation. After manually deleting the windows dirs and program files dirs I am short 1 GB. This is ridiculous.

24th Oct 2003, 17:02
this is exactly what happened to me the 1st time. You must activate your Windows folders so that you can see hidden ones and follow the path that the message says to temporary files I think it was in Documents and Settings in my Windows XP. Manually delete that folder. It is the only way to ever be able to begin the install again. I did delete anything in the registry.

25th Oct 2003, 19:49
Got the same problem too

When I click on uninstall, it says uninstall finished in like two seconds, but nothing was removed. So I manually deleted the Eidos folder.
After that I try to re-install the game and it doesnt give me any option as where the game should be installed, it automatically installs in C:\\WINNT, and worst of all the commandos3.exe is not intalled and I can't play the game.

I used regedit to find anything pyro and commandos3 and deleted everything, but I still can't reinstall. It always says "modify my previous install" and doesnt allow me to choose which folder to instll the game too. It always reinstalls to C:\\WINNT and then it doesnt play.

How do I fix this, thanx in advance

25th Oct 2003, 20:02
It seems another bug in Commandos 3!

Don't know if it has to do with the game, but my WinXP is giving blue screens of death ever since I got troubles with Commandos.

I have a nearly clean system, as I formatted 2 weeks ago.

Eidos, fix this!

25th Oct 2003, 20:07
I had the same problem, I fixed it by empting the "Temp" folder in the windows directory. ;)

25th Oct 2003, 20:12
Yes you must delete that Temp folder to be able to reinstall. In the documnet and setting sub folder the install makes a hidden temporary folder that goes on to make the visible C3 game folders. Try doing disc cleanup from you system tools. That automatically cleans all sorts of temp crap too.

25th Oct 2003, 20:54
I ran disk clean up but it still automatically installs to C:\\WINNT.
Do I have to delete anything else? When I run disk 1 it says modify/repair/remove instead of asking language options and which folder to install to. Seems like my computer still got some info on commandos that won't let me reinstall properly.

25th Oct 2003, 20:57
I even deleted all Eidos/Pyro garbage from the registry. And still the same problem.

25th Oct 2003, 21:40
I hope Pyro makes a patch freaking fast. I only beat two levels of Stalingrad before uninstalling. Does Pyro or Eidos know this problem?

I think they had the same issue with Praetorians if I'm not mistaken

25th Oct 2003, 23:07
When mine copied the 1st disc and would not go further or begin with the 1st disc again I went to hidden folder in DOcuments and Settings and I thing Application Data an found a temp folser in that with the partial C3 stuff in it. I deleted it and could begin install again.

26th Oct 2003, 01:11
Hey guys I found a solution to it:) It should suffice before the patch or whatnots come out.

You have to enable viewing hidden folders and then go to the Installshield Installation Information folder, it's usually under Program Files. In the information folder, find the folder where the commandos setup folder is. The folder name is usually a bunch of crap numbers and stuff, so just go to start button->eidos->pyro->commandos 3-> uninstall commandos and hover above the uninstall icon to see where it is located. And then just delete the whole folder under the Installshield Installation Information folder. After that, you should be able to reinstall the game and choose where you want the game to install to, and it should work fine:D

26th Oct 2003, 08:08
Yes! You did it!
That works fine for me too!

26th Oct 2003, 21:35
Guys- read my posts. That's what I was trying to tell you.:)

28th Oct 2003, 02:16
To wipe the partially-installed game, you might like to try the following:

0. Use move instead of delete to minimize the risk

1. Run the Uninstall once if you could, this will remove most of system registry.

2. Remove the following hidden directory:
C:\Program Files\InstallShield Installation Information\{C270BC04-1540-4673-960F-A546B2C860CD}\
In most instance, you may be able to restart installation process normally

3. Remove the game directory manually
"C:\Program Files\Eidos\Pyro Studios\"

4. Clean Profile temp directory
"C:\Documents and Settings\(Your login name)\Local Settings\Temp\*.*"

5. Clean your temp directory
Default "C:\TEMP\"

6. Modify the registry as others' comment

7. Wait for official resolution... :D

Pyro Studio could have done better :<